Page 1 of 6 123 ... LastLast
Results 1 to 10 of 58

Thread: Testers needed for PowerPC 14.04

  1. #1
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,111

    Testers needed for PowerPC 14.04

    Release time soon, so why not help out with the testing? A PowerPC ISO will only be released if it is tested and passes all tests. This is a VERY time consuming process, so if you are able to help out I'm sure it would be greatly appreciated by the lubuntu-qa team. Lots of info about testing in the FAQ and Lubuntu wikis.

    Don't assume somebody else is going to do it for you, otherwise you might be in for a shock (kubuntu users?).

    I've updated the "Known Issues" page with the current bugs from the tracker. Most of them are old (and not necessarily powerpc specific). I think there are workarounds for most, although I've yet to try the one for the live installer.

    Please don't spam this thread with waffle. Comments in this thread mean nothing. The release team are only interested in official bug reports and official tracker testing results. Remember to confirm any existing bugs as this adds 'heat' to the bug.

    Please also update the PowerPC Known Issues page with any new bugs/workarounds as it makes life so much easier for the next person.

    If you have a problem that you want help with then RAISE A NEW THREAD.
    Last edited by rsavage; April 4th, 2014 at 12:50 AM.

  2. #2
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,111

    Re: Testers needed for PowerPC 14.04

    Live installer is not working. Please can people have a go?

  3. #3
    Join Date
    Sep 2006
    Beans
    8,627
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Testers needed for PowerPC 14.04

    Quote Originally Posted by rsavage View Post
    Live installer is not working. Please can people have a go?
    There are several bugs to that effect since Nov / Dec 2013. Someone with good Python skills or, better, familiarity with Ubiquity would be of great help.

  4. #4
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,111

    Re: Testers needed for PowerPC 14.04

    I just got the live installer to work. Don't know as yet whether it was a fluke. Try purging (remove doesn't seem to be enough) the slideshow package.

  5. #5
    Join Date
    Aug 2010
    Location
    Munich, Germany
    Beans
    365

    Re: Testers needed for PowerPC 14.04

    Attachment 251357 Attachment 251358

    Hi All,

    The NG Amiga users test a lot the development branch of Lubuntu 14.04 PowerPC. And it works very well on the Sams PowerPC and AmigaOne X1000 PowerPC machines.

    http://forum.hyperion-entertainment....=2177&start=30

    http://forum.hyperion-entertainment....hp?f=35&t=2176

    Screenshots:

    http://www.supertuxkart-amiga.de/ami...3_A1-X1000.jpg (Lubuntu 14.04 on an AmigaOne X1000 with the kernel 3.13.0)
    http://forum.hyperion-entertainment....ile.php?id=807 (Lubuntu 14.04 on an AmigaOne X1000 with the unofficial Mesa 10.0.3 and kernel 3.14-rc4)
    http://forum.hyperion-entertainment....ile.php?id=857 (Lubuntu 14.04 on an AmigaOne X1000 with the unofficial Mesa 10.1.0 and kernel 3.14-rc6)
    http://forum.hyperion-entertainment....ile.php?id=858 (Lubuntu 14.04 on an AmigaOne X1000)
    http://forum.hyperion-entertainment....ile.php?id=688 (Lubuntu 14.04 on an AmigaOne X1000 with the kernel 3.13-rc8)
    http://forum.hyperion-entertainment....ile.php?id=751 (Lubuntu 14.04 on an AmigaOne X1000 with the kernel 3.13.1)
    http://forum.hyperion-entertainment....ile.php?id=679 (Lubuntu 14.04 on an AmigaOne X1000 with the wrong colors issue)
    http://forum.hyperion-entertainment....ile.php?id=763 (Lubuntu 14.04 on a Sam440ep Flex with the kernel 3.14-rc1)
    http://forum.hyperion-entertainment....ile.php?id=754 (Lubuntu 14.04 on a Sam440ep Flex with MPlayer and the kernel 3.13.1)
    http://forum.hyperion-entertainment....ile.php?id=712 (Lubuntu 14.04 on a Sam440ep Flex with the kernel 3.13.0)
    http://forum.hyperion-entertainment....ile.php?id=875 (Lubuntu 14.04 on a Sam440ep Flex with the kernel 3.14-rc7)
    http://forum.hyperion-entertainment....ile.php?id=801 (Lubuntu 14.04 on a Sam460ex with kernel 3.14-rc4)


    But there are two main issues. Mesa issued false colors in games. They appear to be ABGR instead of RGBA, thus green becomes purple, red becomes light blue etc. I've created a bug report on freedesktop.org. Bug report 72877: https://bugs.freedesktop.org/show_bug.cgi?id=72877 and http://lists.freedesktop.org/archive...er/050363.html. I also created a bug report on bugs.launchpad.net. Bug report #1275042: https://bugs.launchpad.net/ubuntu/+s...a/+bug/1275042. Additional I have posted the bug on the Mesa dev mailing list: http://lists.freedesktop.org/archive...ch/055510.html. I have figured out what the problem is and I have fixed the problem in the MesaLib source code. More on http://forum.hyperion-entertainment....&t=2137#p23996. I have released some unofficial Mesa packages. Downloads: http://www.supertuxkart-amiga.de/ami...nofficial.html.

    The x server has not been configured automatically on Lubuntu 14.04. You have to create manually a xorg.conf file. For example my xorg.conf file as attachement. I had the problem that the fonts were not displayed. The solution is to set the option "RenderAccel" to "false" in the xorg.conf file.

    My xorg.conf file: http://forum.hyperion-entertainment....ile.php?id=711

    We test Lubuntu 14.04 with some vanilla kernels and ported Ubuntu kernels. Kernels: http://www.supertuxkart-amiga.de/ami...html#downloads and http://www.supertuxkart-amiga.de/ami...html#downloads. For OpenGL and sound tests we use a special AltiVec version of SuperTuxKart 0.8.1. There is also a SuperTuxKart 0.8.1 without AltiVec available.

    We have created some bug reports on bugs.launchpad.net.

    Bug reports:

    Python error after desktop start: https://bugs.launchpad.net/ubuntu/+s...7/+bug/1288207
    ibus-ui-gtk3 crashed with SIGABRT in g_assertion_message(): https://bugs.launchpad.net/ubuntu/+s...s/+bug/1274897
    midori crashed with SIGSEGV in JSC::LLInt::CLoop::execute(): https://bugs.launchpad.net/ubuntu/+s...i/+bug/1274167


    Thank you very much to the developers of Lubuntu 14.04 PowerPC. You're doing a great job.

    Rgds,
    Christian
    Last edited by xeno74; April 5th, 2014 at 11:14 AM.

  6. #6
    Join Date
    Aug 2010
    Location
    Munich, Germany
    Beans
    365

    Re: Testers needed for PowerPC 14.04

    I have edited the page PowerPCKnownIssues. I have added some bugs and solutions. And I have added the AmigaOne X1000 PowerPC computer and the Sam440ep Flex PowerPC computer to the HardWare page.

  7. #7
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,111

    Re: Testers needed for PowerPC 14.04

    Thanks Christian.

    I haven't hit the python error. Is it still there?

    Other architectures seem to have reported a similar ibus error so that is probably not PowerPC specific. Again I haven't hit it.

    I commented on your midori bug. If you follow the link there maybe a patch for you to try.

    Have you got a bug report regarding the font issue? It sounds very much like this old problem https://bugs.debian.org/cgi-bin/bugr...cgi?bug=702480 so is this a regression? [EDIT: that bug seemed to be on UMS https://bugs.freedesktop.org/show_bug.cgi?id=57649 ]

    I can't get Radeon KMS to work at all (but that might be my computer as it is very very random at starting).
    Last edited by rsavage; April 5th, 2014 at 05:46 PM.

  8. #8
    Join Date
    Aug 2010
    Location
    Munich, Germany
    Beans
    365

    Re: Testers needed for PowerPC 14.04

    Quote Originally Posted by rsavage View Post
    Thanks Christian.

    I haven't hit the python error. Is it still there?
    Not at the moment.

    Quote Originally Posted by rsavage View Post
    I commented on your midori bug. If you follow the link there maybe a patch for you to try.
    Thank you.

    Quote Originally Posted by rsavage View Post
    Have you got a bug report regarding the font issue?
    No, I haven't created a bug report yet. Shall I create a new bug report for Lubuntu?

  9. #9
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,111

    Re: Testers needed for PowerPC 14.04

    Quote Originally Posted by xeno74 View Post
    No, I haven't created a bug report yet. Shall I create a new bug report for Lubuntu?
    I would create one on the freedesktop site and see if you can get the attention of one of the radeon developers. If through that a patch is produced, then I would raise an SRU on launchpad (I think that is how you do it) and ask that it is added to (L)ubuntu 14.04.

  10. #10
    rsavage is offline Iced Almond Soy Ubuntu, No Foam
    Join Date
    Jan 2011
    Beans
    1,111

    Re: Testers needed for PowerPC 14.04

    Also, that maybe of interest to you, I've seen a few mentions that 3d is not working in 32 bit e.g. https://lists.debian.org/debian-powe.../msg00035.html . Don't know if this applies to Trusty.

Page 1 of 6 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •