I find that using either the standard GNOME DE (gnome-shell) or the new GNOME Classic sessions that even when the screen-lock is set to off the user must press Esc to exit the screensaver.

Is there a setting to change this behavior so just mouse movement wakes the screen?