Results 1 to 9 of 9

Thread: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

  1. #1
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Trusty Tahr, fully updated (2014-03-30)

    With any sudo-command where the su password is needed (so: in a new terminal tab or after x minutes), I get:

    Code:
    no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
    When I Google that, there is one set of bug reports, related to Samba.

    Tips?

    Examples:

    Code:
    sander@flappie:~$ sudo whoami
    [sudo] password for sander: 
    no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
    root
    sander@flappie:~$
    Code:
    sander@flappie:~$ sudo uptime
    [sudo] password for sander: 
    no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
     10:34:44 up 46 min,  6 users,  load average: 0,24, 0,52, 0,39
    sander@flappie:~$
    Code:
    sander@flappie:~$ sudo ls bl*
    [sudo] password for sander: 
    no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
    blabla	blablabla.planner  blabla.c  blabla.c~	blabla.par
    sander@flappie:~$
    Last edited by sanderj; March 30th, 2014 at 09:35 AM.

  2. #2
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Code:
    bapoumba_lxde@SonyBlue:~$ whoami
    bapoumba_lxde
    bapoumba_lxde@SonyBlue:~$ sudo whoami
    [sudo] password for bapoumba_lxde: 
    root
    bapoumba_lxde@SonyBlue:~$ apt-cache policy samba
    samba:
      Installed: (none)
      Candidate: 2:4.1.3+dfsg-2ubuntu4
      Version table:
         2:4.1.3+dfsg-2ubuntu4 0
            500 http://archive.ubuntu.com/ubuntu/ trusty/main i386 Packages
    Do you have samba installed ?
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  3. #3
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Yes, I have Samba installed and running.

    Code:
    sander@flappie:~$ apt-cache policy samba
    samba:
      Installed: 2:4.1.3+dfsg-2ubuntu4
      Candidate: 2:4.1.3+dfsg-2ubuntu4
      Version table:
     *** 2:4.1.3+dfsg-2ubuntu4 0
            500 http://nl.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
            100 /var/lib/dpkg/status
    sander@flappie:~$
    So it is samba related?

  4. #4
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Looks like..
    I have removed a duplicate post of the one just above mine.
    I did get to the same bug reports you found, but did not find a workaround or a fix in any of them. I'll have a closer look.
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  5. #5
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    9,525
    Distro
    Ubuntu

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Quote Originally Posted by bapoumba View Post
    Looks like..
    I have removed a duplicate post of the one just above mine.
    I wondered why my posting was blocked, timing, huh?
    (I seeming posted at the same time as the mod action)

    That said, my post was asking if this was a fresh install or an upgrade from saucy?
    I had this problem from an upgrade, and seemed to have marked that bug as affecting me.
    (I don't remember doing so, and thought it was for sudo)
    Don't know if it fixed, since that install is gone now.

    Haven't seen it with a fresh install, though.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  6. #6
    Join Date
    Sep 2006
    Location
    France.
    Beans
    Hidden!
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Quote Originally Posted by deadflowr View Post
    I wondered why my posting was blocked, timing, huh?
    (I seeming posted at the same time as the mod action)
    Sometimes pages take a long time to load. If you open the same thread in another tab, you may see your post has already gone through..
    | My old and mostly abandoned blog |
    Linux user #413984 ; Ubuntu user #178
    J'aime les fraises.
    Nighty night me lovelies!

    | Reinstalling Ubuntu ? Please check this bug first ! |
    | Using a ppa ? Please install ppa-purge from universe, you may need it should you want to revert packages back |
    | No support requests / username changes by PM, thanks. |
    [SIGPIC][/SIGPIC]

  7. #7
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    I removed samba & smbclient, did a reboot, but the error message is still there.

    Based on https://bugzilla.samba.org/show_bug.cgi?id=10420, I removed "pam_smbpass.so" from /etc/pam.d/common-password, did a reboot, but the error message is still there.

    FWIW: my 14.04 is an upgraded 13.10.

    EDIT: I also removed samba-common-bin and smbc, but still get the same error message with sudo. So I would say samba is now not installed anymore, but I still get the error message.
    Last edited by sanderj; March 30th, 2014 at 09:48 PM.

  8. #8
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Ah, seems to be gone after

    Code:
    sudo apt-get remove libpam-smbpass
    Based on https://bugs.launchpad.net/ubuntu/+s...a/+bug/1257186 (and it's dupe https://bugs.launchpad.net/ubuntu/+s...o/+bug/1274680)

    EDIT:

    FYI: "the libpam-smbpass package will sync system users and passwords with the Samba user database."
    Last edited by sanderj; March 30th, 2014 at 11:15 PM.

  9. #9
    Join Date
    Sep 2012
    Beans
    1

    Re: "no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory"

    Quote Originally Posted by sanderj View Post
    Ah, seems to be gone after

    Code:
    sudo apt-get remove libpam-smbpass
    Based on https://bugs.launchpad.net/ubuntu/+s...a/+bug/1257186 (and it's dupe https://bugs.launchpad.net/ubuntu/+s...o/+bug/1274680)

    EDIT:

    FYI: "the libpam-smbpass package will sync system users and passwords with the Samba user database."
    You can also fix this issue while keeping libpam-smbpass installed by running "pam-auth-update" and remove "SMB password synchronization". Got that solution from Thomas (reusch) on https://bugs.launchpad.net/ubuntu/+s...a/+bug/1257186

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •