Results 1 to 6 of 6

Thread: 14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black screen

  1. #1
    Join Date
    Jul 2013
    Beans
    50

    14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black screen

    16GB Ram
    2 TB sata
    nvidia gtx 650 card
    amd 8350fx cpu
    asus MB

    Last night everything on 14.04 beta was working fine

    Booted computer today logged in as normal.

    Next I did my daily:
    sudo apt-get update && sudo apt-get upgrade -y

    After update/upgrade I rebooted.

    System came up with a weird look to the login screen, very dark, top menu bar items (time, shutdown etc are almost invisible).

    Enter my password.... screen goes blank and a mouse cursor appears and that is all that happens... mostly a Black Looking screen with a mouse cursor I can move.

    I have to hit Ctrl-Alt-F1 to get to a command prompt & terminal in order to do anything.

    I know there was supposed to be 2 updates (1 for borderless menu's) and the other something about a new lock screen. Not sure if those are having any bad side affects for my machine or not.

    Just for kicks I purged lightdm, ubuntu-desktop and reinstalled both of them... no change so I am not sure what to check next at this point.

  2. #2
    Join Date
    Jun 2005
    Beans
    Hidden!

    Re: 14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black sc

    Quote Originally Posted by bmullan2 View Post
    16GB Ram
    2 TB sata
    nvidia gtx 650 card
    amd 8350fx cpu
    asus MB

    Next I did my daily:
    sudo apt-get update && sudo apt-get upgrade -y

    After update/upgrade I rebooted..
    By any chance did you also run
    Code:
    sudo apt-get dist-upgrade
    Pulls in other things needed.

  3. #3
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black sc

    WHich nvidia driver are you using? Nouveau, or one of the closed source binaries?

  4. #4
    Join Date
    Jul 2013
    Beans
    50

    Re: 14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black sc

    yes

    on this system I did have 13.10 running and did

    sudo apt-get update && sudo apt-get upgrade -y
    # not sure of both below were needed..
    sudo apt-get dist-upgrade
    sudo apt-get do-release-upgrade -d

    as initial post said...

    the system worked night before. shut it down, next morning reboot, login then
    run sudo apt-get update && sudo apt-get upgrade -y and there were alot of updates! After the updates were installed I rebooted into the state I am in.

    when I get to the blank/black screen with the mouse cursor phase... going to a terminal via Ctrl-Alt-F1 I can login as myself again, run "startx"... and although I do NOT get my full normal ubuntu unity desktop.. I do see the launcher ICONs from my old desktop.

    Using those launchers I can start things like Firefox, terminal etc. But in general the desktop environment is gone... no panels, no command bar on left etc.

  5. #5
    Join Date
    Jul 2013
    Beans
    50

    Re: 14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black sc

    using default nvidia driver -- Nouveau .

    However, for my nvidia gtx 650 card I also tried xorg-edgers installing nvidia-331 which "ubuntu" recommends as a driver for my system from running:

    ubuntu-drivers devices | grep recommended

    Note: the above cmd (uses Xorg Edgers PPA) was covered in Section 3 of this great writeup on ubuntu/video: http://askubuntu.com/questions/61396...a-drivers?rq=1

    However, in both cases the system looks the same on boot.

    I know there are no hardware problems as I can boot on other disks an run ubuntu, windows etc.
    Last edited by bmullan2; March 14th, 2014 at 12:35 PM.

  6. #6
    Join Date
    Jul 2013
    Beans
    50

    Re: 14.04 beta, nvidia, amd, apt-get upgrade now NO Desktop after login just black sc

    Issue Resolved...

    Because Ubuntu 14.04 is still beta I decided I wasn't going to beat a dead horse, so I just reinstalled using latest Daily build and everything is working again.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •