I recently installed the latest daily build (PC (Intel x86) desktop image) of Trusty from here: http://cdimage.ubuntu.com/daily-live/current/

Ubuntu works perfectly! I decided to try out ubuntu touch using the ubuntu-emulator to see if I like it. Eventually I will use this to make and test ubuntu apps.

I ran these commands to install, create and run ubuntu-emulator:

sudo apt-get install ubuntu-emulator
sudo ubuntu-emulator create myinstance
ubuntu-emulator run myinstance

The first two worked fine and when I ran the third, a virtual phone appeared however the virtual screen was blank. I waited and waited, but nothing happened, the screen remained blank/black (on the virtual phone). Then I notice I have to log in terminal. I entered phablet then phablet and logged in fine.

Now I have the terminal logged in and a virtual kernel of the phone but the screen is blank. How can I start the graphics?

Also, once I've got the screen working, can I reduce the window size (it doesn't all fit on one desktop)?
Thanks! -Zach