Results 1 to 4 of 4

Thread: Upstart ignores /etc/init

  1. #1
    Join Date
    Jun 2010

    Upstart ignores /etc/init


    I had my first encounter with upstart when I tried to just stop NetworkManager. My understanding is that I should just do

    stop network-manager

    as root and that should do the job. However I only get "stop: Unknown Instance: network-manager" (I can only guess that this is the translation because initctl ignores the LC_ALL, LANG, LANGUAGE variables). In fact it seems that the only services upstart seems to know are the old system v scripts in /etc/init.d. The config files in /etc/init are completely ignored. Can somebody explain this behavoir to me? (I am running Ubuntu 13.10 btw.) Thanks a lot!
    Also concrete help on how to stop NetworkManager would be appreciated. Of course I tried just killing it but then it is restarted.

    Last edited by switzel; March 3rd, 2014 at 09:46 PM. Reason: fixed typo

  2. #2
    Join Date
    Jul 2013

    Re: Upstart ignores /etc/init

    Network Manager is a system service. You must use sudo when you stop it.

    See for yourself. Look at the output difference:
    initctl list
    sudo initctl list

    EDIT: This assumes, of course, that you are logged in as yourself. If you are logged in as root, the output should be identical.
    Last edited by ian-weisser; March 6th, 2014 at 05:42 PM.

  3. #3
    Join Date
    Jun 2010

    Re: Upstart ignores /etc/init

    That's surprising. What is the difference between being root and using sudo? And what's the point? I have the habit of doing su for administrative purposes so it seems strange to do sudo as root.

  4. #4
    Join Date
    Apr 2011
    Mystletainn Kick!

    Re: Upstart ignores /etc/init

    sudo is a one time event, per a command.
    (though you can set it to run interactively)
    root is forever, in which every action is a root action.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts