Results 1 to 2 of 2

Thread: Unable to install GRUB on software RAID

  1. #1
    Join Date
    Feb 2014

    Unable to install GRUB on software RAID

    Hi All,

    I'm absolutely new to Linux, trying to install Ubuntu 13.10 from a CD onto a Dell Dimension 9200 to replace Windows XP. Everything goes fine until I get a message saying "Unable to install GRUB in /dev/sda: Executing 'grub-install/dev/sda' failed. This is a fatal error."

    I've tried installing GRUB on each of the other alternatives it then offers, with no success. I've tried Boot-repair, which makes some changes ( & 6993758) but still leaves the machine unable to boot. And running ls /dev/m* from the terminal window left me no wiser about where to install the GRUB.

    I've got no need to keep a dual boot with Windows, as I'm trying to convert to Ubuntu. I think the problem may be that the hard disk is actually two 149 GB drives configured as a RAID0 with fakeRAID or software RAID (most likely the latter if I understand correctly, but I'm not even sure how to tell reliably). If it is, I know there are many posts about this type of thing, but the problem is that they don't all seem to agree and most of them suggest solutions I simply have no idea how to do yet.

    Any help would be very much appreciated!

    Thanks a lot, Nick

  2. #2
    cprofitt's Avatar
    cprofitt is offline νόησις νοήσεως - nóesis noéseos
    Join Date
    Oct 2006
    Ubuntu Development Release

    Re: Unable to install GRUB on software RAID

    Can you undo the raid?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts