Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

  1. #1
    Join Date
    Dec 2006
    Beans
    Hidden!

    pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    Just will not keep the display for the PC as primary.
    No matter what I manipulate in nvidia-settings, on a reboot, it is all gone.
    I even compared xorg.conf in etc with that generated by nvidia-settings and they are the same.

    from nvidia-settings
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 331.38  (buildd@louvi)  Tue Jan 14 12:02:31 UTC 2014
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: xconfig, VertRefresh source: xconfig
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "TV-0"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "TV-0: nvidia-auto-select +1680+0, DVI-I-1: nvidia-auto-select +0+0"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    from xorg.conf
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 331.38  (buildd@louvi)  Tue Jan 14 12:02:31 UTC 2014
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: xconfig, VertRefresh source: xconfig
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "TV-0"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8400 GS"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "nvidiaXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "TV-0: nvidia-auto-select +1680+0, DVI-I-1: nvidia-auto-select +0+0"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  2. #2
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    To clarify the situation
    This worked in 12.04.

    I have a flat screen monitor
    I have an old style large crt TV

    I want the TV to be at the right and the LCD monitor on the left
    I make changes in nvidia-settings and save to xorg.conf.

    On a reboot, the crt TV always comes up on the left and the LCD monitor on the right.

    I have also manually copied the xorg.conf that nvidia-settings generates into the xorg.conf file.

    Either ubuntu is not loading xorg.conf or it is not being made properly by nvidia-settings.

    xorg.conf looks different, seems to be missing the DFP-0 monitor settings?

  3. #3
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    With nvidia-settings, I moved the tv over to left
    and previewing shows it does generate a different xorg.conf

    So I dont know enough to say what is wrong.
    Ideas?
    In the Monitor section, I only see the TV-0, not DFP-0

    [CODE][# nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 331.38 (buildd@louvi) Tue Jan 14 12:02:31 UTC 2014


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    EndSection

    Section "Files"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"

    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "TV-0"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8400 GS"
    EndSection

    Section "Screen"

    # Removed Option "metamodes" "TV-0: nvidia-auto-select +1680+0, DVI-I-1: nvidia-auto-select +0+0"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "Stereo" "0"
    Option "nvidiaXineramaInfoOrder" "DFP-0"
    Option "metamodes" "TV-0: nvidia-auto-select +0+0, DVI-I-1: nvidia-auto-select +1024+0"
    Option "SLI" "Off"
    Option "MultiGPU" "Off"
    Option "BaseMosaic" "off"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

    /CODE]

  4. #4
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    On reboot, TV always is on the left side.
    So to fix, I unpluged the cable!
    Aynyone have a better fix?
    Attached Images Attached Images

  5. #5
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    I think xorg.cong is ignored
    I made some bigger changes and get no response.

    Is this due to beta status?

    Code:
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "metamodes" "TV-0: 1024x768, DVI-I-1: 1680x1050"
        Option         "TwinViewOrientation" "RightOf"
        Option         "SLI" "Off"
        Option         "MultiGPU" "Off"
        Option         "BaseMosaic" "off"
        SubSection     "Display"
            Depth       24
        EndSubSection

  6. #6
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    Well apparently Display program in Ubuntu settings in Ubuntu overrides Nvidia-settings display orientation position.

    Is that to be expected?

  7. #7
    Join Date
    Jan 2013
    Location
    Riga, Latvia
    Beans
    114
    Distro
    Ubuntu Development Release

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    Quote Originally Posted by sdowney717 View Post
    Well apparently Display program in Ubuntu settings in Ubuntu overrides Nvidia-settings display orientation position.

    Is that to be expected?
    I would say yes. If you have time and want to experiment than you could try following steps:
    1) Login
    2) Use nvidia-settings to set up montiors
    3) Delete ~/.config/monitors.xml
    4) Reboot

    Next time you login new ~/.config/monitors.xml file will be generated. It might now contain correct configuration. I have not tested this!

  8. #8
    Join Date
    Nov 2009
    Beans
    3,225

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    The main problem is that the programmers have not identified what is creating the xorg.conf .......

    A simple commented line in the xorg.conf showing what has created it would help to identify what is creating
    these automatically placed configs into place. ( xorg.conf ) was always a help - but when the system keeps creating it wrong then it soon becomes a pain.

    https://www.google.co.uk/search?clie...CgBQ&gws_rd=cr


    ( a few days back I identified that nvidia-prime was one culprit for my own setup ......... if you have this installed - it may be worth removing it to see if the problem still exists ........... seems it is only required for optimus setups ......... which is ( intel and nvidia combined in laptops for battery/power saving which is what I have - but I think you have a desktop machine with a nvidia 8400 gs ) so that file is not needed if it is there.


    Seems you have another thread on a similar subject and solved it here
    http://ubuntuforums.org/showthread.php?t=2207389
    Last edited by 23dornot23d; February 23rd, 2014 at 07:15 PM.

  9. #9
    Join Date
    Oct 2010
    Beans
    261

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    Am I the only wondering why nvidia-settings has created his xorg.conf while it shouldn't be responsible for doing this? Normally nvidia-xconfig is creating the xorg.conf.

  10. #10
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: pretty serious bug in nvidia-settings with nvidia driver and monitors and TV

    He is probably using the Save to X Configuration File button.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •