Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Suddenly Slow Wireless - Intel Centrino N 6235

  1. #11
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136

    Re: Suddenly Slow Wireless - Intel Centrino N 6235

    Please try "bt_coex_active=N" and "swcrypto=1" parameters as suggested in the link I posted earlier.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  2. #12
    Join Date
    Sep 2009
    Location
    Netherlands
    Beans
    115
    Distro
    Kubuntu 14.04 Trusty Tahr

    Post Re: Suddenly Slow Wireless - Intel Centrino N 6235

    Frankie, you are running a newer kernel than OP, I think you have different issues. At some point (Linux v3.13-10103-g205e221, will end up in 3.14 and newer), AMPDU was disabled for iwldvm devices ("iwlwifi: disable TX AMPDU by default for iwldvm"). For me, that caused a performance drop from about 80 Mbit/s to about 20 Mbit/s (measured with iperf).

    Saucy users are affected if they have upgraded their kernel to at least 3.11.10.8: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1311196
    I couldn't find if 3.13 are affected, but if Ubuntu patched their kernel to include this change, then you will also need to apply the below configuration.

    To test whether you are affected, check whether you are actually using the iwldvm module (and not iwlmvm):
    Code:
    $ lsmod | grep iwlwifi
    iwlwifi               178135  1 iwldvm
    cfg80211              521351  3 iwlwifi,mac80211,iwldvm
    If you are indeed using iwldvm, is your module affected? Affected kernels will have a bitmap option with option 8:
    Code:
    $ modinfo iwlwifi  | grep 11n_disable
    parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
    To restore previous behavior (and alleviate the performance regression), create /etc/modprobe.d/iwlwifi.conf (exact filename does not matter, you could also chose modprobe.conf if you would like) containing options iwlwifi 11n_disable=8. Or, if you do not know what I am talking about, just run the command:
    Code:
    echo options iwlwifi 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi.conf
    Reload the module (sudo modprobe -vr iwldvm iwlwifi && sudo modprobe -v iwlwifi) or reboot.

  3. #13
    Join Date
    May 2014
    Beans
    1

    Re: Suddenly Slow Wireless - Intel Centrino N 6235

    Quote Originally Posted by Lekensteyn View Post
    Frankie, you are running a newer kernel than OP, I think you have different issues. At some point (Linux v3.13-10103-g205e221, will end up in 3.14 and newer), AMPDU was disabled for iwldvm devices ("iwlwifi: disable TX AMPDU by default for iwldvm"). For me, that caused a performance drop from about 80 Mbit/s to about 20 Mbit/s (measured with iperf).

    Saucy users are affected if they have upgraded their kernel to at least 3.11.10.8: https://bugs.launchpad.net/ubuntu/+s...x/+bug/1311196
    I couldn't find if 3.13 are affected, but if Ubuntu patched their kernel to include this change, then you will also need to apply the below configuration.

    To test whether you are affected, check whether you are actually using the iwldvm module (and not iwlmvm):
    Code:
    $ lsmod | grep iwlwifi
    iwlwifi               178135  1 iwldvm
    cfg80211              521351  3 iwlwifi,mac80211,iwldvm
    If you are indeed using iwldvm, is your module affected? Affected kernels will have a bitmap option with option 8:
    Code:
    $ modinfo iwlwifi  | grep 11n_disable
    parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
    To restore previous behavior (and alleviate the performance regression), create /etc/modprobe.d/iwlwifi.conf (exact filename does not matter, you could also chose modprobe.conf if you would like) containing options iwlwifi 11n_disable=8. Or, if you do not know what I am talking about, just run the command:
    Code:
    echo options iwlwifi 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi.conf
    Reload the module (sudo modprobe -vr iwldvm iwlwifi && sudo modprobe -v iwlwifi) or reboot.

    Thanks. This really helped. I have a dual boot system, and windows' speedtest results were almost twice as fast for me. I could hit 100Mbps on windows, but would stay at 60ish on ubuntu. I don't know if this will affect the stability, but I'm glad I found this. Also, it's particularly difficult to find information like this because there are a large no. of posts recommending 11n_disable=1. I guess most people are limited by their ISP's bandwidth and hence don't notice this.

  4. #14
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136

    Re: Suddenly Slow Wireless - Intel Centrino N 6235

    Quote Originally Posted by finknottle2 View Post
    Also, it's particularly difficult to find information like this because there are a large no. of posts recommending 11n_disable=1.
    That's because most of the posts were written before the additional values (other than 0 and 1) were introduced in the driver. And even the current posts often suggest that because most of them are copied suggestions, not from someone who notices the changes and likes tinkering (even I missed those additional values for quite some time, despite my curious nature).

    But above all, cooperation and confirmations from users like you are vital, because we usually have no other way to know what is helpful and what is not. So.. a big thanks for your feedback!
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #15
    Join Date
    Apr 2011
    Beans
    26

    Re: Suddenly Slow Wireless - Intel Centrino N 6235

    Above 11n_disable=8 cured my issue too on Centrino 2230 / Ubuntu 14.04. Now it at least just and just matches what Win7 gives me as downstream, 70-80Mbps (still not near the maximum I get from a wired connection, but I guess that's up to the crappy router throughput or then this card is simply weak on Windows too). Without this trick downstream is maximum 30-40 Mbps. I knew there was something going on because Fedora 20 gave better results (Fedora / 3.11.10-301.fc20.x86_64, Ubuntu / 3.13.0-32-generic, same firmware: 18.168.6.1)

    On the other hand, additionally bt_coex_active=N seemed to lower the downstream again below 40 Mbps and first when I tried that together with swcrypto=1, downstream was below 20Mbps. Not sure what was up with that, because swcrypto=1 alone didn't make a difference.

    130Mbps is the maximum connection speed I get (on Windows too, again my router is probably the reason), on 802.11n, altough on Ubuntu it seems to usually drop to 64-78 Mbps.

    * Downstream = repeated speedtest.net tests, always same server.
    Last edited by Paper Bag; September 6th, 2014 at 12:35 AM.

  6. #16
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,136

    Re: Suddenly Slow Wireless - Intel Centrino N 6235

    Thanks for the detailed feedback Paper Bag, much appreciated!

    The bt_coex_active=N parameters disables an advanced technique in the driver that tries to let both bluetooth and wifi signals work simultaneously without interfering with each other. I don't know exactly how it is implemented, but sometimes that added complexity to the wifi communication method causes troubles. Although obviously it is developed to actually 'help' in a particular situation.

    So my guess is that either the technique has just matured in current drivers, or that you are using bluetooth simultaneously (on this very same laptop, or on other devices around) which starts interfering with the wifi signal with this feature disabled, thus resulting in bad quality signal and lower speeds.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •