Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Cannot copy-paste in new EXT4 partitions

  1. #1
    Join Date
    Aug 2010
    Beans
    31

    Question Cannot copy-paste in new EXT4 partitions

    Hi,

    I'm using Ubuntu 12.04 32bit and I just upgraded my PC with a new HDD. Therefore I have 2 new EXT4 partitions (900 GB and 650 GB). The thing is that I cannot copy-paste anything into them, unless I access Nautilus via terminal (I use the command "sudo nautilus"). I don't know if it matters but when I check the properties of the partitions, in the Permissions tab it is written: "You are not the owner, so you cannot change these permissions". If I convert the partitions to NTFS it's all fine, but I would like them to be EXT4. Could you please help me?

    Thank you,
    Alex

  2. #2
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 17.10 Artful Aardvark

    Re: Cannot copy-paste in new EXT4 partitions

    You can take ownership of an ext4 partition with
    Code:
    sudo chown -R user:user /media/sdb2/
    You'll need to change "user" to your user name and the mount point to wherever the partition's mounted.

  3. #3
    Join Date
    Jul 2005
    Location
    I think I'm here! Maybe?
    Beans
    Hidden!

    Re: Cannot copy-paste in new EXT4 partitions

    To avoid confusion I suggest you use gparted to give a meaningful label to the partition on this new disk as it will then mount to that named folder in /media/user/label.

    Just my opinion, but I recall partitions mounting to /media/0707fdc8-1299-4c11-9f93-8158d3c313d0 (ie the UUID of the partition) in previous systems I ran
    DISTRO: Xubuntu 16.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo --- Wireless-Info --- SolvedThreads

  4. #4
    Join Date
    Aug 2010
    Beans
    31

    Thumbs up Re: Cannot copy-paste in new EXT4 partitions

    @oldos2er: thank you very much, that did the trick! Now everything is fine
    @ajgreeny: thank you also, yours is a very good tip. In my case the partitions were already labelled, so it was easy

  5. #5
    Join Date
    Aug 2010
    Beans
    31

    Re: Cannot copy-paste in new EXT4 partitions

    Hi all,
    I have recently installed Storage Device Manager in order to have all HDD's boot at startup. But after this operation I again cannot copy anything on certain HDD's. I have tried to use the command you suggested (sudo chown -R user:user /media/sdb2/) but I get the answer "Read-only file system". The full reply in the terminal is:

    chown: changing ownership of `/media/Usa/$RECYCLE.BIN/S-1-5-21-1569345450-1471465237-1804068876-1000/desktop.ini': Read-only file system
    chown: changing ownership of `/media/Usa/$RECYCLE.BIN/S-1-5-21-1569345450-1471465237-1804068876-1000': Read-only file system
    chown: changing ownership of `/media/Usa/$RECYCLE.BIN': Read-only file system
    chown: changing ownership of `/media/Usa/System Volume Information/tracking.log': Read-only file system
    chown: changing ownership of `/media/Usa/System Volume Information': Read-only file system
    chown: changing ownership of `/media/Usa': Read-only file system

    Could you please help me once again?
    Thank you!

  6. #6
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 17.10 Artful Aardvark

    Re: Cannot copy-paste in new EXT4 partitions

    What's the exact package name, and/or executable name? The closest thing I can find is system-storage-manager, which I've never used.

    If you're talking about pysdm, don't use it. It's quite buggy and hasn't been updated in a long time (I'm not even sure it was ever updated to work with ext4).
    Last edited by oldos2er; March 1st, 2014 at 10:41 PM.

  7. #7
    Join Date
    May 2009
    Location
    London
    Beans
    147
    Distro
    Ubuntu

    Re: Cannot copy-paste in new EXT4 partitions

    For what it's worth,
    I had the same problem and found it too difficult to resolve so I copied the files i wanted to transfer on to a 32gb flash drive, then simply transerred them to the empty drive (it's not exactly empty since it has a pristine 14.04 waiting for the tweakin)I just copied into the home folder in the new install, and it worked, I had transferred and gained read and write status.
    wasn't too difficult, maybe a bit long winded,but it worked.

  8. #8
    Join Date
    Aug 2010
    Beans
    31

    Re: Cannot copy-paste in new EXT4 partitions

    @Ann (oldos2er): the package name is indeed pysdm. I uninstalled it and tried again to gain ownership of my partition, but the result is the same as before, I still get the message "Read-only file system". Is there anything I could do?
    @ortermagic: thank you, but the data I have to transfer is much bigger than an USB stick. Nevertheless I have tried what you suggested (copy-pasted a file to an USB stick, then into the home folder, then tried to copy-paste it in the target partition) but it didn't work

  9. #9
    Join Date
    Apr 2012
    Beans
    7,110

    Re: Cannot copy-paste in new EXT4 partitions

    Can you open a terminal (Ctrl-Alt-t) and post the out put of the following commands please?

    Code:
    cat /etc/fstab
    and

    Code:
    mount
    You can copy-paste from the terminal by selecting with the mouse and then hitting Ctrl-Shift-c

  10. #10
    Join Date
    Aug 2010
    Beans
    31

    Re: Cannot copy-paste in new EXT4 partitions

    cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda2 during installation
    UUID=fa2329ae-1868-43ee-a4af-df9296462a73 / ext4 errors=remount-ro 0 1
    # swap was on /dev/sda5 during installation
    UUID=dee7c295-3d73-4a5c-9ac5-148946c2f602 none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    /dev/sdb6 /media/Usa ntfs nls=iso8859-1,ro,umask=000 0 0
    /dev/sdc1 /media/IDE ntfs nls=iso8859-1,ro,umask=000 0 0
    /dev/sdb1 /media/FENICE1 ext4 defaults 0 0
    /dev/sdb5 /media/FENICE2 ext4 defaults 0 0
    /dev/sda4 /media/NTFS ntfs defaults 0 0
    /dev/sdd /media/VERBATIM ntfs defaults 0 0

    mount
    /dev/sda2 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    /dev/sdb6 on /media/Usa type fuseblk (ro,nosuid,nodev,allow_other,default_permissions,b lksize=4096)
    /dev/sdb1 on /media/FENICE1 type ext4 (rw)
    /dev/sdb5 on /media/FENICE2 type ext4 (rw)
    /dev/sda4 on /media/NTFS type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sdd on /media/VERBATIM type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sdc1 on /media/IDE type fuseblk (ro,nosuid,nodev,allow_other,default_permissions,b lksize=4096)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/ale/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=ale)
    /dev/sde1 on /media/disk type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed ,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)


    Thank you

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •