Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: lightdm config files location in 14.04

  1. #1
    Join Date
    Nov 2005
    Beans
    403
    Distro
    Ubuntu Development Release

    lightdm config files location in 14.04

    Hello all,

    Recent (last 6 weeks?) updates to lightdm seem to have changed the location of the lightdm config files. What was in /etc/lightdm/lightdm.conf.d/ has been removed (only .bak files remain); the config now seems to be in /usr/share/lightdm/lightdm.conf.d/

    However, a users.conf file remains in /etc/lightdm/ containing the following:

    Code:
    #
    # User accounts configuration
    #
    # NOTE: If you have AccountsService installed on your system, then LightDM will
    # use this instead and these settings will be ignored
    #
    # minimum-uid = Minimum UID required to be shown in greeter
    # hidden-users = Users that are not shown to the user
    # hidden-shells = Shells that indicate a user cannot login
    #
    [UserAccounts]
    minimum-uid=500
    hidden-users=nobody nobody4 noaccess
    hidden-shells=/bin/false /usr/sbin/nologin
    Meanwhile, /usr/share/lightdm/lightdm.conf.d/ contains the files 50-greeter-wrapper.conf 50-guest-wrapper.conf 50-ubuntu.conf 50-unity-greeter.conf 50-xserver-command.conf.

    Can anyone clarify how things have changed here with lightdm? (Incidentally, what's with the hidden-users nobody nobody4 noaccess?)

    I should add that what I really want to understand is how to redo the tweaks that prevent Guest Session and Remote Login from showing up on the login screen, as the pre-14.04 instructions obviously no longer work with those -- and I'd also like to understand how to enable the unity-system-compositor (merely installing the package doesn't seem to have inserted anything in /usr/share/lightdm/lightdm.conf.d/). But I'd like to understand properly why the location/layout of config files has changed, not just blindly follow a set of instructions on how to get what I want

    Thanks & best wishes,

    -- Joe

  2. #2
    Join Date
    Mar 2010
    Beans
    177
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04

    In Trusty you have to install ubuntu-desktop-mir package which will pull in other necessary packages and setup the XMir.

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04

    With unity-system-compositor and ubuntu-desktop-mir installed I not only get Xmir running but 10-unity-system-compositor.conf in /etc/lightdm/lightdm/lightdm.conf.d and no bak files even as hidden files.

    Everything happens for a reason. I am sure the developers have logical reasons but I am not confident that the normal visitors to this section of the forum can provide any enlightenment. I know that I cannot. I can only guess that it is in preparation for giving 14.04 users the login option of logging in to a Unity 8 preview session running on Mir/Xmir.

    Have you tried adding allow-guest=false to either 50-unity-greeter.conf or 50-ubuntu.conf in /usr/share/lightdm/lighdm.conf? Someone has to be the first to crash and burn. At least the machine will not go up in smoke.

    Regards.

    Edit: No crash and burn. Adding allow-guest=false to /user/share/lightdm/lightdm.conf.d/50-ubuntu.conf removes both Guest Session and Remote Session from the login screen. A perfect 3 point landing for Graham.
    Last edited by grahammechanical; February 15th, 2014 at 04:42 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    8,366
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04

    Quote Originally Posted by grahammechanical View Post
    With unity-system-compositor and ubuntu-desktop-mir installed I not only get Xmir running but 10-unity-system-compositor.conf in /etc/lightdm/lightdm/lightdm.conf.d and no bak files even as hidden files.

    Everything happens for a reason. I am sure the developers have logical reasons but I am not confident that the normal visitors to this section of the forum can provide any enlightenment. I know that I cannot. I can only guess that it is in preparation for giving 14.04 users the login option of logging in to a Unity 8 preview session running on Mir/Xmir.
    Good guess Sooner or later ..
    This is Convergence
    Ubuntu Development Version Testing Blog Remarks
    Running 16.04 on Mobo: MSI model: B85-G41 PC Mate(MS-7850) v: 1.0

  5. #5
    Join Date
    Mar 2010
    Beans
    177
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04

    Look at what just landed as an update in Trusty.

    https://launchpad.net/ubuntu/+source...u-docs/14.04.1

    [ Kevin Godby ] * configure.in, html/Makefile, html/ubuntu.xsl, whats-new.page:
    - Bumped version number to 14.04.
    * Typo on printing-cancel-job.page fixed (LP: #1231655).


    ...


    [ Gunnar Hjalmarsson ]
    * The group "Add & remove software" highlighted on index.page by
    creation of the guide page addremove.page. Related links tweaking.
    * shell-guest-session.page:
    - Added description of how you can disable the guest session

    feature (LP: #1076740).
    * Creation of prefs-language-install.page.
    * keyboard-layouts.page:
    - Rewritten to reflect the "System Settings -> Text Entry" design
    (LP: #1242626).
    * tips-specialchars.page:
    - Sections "Compose key" and "Input methods" removed.
    * debian/control:
    - Bump Standards-Version to 3.9.5.
    * Updated ubuntu-help.pot.

    ...

    -- Gunnar Hjalmarsson <gunnarhj@ubuntu.com> Fri, 14 Feb 2014 18:07:00 +0100
    I only cited the relevant changes but there are more of them. Anyway this is what it says on the mentioned shell-guest-session.page

    Disabling the feature

    If you prefer to not allow guest access to your computer, you can disable the Guest Session feature. To do so, press Ctrl+Alt+T to open a terminal window, and then run this command (it's one long command, even if it may be shown wrapped on the screen - copy and paste to get it right):


    sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'


    The command creates a small configuration file. To re-enable Guest Session, simply remove that file:


    sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf
    Last edited by Mateusz Stachowski; February 15th, 2014 at 09:39 PM.

  6. #6
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04

    Ah! The developer sophisticated method as opposed by my brute forced method of editing 50-ubuntu.conf. Then, again gksu is not installed by default any more. Remember? Anyway, it works and it does not also remove the Remote login option.

    I suppose the way to remove Remote Login would be to create a 50-no-remote.conf file. Only one way to find out.

    Edit: Yes!

    sudo sh -c 'printf "[SeatDefaults]\ngreeter-show-remote-login=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-remote-login.conf'
    Creates the 50-no-remote-login.conf file with

    [SeatsDefault]
    greeter-show-remote-login=false
    And that removes Remote login. I suppose that creating a script is a much better way of doing things than telling to user to edit a really important script.

    Edit: 16/02/2014

    I have modified the command for removing remote login. The earlier command did not work. I was fooled by the delay in Remote login appearing at the login screen.

    Regards.
    Last edited by grahammechanical; February 16th, 2014 at 07:04 PM.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  7. #7
    Join Date
    Apr 2014
    Beans
    1

    Re: lightdm config files location in 14.04

    Quote Originally Posted by grahammechanical View Post

    Have you tried adding allow-guest=false to either 50-unity-greeter.conf or 50-ubuntu.conf in /usr/share/lightdm/lighdm.conf? Someone has to be the first to crash and burn. At least the machine will not go up in smoke.

    Regards.
    .
    Hi guys

    I was curious. I did it. I added allow-guest=false in the lightdm.conf
    Whatever the place I chose to put it in the file, whatever I created a dedicated section with brackets as done in the previous versions of Ubuntu, only one thing happened to me : Lightdm did not start and I had to take out the added line in order things to get well again.

    Cheers

  8. #8
    Join Date
    Apr 2014
    Beans
    4

    Re: lightdm config files location in 14.04

    Hi

    Fine that some here sorted out their specific problems. But can anyone please try answering the thread-opener's question:
    "Where have the config files gone?"

    Precisely for my purposes: Where can I change the theme light dm will use, since there is no lightdm.conf anymore?

    Even more precisely: How can I get rid that light dm greeter that got installed by the xubuntu-desktop metapackage, and which apparently does not only make the login screen ugly, but also somehow covers the desktop background on all other installed gtk based DEs (Unity, gnome) AFTER login. Simply removing the xfce light dm theme will only cause light dm to have NO configuration.
    Last edited by QIII; April 25th, 2014 at 08:31 PM. Reason: corrected some unfortunate typos

  9. #9
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    4,502
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04

    Apart from the (unusual for this place) tone of Your message, the answer is given in the thread: /usr/share/lightdm/lightdm.conf.d/
    For example, You can make Your own files in that folder and control what You've used to control from previous default location...
    Code:
    cat  /usr/share/lightdm/lightdm.conf.d/50-неко_име.conf 
    [SeatDefaults]
    autologin-user=неко
    allow-guest=false
    greeter-show-remote-login=false
    Simply put: (kind of) forget about /etc/lightdm folder or think about it as a wrong place to put anything You plan to use later and that should work... One word: depreciated...
    Last edited by zika; April 25th, 2014 at 05:34 PM.

  10. #10
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    8,366
    Distro
    Ubuntu Development Release

    Re: lightdm config files location in 14.04


    Precisely for my purposes: Where can I change the theme light dm will use, since there is no lightdm.conf anymore?


    Here..

    Keep in mind this is a Utopic convert..on xorg. (no xmir installed).
    Attached Images Attached Images
    Last edited by ventrical; April 25th, 2014 at 05:17 PM.
    This is Convergence
    Ubuntu Development Version Testing Blog Remarks
    Running 16.04 on Mobo: MSI model: B85-G41 PC Mate(MS-7850) v: 1.0

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •