I've been using ubuntu for a long time.
It's powered with core i7 processor, 8GB RAM, and ATI Radeon HD 5470 Graphics 1GB.
Here's several points in dmesg results that took more times to finish the boot:

Code:
[    2.310496] ata6: SATA link down (SStatus 0 SControl 300)
[    3.767050] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   25.881100] udevd[437]: starting version 175
[   26.402319] type=1400 audit(1392146010.032:2): apparmor="STATUS" operation="profile_load" name="/sbin/dhclient" pid=643 comm="apparmor_parser"


And then:

Code:
[   27.419961] psmouse serio4: elantech: assuming hardware version 2 (with firmware version 0x040101)
[   27.447504] psmouse serio4: elantech: Synaptics capabilities query result 0x7e, 0x13, 0x0d.
[   27.552488] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio4/input/input12
[   28.190164] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   28.720869] init: failsafe main process (957) killed by TERM signal
[   29.000567] type=1400 audit(1392146012.632:8): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper" pid=1026 comm="apparmor_parser"
[   29.001075] type=1400 audit(1392146012.632:9): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm/lightdm-guest-session-wrapper//chromium_browser" pid=1026 comm="apparmor_parser"
[   29.003836] type=1400 audit(1392146012.636:10): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=1027 comm="apparmor_parser"
[   29.004466] type=1400 audit(1392146012.636:11): apparmor="STATUS" operation="profile_replace" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=1027 comm="apparmor_parser"
[   29.243459] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   29.243463] Bluetooth: BNEP filters: protocol multicast
[   29.243470] Bluetooth: BNEP socket layer initialized
[   29.244274] Bluetooth: RFCOMM TTY layer initialized
[   29.244282] Bluetooth: RFCOMM socket layer initialized
[   29.244284] Bluetooth: RFCOMM ver 1.11
[   29.558013] ppdev: user-space parallel port driver
[   29.708591] init: avahi-cups-reload main process (1067) terminated with status 1
[   31.896938] jme 0000:07:00.5: irq 49 for MSI/MSI-X
[   31.922679] jme 0000:07:00.5 eth0: Link is down
[   46.910368] vesafb: mode is 1024x768x32, linelength=4096, pages=0
[   46.910371] vesafb: scrolling: redraw
[   46.910374] vesafb: Truecolor: size=0:8:8:8, shift=0:16:8:0
[   46.915115] vesafb: framebuffer at 0xe0000000, mapped to 0xffffc90005200000, using 3072k, total 3072k
[   46.915320] Console: switching to colour frame buffer device 128x48
[   46.918305] fb0: VESA VGA frame buffer device
[   53.866018] fglrx_pci 0000:01:00.0: irq 50 for MSI/MSI-X
[   53.866544] <6>[fglrx] Firegl kernel thread PID: 1727
[   53.866910] <6>[fglrx] Firegl kernel thread PID: 1728
[   53.867281] <6>[fglrx] Firegl kernel thread PID: 1729
[   53.867479] <6>[fglrx] IRQ 50 Enabled
[   53.874944] <6>[fglrx] Gart USWC size:1280 M.
[   53.874946] <6>[fglrx] Gart cacheable size:508 M.
[   53.874949] <6>[fglrx] Reserved FB block: Shared offset:0, size:1000000 
[   53.874950] <6>[fglrx] Reserved FB block: Unshared offset:f8fc000, size:404000 
[   53.874952] <6>[fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000 
[   55.382735] postgres (1758): /proc/1758/oom_adj is deprecated, please use /proc/1758/oom_score_adj instead.
[   65.614550] init: plymouth-stop pre-start process (2573) terminated with status 1


And it took about 65.62 seconds for my laptop to boot.

(You can also answer this problem here)