Results 1 to 3 of 3

Thread: Problems with X45A and UEFI

  1. #1
    Join Date
    Feb 2014

    Problems with X45A and UEFI

    Now I have a small problem with an ASUS that I picked up second hand. Windows 8 was preinstalled but it was buggy as hell, system restore was down and you couldn't install any new programs. Now hearing only bad things about the OS I decided to wipe it and start a fresh.
    I chose to run Ubuntu 12.4 64 bit because I had it laying about. So I went through the UEFI and turned of the bells and whistles, and started up in legacy without the security. Live from USB worked straight off the bat no problems. It's still working fine. But the problem started after I had installed Ubuntu and did a reboot. It simply didn't have any option to boot from HDD, none. In fact there were no boot options. I replaced the USB and Live booted up fine again. I looked at all my partitions and they were there. I did some reading about and tried a program called root-repairer. I ran that successfully - is the log.
    After that I recieved an option of Windows loader. but after pressing that it would just return me to the bios screen.
    This is the flashiest computer I have owned, as in the newest as most of the computers I've been running are ancient in today's terms. I've been reading about but it seems no one has had a problem exactly like mine.
    It's quite perplexing. Thanking anyone who can point me in the right direction.
    Cheers Dwuan

  2. #2
    Join Date
    Jul 2005

    Re: Problems with X45A and UEFI

    Follow the instructions at UEFI - Ubuntu Documentation to install in UEFI mode which I think has some advantages over BIOS. You already have an efi partitionso can use that but make sure it has the boot flag on it, or delete that one and make a new one which will remove the boot option for windows, which is now not available to boot.

    It is simpler than it looks at first glance as you will not have windows to worry about, so have a long careful read of that link and see if it is any help.

    I note you seem to have Mint 15, not Ubuntu 12.04, but it should be very similar, I thnk, so far as installing is concerned.
    DISTRO: Xubuntu 14.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Problems with X45A and UEFI

    You have a UEFI install.
    Did you turn on secure boot in UEFI, as your Linux install is not a secure boot version.
    OR did you turn on legacy only boot as you have no legacy installs and that would not work.
    You show a couple of Windows efi boot files in efi partition but no Windows install, so those boot entries will not work.

    Some UEFI only boot Windows. Vendors modify descriptions in UEFI to look only for Windows to boot. Boot-Repair has a work around for that if that is your case.

    But since you have only one install you will not normally get grub menu. It will just auto boot defautl entry. But then you may have video issues or other issues that prevent booting and you really do not know if or where issue is.
    If you hold shift key from UEFI/BIOS do you get grub menu? Or with some UEFI you have to use escape key.

    Also many new UEFI systems work better if you use the newest version of Ubuntu or 13.10. Also 12.04.4 will be out in a week or two and both have major improvements in UEFI Linux support.
    Also vendors are making major changes to improve UEFI, so often good idea to update UEFI/BIOS from vendor to newest version.

    You also show no entry in UEFI.
     chroot /mnt/boot-sav/sda2 efibootmgr -v
    BootCurrent: 0003
    Timeout: 2 seconds
    BootOrder: 0003,0004,0001,0002
    Boot0001  CD/DVD Drive 	BIOS(3,0,00)AMGOAMNO........o.H.L.-.D.T.-.S.T. .D.V.D.R.A.M. .G.T.7.0.N....................A...........................>..Gd-.;.A..MQ..L.Y.K.C.O.B. .3. . . . . . . . ......AMBO
    Boot0002  Network Card 	BIOS(6,0,00)AMGOAMNO........k.R.e.a.l.t.e.k. .P.X.E. .B.0.3. .D.0.0.........................rN.D+..,............<..Gd-.;.A..MQ..L.R.e.a.l.t.e.k. .P.X.E. .B.0.3. .D.0.0......AMBO
    Boot0003* UEFI: Lexar USB Flash Drive 1100	ACPI(a0341d0,0)PCI(1d,0)USB(1,0)USB(2,0)HD(1,20,1d3ffe0,c3072e18)AMBO
    Boot0004* Hard Drive 	BIOS(2,0,00)AMGOAMNO........}.L.e.x.a.r. .U.S.B. .F.l.a.s.h. .D.r.i.v.e. .;.A..MQ..L.L.e.x.a.r. .U.S.B. .F.l.a.s.h. .D.r.i.v.e. .
    Last edited by oldfred; February 4th, 2014 at 07:21 PM.
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts