Update... Yesterday I reformatted the 12.04 drive (only because I had lost track with all the adjustments i'd made using the terminal) Then on my other hd I tried to skype using the 13.04 installation and the new webcam, got the same quiet shutdown effect.
However the good news is that undeterred I restarted and grubbed into my 13.10/14.04 (hybrid) install and lo and behold Skype worked, and I was able to maintain an hour long communication, I don't know why, but at the present time all's well. I will be running an update later just hoping that I wont have a relapse.
As for your question about the light on the logitec camera I cant really say whether the light was on or not since I was never aware of it, perhaps it was off. My problem may well have been a faulty cam, coupled to my increasingly desperate attempts to get it going using web gleaned terminal cures that might have caused conflicts.
I will try out skype again later today when my son logs on in Ontario, hopefully it will still work.