Results 1 to 10 of 17

Thread: Following recommendation from 'sudo apt-get install apt-show-versions' breaks skype

Threaded View

  1. #1
    Join Date
    Jun 2008
    Beans
    199
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Following recommendation from 'sudo apt-get install apt-show-versions' breaks skype

    I have just installed Ubuntu 12.04 (amd64 version) after using 9.10 and have installed gnome-shell and removed unity.
    I downloaded skype from
    http://www.skype.com/en/download-sky...-for-computer/
    and chose the option 'Ubunti 12.04 (Multiarch)'
    This produced file skype-ubuntu-precise_4.2.0.13-1_i386.deb
    I installed this with gdebi and skype worked fine.

    I decided to install apt-show-versions thus:

    Code:
    $ sudo apt-get install apt-show-versions
    [sudo] password for : 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libkrb5-3:i386 libk5crypto3:i386 libstdc++6:i386 liblcms1:i386 libwrap0:i386 libsamplerate0:i386 libjpeg-turbo8:i386 libjpeg8:i386
      libqt4-script:i386 libqt4-network:i386 libqt4-dbus:i386 libjack-jackd2-0:i386 libgnutls26:i386 libtasn1-3:i386 libfreetype6:i386 libglib2.0-0:i386
      libmysqlclient18:i386 libexpat1:i386 libqt4-xmlpatterns:i386 libavahi-common-data:i386 libjson0:i386 libxcb1:i386 libp11-kit0:i386 libxau6:i386
      libcups2:i386 libqtcore4:i386 libkrb5support0:i386 libice6:i386 libspeexdsp1:i386 libxdmcp6:i386 libgcrypt11:i386 libxml2:i386 libkeyutils1:i386
      libqt4-sql:i386 libasound2:i386 libflac8:i386 libxrender1:i386 liborc-0.4-0:i386 libvorbisenc2:i386 libqt4-xml:i386 libasyncns0:i386 libxss1:i386
      libtiff4:i386 libgstreamer-plugins-base0.10-0:i386 libavahi-client3:i386 libx11-6:i386 libsm6:i386 libpulse0:i386 libqt4-sql-mysql:i386
      libgssapi-krb5-2:i386 libxi6:i386 libvorbis0a:i386 libgstreamer0.10-0:i386 libaudio2:i386 libxt6:i386 libxv1:i386 libxext6:i386
      libavahi-common3:i386 mysql-common libsndfile1:i386 libsqlite3-0:i386 libmng1:i386 libasound2-plugins:i386 libgpg-error0:i386 libogg0:i386
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      libapt-pkg-perl
    The following NEW packages will be installed
      apt-show-versions libapt-pkg-perl
    0 upgraded, 2 newly installed, 0 to remove and 120 not upgraded.
    Need to get 116 kB of archives.
    After this operation, 444 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://es.archive.ubuntu.com/ubuntu/ precise/main libapt-pkg-perl amd64 0.1.25build2 [82.9 kB]
    Get:2 http://es.archive.ubuntu.com/ubuntu/ precise/universe apt-show-versions all 0.17 [32.9 kB]
    Fetched 116 kB in 0s (135 kB/s)              
    Selecting previously unselected package libapt-pkg-perl.
    (Reading database ... 164425 files and directories currently installed.)
    Unpacking libapt-pkg-perl (from .../libapt-pkg-perl_0.1.25build2_amd64.deb) ...
    Selecting previously unselected package apt-show-versions.
    Unpacking apt-show-versions (from .../apt-show-versions_0.17_all.deb) ...
    Processing triggers for man-db ...
    Setting up libapt-pkg-perl (0.1.25build2) ...
    Setting up apt-show-versions (0.17) ...
    ** initializing cache. This may take a while **
    So I took the advice:

    Code:
    $ sudo apt-get autoremove
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED
      libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
      libcups2:i386 libexpat1:i386 libflac8:i386 libfreetype6:i386 libgcrypt11:i386 libglib2.0-0:i386 libgnutls26:i386 libgpg-error0:i386
      libgssapi-krb5-2:i386 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libice6:i386 libjack-jackd2-0:i386 libjpeg-turbo8:i386
      libjpeg8:i386 libjson0:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms1:i386 libmng1:i386
      libmysqlclient18:i386 libogg0:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpulse0:i386 libqt4-dbus:i386 libqt4-network:i386 libqt4-script:i386
      libqt4-sql:i386 libqt4-sql-mysql:i386 libqt4-xml:i386 libqt4-xmlpatterns:i386 libqtcore4:i386 libsamplerate0:i386 libsm6:i386 libsndfile1:i386
      libspeexdsp1:i386 libsqlite3-0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libx11-6:i386
      libxau6:i386 libxcb1:i386 libxdmcp6:i386 libxext6:i386 libxi6:i386 libxml2:i386 libxrender1:i386 libxss1:i386 libxt6:i386 libxv1:i386 mysql-common
    0 upgraded, 0 newly installed, 65 to remove and 120 not upgraded.
    After this operation, 54.7 MB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 164467 files and directories currently installed.)
    Removing libasound2-plugins:i386 ...
    Removing libasound2:i386 ...
    Removing libpulse0:i386 ...
    Removing libasyncns0:i386 ...
    Removing libaudio2:i386 ...
    Removing libcups2:i386 ...
    Removing libavahi-client3:i386 ...
    Removing libavahi-common3:i386 ...
    Removing libavahi-common-data:i386 ...
    Removing libexpat1:i386 ...
    Removing libsndfile1:i386 ...
    Removing libflac8:i386 ...
    Removing libfreetype6:i386 ...
    Removing libgnutls26:i386 ...
    Removing libgcrypt11:i386 ...
    Removing libqt4-xmlpatterns:i386 ...
    Removing libqt4-script:i386 ...
    Removing libqt4-network:i386 ...
    Removing libqt4-dbus:i386 ...
    Removing libqt4-xml:i386 ...
    Removing libqt4-sql-mysql:i386 ...
    Removing libqt4-sql:i386 ...
    Removing libqtcore4:i386 ...
    Removing libgstreamer-plugins-base0.10-0:i386 ...
    Removing libgstreamer0.10-0:i386 ...
    Removing libglib2.0-0:i386 ...
    Removing libgpg-error0:i386 ...
    Removing libgssapi-krb5-2:i386 ...
    Removing libxt6:i386 ...
    Removing libsm6:i386 ...
    Removing libice6:i386 ...
    Removing libjack-jackd2-0:i386 ...
    Removing libtiff4:i386 ...
    Removing libmng1:i386 ...
    Removing libjpeg8:i386 ...
    Removing libjpeg-turbo8:i386 ...
    Removing libjson0:i386 ...
    Removing libkrb5-3:i386 ...
    Removing libk5crypto3:i386 ...
    Removing libkeyutils1:i386 ...
    Removing libkrb5support0:i386 ...
    Removing liblcms1:i386 ...
    Removing libmysqlclient18:i386 ...
    Removing libvorbisenc2:i386 ...
    Removing libvorbis0a:i386 ...
    Removing libogg0:i386 ...
    Removing liborc-0.4-0:i386 ...
    Removing libp11-kit0:i386 ...
    Removing libsamplerate0:i386 ...
    Removing libspeexdsp1:i386 ...
    Removing libsqlite3-0:i386 ...
    Removing libstdc++6:i386 ...
    Removing libtasn1-3:i386 ...
    Removing libwrap0:i386 ...
    Removing libxi6:i386 ...
    Removing libxv1:i386 ...
    Removing libxrender1:i386 ...
    Removing libxss1:i386 ...
    Removing libxext6:i386 ...
    Removing libx11-6:i386 ...
    Removing libxcb1:i386 ...
    Removing libxau6:i386 ...
    Removing libxdmcp6:i386 ...
    Removing libxml2:i386 ...
    Removing mysql-common ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Processing triggers for libglib2.0-0 ...
    Processing triggers for man-db ...


    However this broke skype and it vanished:

    Code:
    $ dpkg -l skype
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name                            Version                         Description
    +++-===============================-===============================-==============================================================================
    un  skype                           <none>                          (no description available)
    Trying to reinstall it did not work:

    Code:
    $ sudo dpkg -i skype-ubuntu-precise_4.2.0.13-1_i386.deb 
    [sudo] password for : 
    Selecting previously unselected package skype:i386.
    (Reading database ... 164214 files and directories currently installed.)
    Unpacking skype:i386 (from skype-ubuntu-precise_4.2.0.13-1_i386.deb) ...
    dpkg: dependency problems prevent configuration of skype:i386:
     skype:i386 depends on libasound2 (>= 1.0.23); however:
      Package libasound2:i386 is not installed.
     skype:i386 depends on libqt4-dbus (>= 4:4.5.3); however:
      Package libqt4-dbus:i386 is not installed.
     skype:i386 depends on libqt4-network (>= 4:4.8.0); however:
      Package libqt4-network:i386 is not installed.
     skype:i386 depends on libqt4-xml (>= 4:4.5.3); however:
      Package libqt4-xml:i386 is not installed.
     skype:i386 depends on libqtcore4 (>= 4:4.7.0~beta1); however:
      Package libqtcore4:i386 is not installed.
     skype:i386 depends on libqtgui4 (>= 4:4.8.0); however:
      Package libqtgui4:i386 is not installed.
     skype:i386 depends on libqtwebkit4 (>= 2.2~2011week36); however:
      Package libqtwebkit4:i386 is not installed.
     skype:i386 depends on libstdc++6 (>= 4.6); however:
      Package libstdc++6:i386 is not installed.
     skype:i386 depends on libx11-6; however:
      Package libx11-6:i386 is not installed.
     skype:i386 depends on libxext6; however:
      Package libxext6:i386 is not installed.
     skype:i386 depends on libxss1; however:
      Package libxss1:i386 is not installed.
     skype:i386 depends on libxv1; however:
      Package libxv1:i386 is not installed.
     skype:i386 depends on libasound2-plugins; however:
      Package libasound2-plugins:i386 is not installed.
    dpkg: error processing skype:i386 (--install):
     dependency problems - leaving unconfigured
    Processing triggers for hicolor-icon-theme ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Processing triggers for gnome-menus ...
    Errors were encountered while processing:
     skype:i386

    Trying to re-install the libraries did not work:

    Code:
    $ sudo apt-get install libkrb5-3:i386 libk5crypto3:i386 libstdc++6:i386 liblcms1:i386 libwrap0:i386 libsamplerate0:i386 libjpeg-turbo8:i386 libjpeg8:i386  libqt4-script:i386 libqt4-network:i386 libqt4-dbus:i386 libjack-jackd2-0:i386 libgnutls26:i386 libtasn1-3:i386 libfreetype6:i386 libglib2.0-0:i386  libmysqlclient18:i386 libexpat1:i386 libqt4-xmlpatterns:i386 libavahi-common-data:i386 libjson0:i386 libxcb1:i386 libp11-kit0:i386 libxau6:i386  libcups2:i386 libqtcore4:i386 libkrb5support0:i386 libice6:i386 libspeexdsp1:i386 libxdmcp6:i386 libgcrypt11:i386 libxml2:i386 libkeyutils1:i386  libqt4-sql:i386 libasound2:i386 libflac8:i386 libxrender1:i386 liborc-0.4-0:i386 libvorbisenc2:i386 libqt4-xml:i386 libasyncns0:i386 libxss1:i386  libtiff4:i386 libgstreamer-plugins-base0.10-0:i386 libavahi-client3:i386 libx11-6:i386 libsm6:i386 libpulse0:i386 libqt4-sql-mysql:i386  libgssapi-krb5-2:i386 libxi6:i386 libvorbis0a:i386 libgstreamer0.10-0:i386 libaudio2:i386 libxt6:i386 libxv1:i386 libxext6:i386  libavahi-common3:i386 mysql-common libsndfile1:i386 libsqlite3-0:i386 libmng1:i386 libasound2-plugins:i386 libgpg-error0:i386 libogg0:i386
    [sudo] password for bob: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies.
     libasound2 : Breaks: libasound2:i386 (!= 1.0.25-1ubuntu10.2) but 1.0.25-1ubuntu10 is to be installed
     libasound2:i386 : Breaks: libasound2 (!= 1.0.25-1ubuntu10)
     libavahi-client3 : Breaks: libavahi-client3:i386 (!= 0.6.30-5ubuntu2.1) but 0.6.30-5ubuntu2 is to be installed
     libavahi-client3:i386 : Breaks: libavahi-client3 (!= 0.6.30-5ubuntu2) but 0.6.30-5ubuntu2.1 is to be installed
     libavahi-common-data : Breaks: libavahi-common-data:i386 (!= 0.6.30-5ubuntu2.1) but 0.6.30-5ubuntu2 is to be installed
     libavahi-common-data:i386 : Breaks: libavahi-common-data (!= 0.6.30-5ubuntu2) but 0.6.30-5ubuntu2.1 is to be installed
     libavahi-common3 : Breaks: libavahi-common3:i386 (!= 0.6.30-5ubuntu2.1) but 0.6.30-5ubuntu2 is to be installed
     libavahi-common3:i386 : Breaks: libavahi-common3 (!= 0.6.30-5ubuntu2) but 0.6.30-5ubuntu2.1 is to be installed
     libcups2 : Breaks: libcups2:i386 (!= 1.5.3-0ubuntu8) but 1.5.3-0ubuntu5.1 is to be installed
     libcups2:i386 : Breaks: libcups2 (!= 1.5.3-0ubuntu5.1) but 1.5.3-0ubuntu8 is to be installed
     libglib2.0-0 : Breaks: libglib2.0-0:i386 (!= 2.32.4-0ubuntu1) but 2.32.1-0ubuntu2 is to be installed
     libglib2.0-0:i386 : Depends: libelf1:i386 (>= 0.131) but it is not going to be installed
                         Breaks: libglib2.0-0 (!= 2.32.1-0ubuntu2) but 2.32.4-0ubuntu1 is to be installed
     libgnutls26 : Breaks: libgnutls26:i386 (!= 2.12.14-5ubuntu3.5) but 2.12.14-5ubuntu3.4 is to be installed
     libgnutls26:i386 : Breaks: libgnutls26 (!= 2.12.14-5ubuntu3.4) but 2.12.14-5ubuntu3.5 is to be installed
     libgstreamer-plugins-base0.10-0 : Breaks: libgstreamer-plugins-base0.10-0:i386 (!= 0.10.36-1ubuntu0.1) but 0.10.36-1 is to be installed
     libgstreamer-plugins-base0.10-0:i386 : Breaks: libgstreamer-plugins-base0.10-0 (!= 0.10.36-1) but 0.10.36-1ubuntu0.1 is to be installed
     libjack-jackd2-0 : Breaks: libjack-jackd2-0:i386 (!= 1.9.8~dfsg.1-1ubuntu2) but 1.9.8~dfsg.1-1ubuntu1 is to be installed
     libjack-jackd2-0:i386 : Breaks: libjack-jackd2-0 (!= 1.9.8~dfsg.1-1ubuntu1) but 1.9.8~dfsg.1-1ubuntu2 is to be installed
     libpulse0 : Breaks: libpulse0:i386 (!= 1:1.1-0ubuntu15.4) but 1:1.1-0ubuntu15 is to be installed
     libpulse0:i386 : Breaks: libpulse0 (!= 1:1.1-0ubuntu15) but 1:1.1-0ubuntu15.4 is to be installed
     libqt4-dbus : Breaks: libqt4-dbus:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqt4-dbus:i386 : Recommends: qdbus:i386 (= 4:4.8.1-0ubuntu4.5)
                        Breaks: libqt4-dbus (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libqt4-network : Breaks: libqt4-network:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqt4-network:i386 : Breaks: libqt4-network (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libqt4-script : Breaks: libqt4-script:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqt4-script:i386 : Breaks: libqt4-script (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libqt4-sql : Breaks: libqt4-sql:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqt4-sql:i386 : Breaks: libqt4-sql (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libqt4-xml : Breaks: libqt4-xml:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqt4-xml:i386 : Breaks: libqt4-xml (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libqt4-xmlpatterns : Breaks: libqt4-xmlpatterns:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqt4-xmlpatterns:i386 : Breaks: libqt4-xmlpatterns (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libqtcore4 : Breaks: libqtcore4:i386 (!= 4:4.8.1-0ubuntu4.6) but 4:4.8.1-0ubuntu4.5 is to be installed
     libqtcore4:i386 : Breaks: libqtcore4 (!= 4:4.8.1-0ubuntu4.5) but 4:4.8.1-0ubuntu4.6 is to be installed
     libsqlite3-0 : Breaks: libsqlite3-0:i386 (!= 3.7.9-2ubuntu1.1) but 3.7.9-2ubuntu1 is to be installed
     libsqlite3-0:i386 : Breaks: libsqlite3-0 (!= 3.7.9-2ubuntu1) but 3.7.9-2ubuntu1.1 is to be installed
     libx11-6 : Breaks: libx11-6:i386 (!= 2:1.4.99.1-0ubuntu2.2) but 2:1.4.99.1-0ubuntu2.1 is to be installed
     libx11-6:i386 : Breaks: libx11-6 (!= 2:1.4.99.1-0ubuntu2.1) but 2:1.4.99.1-0ubuntu2.2 is to be installed
     libxi6 : Breaks: libxi6:i386 (!= 2:1.7.1.901-1ubuntu1~precise1) but 2:1.6.0-0ubuntu2.1 is to be installed
     libxi6:i386 : Breaks: libxi6 (!= 2:1.6.0-0ubuntu2.1) but 2:1.7.1.901-1ubuntu1~precise1 is to be installed
     skype:i386 : Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
                  Recommends: sni-qt:i386 but it is not going to be installed
    W: Duplicate sources.list entry http://deb.opera.com/opera/ stable/non-free amd64 Packages (/var/lib/apt/lists/deb.opera.com_opera_dists_stable_non-free_binary-amd64_Packages)
    W: Duplicate sources.list entry http://deb.opera.com/opera/ stable/non-free i386 Packages (/var/lib/apt/lists/deb.opera.com_opera_dists_stable_non-free_binary-i386_Packages)
    W: You may want to run apt-get update to correct these problems
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    At this point I have no idea how to proceed! Any advice?
    Last edited by desconocido; February 3rd, 2014 at 01:20 AM. Reason: mention (amd64 version)
    I have a Toshiba Satellite C50D laptop with 3.4 GB of RAM and (AMD E1-1200 APU @ 1.4 GHz with Radeon HD Graphics) x 2 processor; (older posts refer to 8.04, 9.10, 12.04 on this or other hardware).

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •