Results 1 to 5 of 5

Thread: Cannot install steam due to missing i386 packages

  1. #1
    Join Date
    Apr 2013
    Beans
    4

    Cannot install steam due to missing i386 packages

    Hi,

    I've reinstalled Ubuntu 64bit a few days ago and since then I cannot install steam
    Code:
    :~$ sudo apt-get install steam
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
     libgl1-mesa-dri : Depends: libdrm-intel1 (>= 2.4.48) but it is not going to be installed
                       Depends: libdrm-nouveau2 (>= 2.4.38) but it is not going to be installed
                       Depends: libdrm-radeon1 (>= 2.4.31) but it is not going to be installed
     steam:i386 : Depends: libx11-6:i386 but it is not going to be installed
                  Depends: libxcb1:i386 but it is not going to be installed
                  Depends: libgl1-mesa-dri:i386 but it is not going to be installed
                  Depends: libgl1-mesa-glx:i386 but it is not going to be installed
     ubuntu-system-settings : Depends: indicator-bluetooth (> 0.0.6+13.10.20131010) but it is not going to be installed
                              Depends: indicator-network (>= 0.5.0+13.10.20130918) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    And apt-get -f install doesn't do anything
    Code:
    :~$ sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Do you have any idea how to solve this?
    Last edited by maeries; February 2nd, 2014 at 05:54 PM.

  2. #2
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 17.10 Artful Aardvark

    Re: Cannot install steam due to missing i386 packages

    Have you updated your sources since reinstalling?
    Code:
    sudo apt-get update && sudo apt-get dist-upgrade
    Also I think it's best to get the latest steam*deb from Steam's site, http://store.steampowered.com/about/ click 'Install Steam Now'. Let us know if it works or not.

  3. #3
    Join Date
    Apr 2013
    Beans
    4

    Re: Cannot install steam due to missing i386 packages

    Yes, i ran apt-get update, apt-get (dist-)upgrade, apt-get autoremove and apt-get -f install nearly 100 times.

    So, I downloaded steam from steampowered.com and it kinda works. I can start it, but at every start I get this
    Code:
    Steam needs to install these additional packages: 
        libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
    [sudo] password for user: 
    ..............................................................................................................................................
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
     libgl1-mesa-dri:i386 : Depends: libdrm-intel1:i386 (>= 2.4.38) but it is not going to be installed
                            Depends: libdrm-nouveau2:i386 (>= 2.4.38) but it is not going to be installed
                            Depends: libdrm-radeon1:i386 (>= 2.4.31) but it is not going to be installed
                            Depends: libdrm2:i386 (>= 2.4.38) but it is not going to be installed
                            Depends: libglapi-mesa:i386 but it is not going to be installed
     libgl1-mesa-glx:i386 : Depends: libdrm2:i386 (>= 2.3.1) but it is not going to be installed
                            Depends: libglapi-mesa:i386 (= 9.2.1-1ubuntu3) but it is not going to be installed
                            Depends: libx11-6:i386 (>= 2:1.4.99.1) but it is not going to be installed
                            Depends: libxcb-dri2-0:i386 (>= 1.8) but it is not going to be installed
                            Depends: libxcb-glx0:i386 (>= 1.8) but it is not going to be installed
                            Depends: libxcb1:i386 but it is not going to be installed
                            Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed
                            Depends: libxext6:i386 but it is not going to be installed
                            Depends: libxfixes3:i386 but it is not going to be installed
                            Depends: libxxf86vm1:i386 but it is not going to be installed
     libqt5feedback5 : Depends: libqt5multimedia5 (>= 5.0.2) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Also, when I want to install Skype it nearly looks the same
    Code:
    :~$ sudo apt-get install skype-bin
    [sudo] password for user: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
     skype-bin:i386 : Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
                      Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
                      Depends: libgl1-mesa-glx:i386 but it is not going to be installed
                      Recommends: sni-qt:i386 but it is not going to be installed
                      Recommends: libasound2-plugins:i386 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Notice that it says here "held broken packages" while steam says only "held packages"
    Last edited by maeries; February 2nd, 2014 at 06:57 PM.

  4. #4
    Join Date
    Apr 2013
    Beans
    4

    Re: Cannot install steam due to missing i386 packages

    I found something I don't understand. I have to install libdrm2:i386 to get steam working
    Code:
    :~$ sudo apt-get install libdrm2:i386
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies.
     kmod : Depends: upstart-job
     libqt5feedback5 : Depends: libqt5multimedia5 (>= 5.0.2) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    But why does thin not work? I have kmod, upstart, libqt5feedback5 and libqt5multimedia5 installed.

  5. #5
    Join Date
    Apr 2013
    Beans
    4

    Re: Cannot install steam due to missing i386 packages

    Anyone any idea?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •