Results 1 to 3 of 3

Thread: Black screen after installing fglrx

  1. #1
    Join Date
    Jan 2014

    Black screen after installing fglrx

    Hi guys,

    I am running Ubuntu 13.10 on my PC with 2x Sapphire Radeon HD 7950. After I installed fglrx, ran
    sudo aticonfig --adapter=all --initial
    and rebooted, I get a black screen.

    When I go into recovery mode and run fglrxinfo, it gives me the following output:
    unable to open display (null)
    When I looked on the ubuntu forums someone suggested I run
    aticonfig --acpi-services=off
    but unfortunately this doesnt seem to have any effect.

    Does anyone have some suggestion? Any help would be appreciated, and I would be happy to provide more information if needed.

    Thanks in advance!

    I should also mention that I previously had an install with fglrx on this system which worked fine. At some point this black screen appeared. After that I decided to reinstall Ubuntu, which works fine until I install fglrx again.
    Last edited by jaspervdmaarel; January 27th, 2014 at 03:19 PM.

  2. #2
    Join Date
    Dec 2013

    Re: Black screen after installing fglrx

    I'm having a similar issue on 14.04/10 with the latest packages. Did you find a fix for this?

  3. #3
    Join Date
    Sep 2014

    Re: Black screen after installing fglrx

    Me too having the same issue in ubuntu 14.4 LTS,If you find a fix means tell me?

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts