Results 1 to 5 of 5

Thread: Downgrade apache from 2.2.22 to 2.2.19 on Moodle 2.5 in the distro Ubuntu 12.04

  1. #1
    Join Date
    Jan 2014
    Beans
    2

    Downgrade apache from 2.2.22 to 2.2.19 on Moodle 2.5 in the distro Ubuntu 12.04

    Hi People,
    I need help!

    I'm doing my graduation dissertation and I making a scenario business continuity using DRBD mirroring solution to provide continuity to Moodle.
    I am creating an environment of business continuity and I need to attack a vulnerable environment and return the operation to the secondary environment in order to demonstrate that the business continuity plan will be effective in a time of disaster secondary environment.

    Apache 2.2.19 has a vulnerability and exploit that I can use to attack the environment, so I intend to carry out the attack and even after using the most updated apache.

    I can downgrade from apache 2.2.22 to 2.2.19, the apache worked successfully but the moodle environment did not work. How Can a make the moodle environment work with the apache downgrade ?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Tennessee
    Beans
    3,421

    Re: Downgrade apache from 2.2.22 to 2.2.19 on Moodle 2.5 in the distro Ubuntu 12.04

    Tell us a bit more about how it didn't work, how you went about installing things and downgrading them. Were you working strictly with packages from the repo, installing from source, or something else? Did you install Moodle from the repositories or from source?

  3. #3
    Join Date
    Jan 2014
    Beans
    2

    Re: Downgrade apache from 2.2.22 to 2.2.19 on Moodle 2.5 in the distro Ubuntu 12.04

    The main page Moodle didin't load.
    I installed Moodle from source.

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    Tennessee
    Beans
    3,421

    Re: Downgrade apache from 2.2.22 to 2.2.19 on Moodle 2.5 in the distro Ubuntu 12.04

    If the page doesn't load, you should check /var/log/apache2/error.log for some information on why.

  5. #5
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Downgrade apache from 2.2.22 to 2.2.19 on Moodle 2.5 in the distro Ubuntu 12.04

    Moved to Server Platforms, as you will more than likely get more help here.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •