Results 1 to 8 of 8

Thread: Desktop icons overlap with taskbar

  1. #1
    Join Date
    Dec 2013
    Beans
    18
    Distro
    Xubuntu 14.04 Trusty Tahr

    Desktop icons overlap with taskbar

    After boot, desktop icons overlap with the top taskbar. Opening the taskbar preferences sets it back to the correct position; I haven't found specifics to this, but the "reset" may be similar to an earlier issue.

    A workaround may be to start/stop the preferences at boot, but I was hoping to solve the underlying issue (especially when it's a recent one). Using Xubuntu 12.04 with XFCE 4.8
    Attached Images Attached Images

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Desktop icons overlap with taskbar

    Looks like struts may be disabled (though I'm not sure why open the taskbar preferences resets it). What does the following command return?
    Code:
    xfconf-query -c xfce4-panel -lv | grep struts
    ...it will display whether struts are enabled and what setting its at.

  3. #3
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Desktop icons overlap with taskbar

    Have you got a selection tick in the "Don't reserve space on borders" in your panel Preferences -> Display tab?
    DISTRO: Xubuntu 14.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Desktop icons overlap with taskbar

    Quote Originally Posted by ajgreeny View Post
    Have you got a selection tick in the "Don't reserve space on borders" in your panel Preferences -> Display tab?
    I don't believe 4.8 has this option visible in the preferences dialog. To manage this setting you had to use the hidden struts property.
    I don't have a 4.8 install handy to check.

  5. #5
    Join Date
    Dec 2013
    Beans
    18
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Desktop icons overlap with taskbar

    xf-conf didn't return an entry, and indeed, I don't have an option for "Don't reserve space on borders". I've tried adding "disable-struts" and setting it to "false", but it still needs a refresh.

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Desktop icons overlap with taskbar

    Quote Originally Posted by Previous1 View Post
    I've tried adding "disable-struts" and setting it to "false", but it still needs a refresh.
    How did you try adding it? Which channel/property did you use?

    Does clearing your saved sessions cache help? To clear your sessions cache (in 4.8), delete the ~/.cache/sessions directory while not logged in (from the first virtual console - Ctrl+Alt+F1).

  7. #7
    Join Date
    Dec 2013
    Beans
    18
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Desktop icons overlap with taskbar

    I've used this command: xfconf-query -c xfce4-panel -p /panels/panel-0/disable-struts -n -t bool -s false

    Clearing sessions didn't help but, oddly enough, changing the theme from Bluebird to Greybird did..

    Thanks for the help.

  8. #8
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Desktop icons overlap with taskbar

    Another alternative is to use the ppa for xfce 4.10 which works faultlessly in 12.04
    https://launchpad.net/~xubuntu-dev/+...filter=precise
    You will then find that you have the option for reserving space on borders. Sorry, I forgot I was on 4.10, and didn't really notice you are using 4.8.
    Last edited by ajgreeny; January 12th, 2014 at 04:46 PM.
    DISTRO: Xubuntu 14.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •