Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Trouble mounting Seagate Central 3TB Data partition (LVM)

  1. #1
    Join Date
    Jan 2014
    Beans
    10

    Trouble mounting Seagate Central 3TB Data partition (LVM)

    Hi - I'm new to Linux and am hoping someone can help save me.., well my HDD at least. The data on my Seagate Central 3TB was no longer accessible in Windows, so I've opened the unit to retrieve the HDD and am trying to use Linux (Ubuntu 12.04 LTS) and a drive reader (via USB) to recover and copy the data off the drive. The drive appears readible as all but the 'Data' partition seem to be able to mount. However, when looking at the Disk utility, the Data volume will not mount. I've been researching a number of help sites, and have tried a few things, but being new, am afraid to make the situation worse.

    Here's are screenshots of the error that I receive when trying to mount the Data volume. Let me know what additional info would be useful. Any help is appreciated - thanks in advance!!


  2. #2
    Join Date
    Apr 2012
    Beans
    7,257

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    Hello and welcome to the forums

    Your screenshot isn't showing for me - maybe you didn't upload it? (via the 'Manage Attachments' button in the 'Additional Options' box below the main text entry area)

    Alternatively you can open a terminal window and enter

    Code:
    sudo parted -l
    and copy + paste the output here

  3. #3
    Join Date
    Jan 2014
    Beans
    10

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    Thanks for the response steeldriver, and sorry about the screenshots. I thought I was able to drag and drop from the picture folder, but guess not.
    In any case, here's the output for sudo parted -l. The red device is the one I'm having issues with. Thanks again.

    Model: ATA ST9250410AS (scsi)
    Disk /dev/sda: 250GB
    Sector size (logical/physical): 512B/512B
    Partition Table: msdos

    Number Start End Size Type File system Flags
    1 32.3kB 41.1MB 41.1MB primary fat16 diag
    2 41.9MB 828MB 786MB primary ntfs boot
    3 828MB 182GB 181GB primary ntfs
    4 182GB 250GB 68.5GB extended
    5 182GB 246GB 64.3GB logical ext4
    6 246GB 250GB 4149MB logical linux-swap(v1)


    Error: Unable to satisfy all constraints on the partition.

    Model: Linux device-mapper (linear) (dm)
    Disk /dev/mapper/vg1-lv1: 2995GB
    Sector size (logical/physical): 512B/512B
    Partition Table: loop

    Number Start End Size File system Flags
    1 0.00B 2995GB 2995GB ext4

  4. #4
    Join Date
    Apr 2012
    Beans
    7,257

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    That all looks encouraging so far - for a little more information you can do

    Code:
    sudo lvs /dev/mapper/vg1-lv1
    or
    Code:
    sudo lvdisplay /dev/mapper/vg1-lv1
    or just go right ahead and try to mount it e.g.

    Code:
    sudo mkdir /mnt/seagate
    sudo mount -t ext4 -o ro /dev/mapper/vg1-lv1 /mnt/seagate

  5. #5
    Join Date
    Jan 2014
    Beans
    10

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    Promising to hear. Here's what I get after with the code suggested:

    ssoong@ssoong-Latitude-E6410:~$ sudo lvdisplay /dev/mapper/vg1-lv1
    [sudo] password for ssoong:
    --- Logical volume ---
    LV Name /dev/vg1/lv1
    VG Name vg1
    LV UUID 0BDfLf-Hth4-iy0g-xg0W-MBp2-kWC2-6gl6eJ
    LV Write Access read/write
    LV Status available
    # open 0
    LV Size 2.72 TiB
    Current LE 714106
    Segments 1
    Allocation inherit
    Read ahead sectors auto
    - currently set to 256
    Block device 252:0

    ssoong@ssoong-Latitude-E6410:~$ sudo mkdir /mnt/seagate
    ssoong@ssoong-Latitude-E6410:~$ sudo mount -t ext4 -o ro /dev/mapper/vg1-lv1 /mnt/seagate
    mount: wrong fs type, bad option, bad superblock on /dev/mapper/vg1-lv1,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

  6. #6
    Join Date
    Jan 2014
    Beans
    10

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    Checking in to see what the next step should be.., thanks

  7. #7
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    If this worked with Windows, I do not think it was LVM as LVM does not work with Windows.
    Perhaps it is some sort of RAID, but with one drive that would also not be standard.
    Some preformatted drives used for backup have unusual formats or configurations.
    As a network type device then how does it really work? Is it internally translating data from a format inside drive to network like Samba?
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #8
    Join Date
    Jan 2014
    Beans
    10

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    oldfred - I'm afraid I don't know how LVM, RAID, or Samba works. I only referenced it as an LVM type drive b/c that's how it was identified in the Disk Utility manager and was hoping that would be of use in troubleshooting.

    When I could no longer access my Seagate Central NAS drive via Windows, I contacted customer support and they attempted to troubleshoot, eventually concluding that the drive must be corrupt. They suggested that I might try opening the drive to remove the HDD and then use a drive reader to attempt to recover the data stored on it manually. However, then noted that when doing this, I would need a Linux OS or a Linux reader to read the drive if I removed it. I tried installing a Linux reader program that works with Windows, but it only allows me to save certain files on the drive, so I tried installing Ubuntu to get full access to the drive and then hopefully recover all the files from it.

    This is where I've ran into the issue of being able to mount certain partitions of the drive, but not the main 'Data' partition where all my data is saved. Not being familiar with Linux, and not being able to find anything specific to this issue, I'm really hoping that I can get some assistance in resolving this.

  9. #9
    Join Date
    Jan 2014
    Beans
    10

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    steeldriver - any other suggestions on how to proceed?
    thanks

  10. #10
    Join Date
    Jan 2014
    Beans
    10

    Re: Trouble mounting Seagate Central 3TB Data partition (LVM)

    I could still really use some help with this if anyone is available? Thanks in advance!

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •