Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Resume after suspend 13.10

  1. #1
    Join Date
    Dec 2013
    Location
    Michigan, US
    Beans
    49
    Distro
    Ubuntu 13.10 Saucy Salamander

    Resume after suspend 13.10

    Samsung Laptop When I close the lid it goes to suspend real nice.
    When I open the lid it does not resume. It will resume when I push the power button, but I'd really like it to resume when the lid opens. It worked that way with Win 8.1

    cat /proc/acpi/wakeup
    Device S-state Status Sysfs node
    P0P1 S4 *disabled
    USB1 S3 *disabled
    USB2 S3 *disabled
    USB3 S3 *disabled
    USB4 S3 *disabled
    USB5 S3 *disabled
    USB6 S3 *disabled
    USB7 S3 *disabled
    RP01 S4 *enabled pci:0000:00:1c.0
    RP04 S4 *enabled pci:0000:00:1c.3
    PEG0 S4 *disabled
    PEGP S4 *disabled
    PEG1 S4 *disabled
    PEG2 S4 *disabled
    PEG3 S4 *disabled
    PWRB S5 *enabled

    I think PWRB is the Power button. I tried this
    echo LID0 >/proc/acpi/wakeup

    But no joy.
    I tried looking for the list of what the variiables stand for but nothing real helpful.

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Resume after suspend 13.10

    My laptop wakes on lid open and I don't have a lid entry in /proc/acpi/wakeup either. I do have a setting in my bios to resume on lid open and that seems to work. I believe that in my case this is handled by the bios.

    Is there a setting in your bios to control LID behaviour?

  3. #3
    Join Date
    Dec 2013
    Location
    Michigan, US
    Beans
    49
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Resume after suspend 13.10

    Nope -- nothing specific in the BIOS.

  4. #4
    Join Date
    Dec 2013
    Location
    East Coast of the USA
    Beans
    21
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Resume after suspend 13.10

    Try searching around in your system settings. I believe somewhere there is a submenu where you can select the action that happens when you open/close the lid.

  5. #5
    Join Date
    Jan 2014
    Beans
    8
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Resume after suspend 13.10

    I think it's under "Brightness and Lock"

  6. #6
    Join Date
    Dec 2013
    Location
    Michigan, US
    Beans
    49
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Resume after suspend 13.10

    No nothing under Brightness and Lock. I did find some settings under Power that reference what to do when the lid is closed, but not what to do when the lid is opened.

  7. #7
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Resume after suspend 13.10

    Consider that when your laptop is asleep, userspace is unavailable. Therefore, there is nothing that you can do/configure in userspace to get your system to resume based on an action like lid open because userspace is not "listening". Acpi allows for some triggers/hooks to return your system from suspended states and these are defined in /proc/acpi/wakeup (you can also use rtc to wake up systems, but this is basically via a time-based trigger, not an action-based one like you are looking for). Unfortunately, in your case the LID event is not made available as a action to return your system from suspend. There are a few things you can try:

    1. Look to see if there is a setting in the bios that manages lid actions (this you have already checked)
    2. Ensure that your lid is being properly recognized. Run this command in a terminal:
    Code:
    dmesg | grep -i lid
    ...and see what it says.
    3. Look to see if there is a bios update for your system. Maybe this functionality is added later.
    4. Create a bug report to see if a developer will add this functionality to acpi for your model of laptop. It will probably involve the creation of some sort of model-specific quirk.

    I tried looking for the list of what the variiables stand for but nothing real helpful.
    The USB devices are usb devices connected to your system - it appears that none currently are.
    The RP0 devices are linked to PCI devices - to find out which ones they are, run "lspci" and match the sysfs node values.
    PWRB is your power button, and as you can see, it is enabled.
    The PEG devices I believe are related to your video card (not sure).



    One other thing that you can try, and I'm not sure of the mileage you'll get out of this, is to try different acpi kernel parameters. In some cases, for some laptops, different sets of acpi tables are loaded when different sets of acpi parameters are specified. What is the model # of your Samsung? You can try:
    - acpi_osi=
    - acpi_osi=Linux
    - acpi_osi=\"!Windows 2012\"
    ...and after each attempt, check the contents of /proc/acpi/wakeup to see if the LID is recognized. Follow the "Temporarily Add a Kernel Boot Parameter for Testing" instructions from the Kernel Boot Parameters Wiki to test them.

  8. #8
    Join Date
    Dec 2013
    Location
    Michigan, US
    Beans
    49
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Resume after suspend 13.10

    Heres the results of "dmesg | grep -i lid"

    [ 0.914673] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
    [ 0.914684] ACPI: Lid Switch [LID0]

    Am going to try the Kernel parameter switches next

  9. #9
    Join Date
    Dec 2013
    Location
    Michigan, US
    Beans
    49
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Resume after suspend 13.10

    No luck with the Kernel switches. Whats odd is that this was working with Windows 8.1

  10. #10
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Resume after suspend 13.10

    Quote Originally Posted by devine.steve View Post
    No luck with the Kernel switches. Whats odd is that this was working with Windows 8.1
    In that case, can you try acpi_osi="!Windows 2012" again. When you boot with it, post back:
    Code:
    cat /proc/cmdline
    ...and
    Code:
    cat /proc/acpi/wakeup
    The way you format the "!Windows 2012" string differs based on how you are testing the parameter (temporary vs permanent). Try it temporarily like this:
    Code:
    acpi_osi="!Windows 2012"

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •