Results 1 to 5 of 5

Thread: Run Script @ login with root permissions

Threaded View

  1. #1
    Join Date
    Dec 2013

    Run Script @ login with root permissions

    as the title already says I have problems with running a script.
    The script does the following
    1. mount the device (hdd)
    2. check if gxmessage is installed, if not --> install it
    3. do a backup with rsync

    I have made a udev rule to run the script when the hdd is plugged in. There I have no problem because scripts which are executed by udev rules are executed with root permissions.

    Now here is the problem:
    The hdd is plugged in as long as I dont need the notebook in school and this time I get no backups then.
    So I want the script to be executed at login. I tried this with System Settings -> Preferences -> Startup Programs but it doesent have enough permissions.
    I also tried running it with a command in ~/.profile but there is the same problem.

    If you want to see the udev rule or my script please tell me

    I would be glad if anybody could help me
    Last edited by michikurz; December 29th, 2013 at 12:16 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts