Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Why is PulseAudio the default mixer in Ubuntu?

  1. #1
    Join Date
    Dec 2013
    Beans
    3

    Why is PulseAudio the default mixer in Ubuntu?

    I just switched to Ubuntu from Windows and then I switched to Xubuntu because Unity's Laucher takes up valuable space on my screen.
    While searching stuff about Ubuntu I saw a lot of posts about switching to Alsa. I was using headphones the whole time and when I used my laptop's speaker, I couldn't hear anything. I purged every PulseAudio package in synaptic and installed Alsa Mixer and my speaker works again

    With so many posts about people switching from PulseAudio, why is it the default mixer installed in Ubuntu?

  2. #2
    Join Date
    Aug 2013
    Beans
    3,267

    Re: Why is PulseAudio the default mixer in Ubuntu?

    I don't know. I never have any problem with pulseaudio which cannot be fixed by simply changing a few settings (and that is for other distros, with Ubuntu even that is very rare). I know that there were many posts back in the time of 9.10 or something like that saying that pulseaudio was buggy, but that was a long time ago.

    Somehow there are people who are still stuck in 2009 and they continue to advise others to remove pulseaudio whenever there is any issue with sound and end up messing the system up even more. After messing up my 10.04 sound by removing pulseaudio following one of these people's advice (the problem turned out to be quite easily fixed) I have since followed the policy of ignoring anyone who tells others to remove pulseaudio because the person is likely clueless and probably running an unsupported OS.

    Not knowing any detail I can't say what was wrong with your system, but probably could be fixed by changing a few settings in pauvcontrol or alsamixer without having to remove pulse (I experienced something like that in Manjaro Linux with xfce, some messing with pauvcontrol fixed it)
    Last edited by monkeybrain20122; December 28th, 2013 at 02:48 AM.

  3. #3
    Join Date
    Dec 2013
    Beans
    3

    Re: Why is PulseAudio the default mixer in Ubuntu?

    When I searched I didn't see anything that could solve it, and I tried some solutions to no avail and well, I can't check if it would work with me messing around because I don't remember what packages I removed.

    Most of the problem on the internet were about sounds not working, mine was working when I have my headphones plugged in but it wouldn't work with the laptop's speakers.

  4. #4
    Join Date
    Aug 2006
    Beans
    12,973
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Why is PulseAudio the default mixer in Ubuntu?

    Alsa doesn't always work for everyone, so why is it the default choice? In fact, why anything is?

  5. #5
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Why is PulseAudio the default mixer in Ubuntu?

    Not a support request.

    Moved to Ubuntu, Linux and OS Chat
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  6. #6
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Why is PulseAudio the default mixer in Ubuntu?

    You did open the mixer and check to see what the volume levels where set at (including the page you have to scroll over to), if anything was muted, etc., right? Under sound settings, what was the default output?

  7. #7
    Join Date
    Dec 2005
    Location
    Western Australia
    Beans
    11,480
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Why is PulseAudio the default mixer in Ubuntu?

    There's no reason why your laptop speakers would work with Alsa and not with Pulseaudio.

    Pulseaudio is just a layer on top of Alsa. Pulseaudio doesn't contain any drivers, it just mixes sounds together and feeds them to Alsa. I suggest that you probably just needed to change a wonky default setting in the Pulseaudio mixer.

    The reason why Pulseaudio is default in Ubuntu is simply because it allows for additional features that can't be done, or can't be done easily and reliably, in Alsa. The reason you see so many people saying that they remove Pulseaudio is because it didn't work so well in 2008, and even people whose audio works perfectly well in Pulseaudio today will remove it because that's what they used to have to do.
    I try to treat the cause, not the symptom. I avoid the terminal in instructions, unless it's easier or necessary. My instructions will work within the Ubuntu system, instead of breaking or subverting it. Those are the three guarantees to the helpee.

  8. #8
    Join Date
    Nov 2011
    Beans
    2,336
    Distro
    Ubuntu

    Re: Why is PulseAudio the default mixer in Ubuntu?

    Quote Originally Posted by jgj.adaoag View Post
    ... Unity's Laucher takes up valuable space on my screen.
    The Launcher is easily set to autohide with one click in Settings.

    (Headphones and speakers are often listed as two separate audio output devices. If sound is not configured properly (again, in Settings, and the mixer), then one or both may not be correctly set as an output device for Pulse or Alsa. And, as suggested above, a common source of no sound is simply forgetting to turn the volume up.)
    Last edited by buzzingrobot; December 28th, 2013 at 12:48 PM.

  9. #9
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,057
    Distro
    Ubuntu Development Release

    Re: Why is PulseAudio the default mixer in Ubuntu?

    Unity launcher icon size can be reduced too. Vertical space is not an issue for me on a wide screen monitor or laptop.

  10. #10
    Join Date
    Dec 2013
    Beans
    3

    Re: Why is PulseAudio the default mixer in Ubuntu?

    After all those replies, I decided to give PulseAudio another chance and look for the settings.

    I reinstalled PulseAudio, force reloaded alsa, rebooted and for some magical reason it works with my speakers on the spot without changes. I did this a while back (purging Pulse then reinstall) and it didn't work. I think when I manually removed everything with PulseAudio using synaptic I may have removed the problem.

    Quote Originally Posted by buzzingrobot View Post
    The Launcher is easily set to autohide with one click in Settings.

    (Headphones and speakers are often listed as two separate audio output devices. If sound is not configured properly (again, in Settings, and the mixer), then one or both may not be correctly set as an output device for Pulse or Alsa. And, as suggested above, a common source of no sound is simply forgetting to turn the volume up.)
    I didn't knew about that autohide, but I don't want something to pop out when I accidentaly move my mouse to the side and there are times when I can't reach the keyboard (lying on the bed, laptop on table) so I use the mouse a lot and currently, I have a bottom panel with 20 launchers with the top panel for a list of open programs and other stuff. I don't want a launcher(unity) cramped with launchers(launchers)

    Btw, I checked everything properly during the time of problem, the volume was set to 100% and the output device is not a dummy.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •