Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: New Catalyst 13.12 non-beta is out!

  1. #1
    Join Date
    May 2009
    Location
    Terra Australis
    Beans
    189
    Distro
    Ubuntu

    Lightbulb New Catalyst 13.12 non-beta is out!

    I ran Unigine Valley with the new driver with a R9-290X and looks like I gained 2-3 FPS. I suppose something is better than nothing. LoL

  2. #2
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    2,050
    Distro
    Ubuntu Mate

    Re: New Catalyst 13.12 non-beta is out!

    Well, keep a good thought...

    I drink my Ubuntu black, no sugar.
    Ubuntu user 28819

  3. #3
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: New Catalyst 13.12 non-beta is out!

    will try out the new AMD BETA driver AFTER I use clonezilla to backup my / partition. Thanks for letting me know!

    UPDATE: Gained 8 FPS (from 18.4 to 26.6) in Valley, 5 FPS (from 20.1 to 25.2) in Heaven and a WHOOPING 41 FPS GAINED in the Team Fortress 2 test ran by Phoronix Test Suite (from 54.4 to 95.4). Now that's a SOLID AMD Driver update right there! All I had to do was log out, log into tty1, stop lightdm, run the 13.11v9.4 run file with the --uninstall option as root. Restart the machine. Log into tty1, stop lightdm, install the 13.12 AMD driver using the run file with sudo and restart my machine again and all is well. AWESOME!
    Last edited by dannyboy79; December 22nd, 2013 at 07:07 AM. Reason: added FPS gain

  4. #4
    Join Date
    May 2009
    Location
    Terra Australis
    Beans
    189
    Distro
    Ubuntu

    Re: New Catalyst 13.12 non-beta is out!

    That's awesome! Perhaps most of the fixes were for the mature cards. I got the immature R9-290X. Hopefully I'll get more FGLRX-loving from the new drivers coming in Jan.

    On another note, I finally got leave from work and was able to spend the last couple of days watercooling the R9; it is now running at a constant 1GHz. I think I'll play Metro LL all over again knowing I'm now getting a constant 1GHz!

  5. #5
    Join Date
    Dec 2013
    Location
    Rochester, NY
    Beans
    15
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: New Catalyst 13.12 non-beta is out!

    I had no such luck with the new driver... black screen after i login... i noticed that your running 12.04 though do you know of any issues with fglrx and 13.10? (and if you do give me some links please) Thanks

  6. #6
    Join Date
    Feb 2009
    Location
    Slovenija
    Beans
    Hidden!

    Re: New Catalyst 13.12 non-beta is out!

    You should completely uninstall the old driver, remove /etc/X11/xorg.conf and reboot (make sure you have generic ati driver installed: https://help.ubuntu.com/community/RadeonDriver). Then download the driver from here http://archive.ubuntu.com/ubuntu/poo...aller-updates/ . The version number is 13.125. Download all packages with the number (for your architecture offcourse), install as sudo
    Code:
    dpkg -i *deb
    If there are dependency problems, run
    Code:
    sudo apt-get install -f
    After installation run
    Code:
    sudo amdconfig --initial
    and reboot. If your hardware is supported, this should always work.

    The performance improvement from 13.11 v9.4 for me is minor (+/- 3% - probably experimental error), xonotic performance dropped 3%. So no actual gains for me (HD 7750).

  7. #7
    Join Date
    May 2006
    Location
    Milwaukee,WI
    Beans
    6,282
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: New Catalyst 13.12 non-beta is out!

    WOW, i'm shocked I saw an 8 FPS increase with my HD7770 but you didn't see any gain with your HD7750.

  8. #8
    Join Date
    Feb 2009
    Location
    Slovenija
    Beans
    Hidden!

    Re: New Catalyst 13.12 non-beta is out!

    I think this is something you can expect from my version of HD7750. It's already heavily factory overclocked and it's running near the power limits of the PCI-E slot (remember, my card has no power connector). This means the power management tweaks your card might receive, won't have big effects on my card, since there is no juice to improve performance. Also, various sotware combinations might have different impacts on performance. I use heavy DE (KDE), you use lightweight XFCE (probably). I would say that my card is already running at it's best since the 12.4 drivers came out, there is hardly anything to fix, maybe some tweak here and there. The only thing I'm missing is ZeroCore Power support.

  9. #9
    Join Date
    Dec 2013
    Location
    Rochester, NY
    Beans
    15
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: New Catalyst 13.12 non-beta is out!

    Well after reading the post by R33D3M33R and going through the help link and another link on that page i tweaked a few things and am going to try the 13.12 driver again. If that doesn't work ill grab the 13.11 he reccomended and try that. If that doesn't work, ill take the video card out and get a hammer, then go buy the gtx 770 ive been looking at Thanks for all the help!!

    Update: i made a post of the error i recieved installing 13.12 in the thread i started Driver questions including the make.log file that shows the error... if any of you could tell me what it means in english that would help a lot thanks
    Last edited by sjackling; December 30th, 2013 at 06:33 PM.
    Desktop:IntelDP55KGMoboUnlockedIntelCorei7k875CPU@2.93 GHz+CoolerMasterV88GBDDR31333MHzASUSEAH5770CuCore1TBHDD OS:Win7Ultimatex64/Ubuntux64 Laptop:HPPavilion15NotebookPC OS:Win8Corex64

  10. #10
    Join Date
    Apr 2006
    Beans
    21

    Re: New Catalyst 13.12 non-beta is out!

    As I play a lot in Ubuntu and have a HD6870, I would love to try these drivers out. I'm on 12.04 so the ones installed via the "Additional drivers" are pretty old, I think.

    Always when I install a driver manually, the fglrx module cannot be loaded and when I try to do "amdconfig --initial" I get an error that libgl.so.1 cannot be found. This happened with this latest version also. The installer itself gives no error.

    Anyone have any idea why? Is there a package I'm missing or something?

    (Maybe I should post a new topic with more details..)

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •