Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Letters that don't show properly in browser

  1. #1
    Join Date
    Dec 2007
    Beans
    4

    Unhappy Letters that don't show properly in browser

    I have a problem that it is a bit difficult to explain. After updating to the most recent release of xubuntu I have problems when browsing with Firefox. Sometimes, some letters (up to 3 or so per page) fail to display properly, and instead the browser shows a small point, an empty space, or a small black symbol. When realoading or when scrolling down until the text dissappears and then scrolling upwards again, the letters that were not displayed correctly appear and some of the ones displayed correctly are substituted by these points or small symbols. In fact, while I am writing this lines, some of the letters are turned into the points/symbols and back again to normal. It is very annoying!!

    What could be causing this behaviour?

    Best,

    Fran

  2. #2
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,054
    Distro
    Ubuntu Development Release

  3. #3
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Letters that don't show properly in browser

    If you have an intel graphics card and are using 13.10, the default acceleration method was changed from uxa to sna. On some systems, sna acceleration causes graphic "artefacts". The solution (workaround?) is to revert to uxa acceleration.

    To find out which acceleration method you are using:
    Code:
    cat /var/log/Xorg.0.log | grep -i accelmethod
    ...example result:
    [ 4.104] (**) intel(0): Option "AccelMethod" "sna"
    To revert to uxa acceleration, with root privileges, create a /usr/share/X11/xorg.conf.d/20-intel.conf file with the following content:
    Code:
    Section "Device"
    	Identifier 	"Intel Graphics"
    	Driver 		"intel"
    	Option		"AccelMethod"		"uxa"
    	Option		"TearFree"		"true"
    EndSection
    ...save the file, log out and log in again.

    On reboot, check whether its properly enabled with:
    Code:
    cat /var/log/Xorg.0.log | grep -i accelmethod
    ...and check for the artifacts again.

    ***Remember, this will only work with intel graphics cards.

  4. #4
    Join Date
    Dec 2007
    Beans
    4

    Re: Letters that don't show properly in browser

    The code
    Code:
    cat /var/log/Xorg.0.log | grep -i accelmethod
    does not return anything

    Code:
    lspci | grep VGA
    returns:

    Code:
    >00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
    Do you think the workaround would work in my system?

  5. #5
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Letters that don't show properly in browser

    You do have an intel card.

    What version of ubuntu are you running and what kernel is active?
    Code:
    uname -r
    Can you post back your complete /var/log/Xorg.0.log file?

  6. #6
    Join Date
    Dec 2007
    Beans
    9,281
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Letters that don't show properly in browser

    Hi Toz, I'm having the same problem but not as severe as the OP has. In my case, these malformed letters appear quite infrequently. My hardware is a Dell Inspiron 1545 laptop.

    The /var/log/Xorg.0.log details are here:
    http://paste.ubuntu.com/6603101/
    because grepping for accelmethod didn't return anything.

    And uname -r gives
    Code:
    3.11.0-14-generic
    Edit: I understand that my graphics is "integrated" and incapable of hardware acceleration.
    Last edited by vasa1; December 20th, 2013 at 03:18 AM.

  7. #7
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Letters that don't show properly in browser

    Looks like I goofed again. The command should be:
    Code:
    cat /var/log/Xorg.0.log | grep -i sna
    ...to see if SNA is enabled and:
    Code:
    cat /var/log/Xorg.0.log | grep -i uxa
    ...to see if UXA is enabled.

    Vasa1, in your case:
    [ 25.176] (II) intel(0): SNA initialized with Eaglelake (gen4.5) backend
    ...yes, sna is enabled. You can try using uxa instead with the file above.

    I have the same problem on my laptop (not severe at all) and disabling SNA gets rid of it but I notice that graphics performance is better with SNA.

  8. #8
    Join Date
    Mar 2009
    Location
    The Freight Yard
    Beans
    212
    Distro
    Ubuntu Mate 16.10 Yakkety Yak

    Re: Letters that don't show properly in browser

    First of all, I would like to thank Toz for showing what's up with the funny letters problem. My Dell Studio 1745 was doing the same thing so after seeing I indeed had sna instead of uxa I added the 20-intel.conf file as you suggested.

    Hilarity ensued, as the funniest graphics problems occurred during boot up. First, the KDM Login menu graphic grew 3 sizes too big. Then the KDE splash screen spinning indicator showed up 3 sizes too small (guess KDE was having a Grinch moment there). Then it starts showing the desktop, but in slices far right, then a second later the middle then finally the left. I tried rebooting, same thing. Removed the 20-intel.conf file, rebooted, everything's back to normal. Hmmmmm........

    To be honest, I have NO Idea what went wrong there, but sure hope Intel gets a working display driver out soon.

    Of course, other peoples experiences will probably be different, but gosh I wish I had a Cell Phone or Digital camers so I could have filmed it, it was pretty funny (scary at first, but funny).

    Oh Snap, I forgot to say this was all going on on the external monitor, as the primary laptop screen is broken. Lucky for me I had rearranged the grub2 menu to have Kubuntu first & Windows 7 second in the order so all I have to do is wait a couple of seconds & hit enter.
    Last edited by SantaFe; December 20th, 2013 at 03:53 PM. Reason: Forgot to mention it was happening on an external monitor. ;)
    This post is like Brigadoon!

  9. #9
    Join Date
    Dec 2007
    Beans
    9,281
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Letters that don't show properly in browser

    Quote Originally Posted by Toz View Post
    ...
    I have the same problem on my laptop (not severe at all) and disabling SNA gets rid of it but I notice that graphics performance is better with SNA.
    Thank you for mentioning the trade-off. In that case, I'll stay with the infrequent deformed letters (and keep this in mind in case things get unbearable). But if you know of a bug to "me too", please let us know.

  10. #10
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Letters that don't show properly in browser

    @SantaFe, really weird, I've never heard of an issue like that. I wouldn't mind seeing your Xorg.0.log file from that boot (Xorg.0.log.old?)

    @Vasa1, here is an article from Phoronix about UXA/SNA performance benchmarks.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •