Results 1 to 3 of 3

Thread: Can't boot after upgrade.

  1. #1
    Join Date
    Apr 2005
    The Peoples republic of Poulton-Le-Fylde

    Can't boot after upgrade.


    I tried to do a release upgrade on my home server the other day, from 11.10 to 12.04, after which it will not boot. The file system appears to be present as I can view it from a live CD but grub fails with an "Error 15 File Not Found" message. I've tried using the grub menu and have tried using all the listed kernel images (there are about 6 present) but none of them work (including the recovery console options) and they all fail with the same "Error 15 File Not Found" message.

    Additionally I've tried manually running grub from it's command line by doing the following:

    grub> find /grub/stage1
    root (hd0,2)
    grub> root (hd0,2)
    grub>kernel (hd0,2)/boot/<TAB>
    But this gives me the same "Error 15 File Not Found" message.

    Following this I also tried reinstalling grub which seemed to suggest it worked but after rebooting I still get the same "Error 15 File Not Found" message. I am confident that there is no hardware problem as the box has been running fine for about 5 years now and the S.M.A.R.T. on the disk shows it to be fine (it was running splendidly until I tried the dist upgrade).

    At this point I have taken a copy of my /etc directory so if this can't be fixed I could do a reinstall but I would like to fix it if possible. So if anyone has any ideas what to try I'd be most grateful ?

    Failing that I would like to know if it's possible to reinstall from an Ubuntu server CD without formatting the disk (I've just downloaded the 12.04 CD) ?


  2. #2
    Join Date
    Jun 2006
    Houston, TX
    Ubuntu 6.06

    Re: Can't boot after upgrade.

    Is it a large hard drive on an old motherboard? If so, it may have loaded the new boot image in a part of the drive the BIOS can't see...

  3. #3
    Join Date
    Jul 2011
    Ubuntu 13.10 Saucy Salamander

    Re: Can't boot after upgrade.

    Try boot-repair and follow instructions here

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts