I was reading the man pages and was going to list the devices available to ghostscript. I misread and did this:

gs devicenames ==


Of course that didn't do anything but an error. Then I realized I was supposed to run gs like a program and then type in devicenames == which gave me the names.

However, now gs is fubar. I can't do what I want without it giving the same error (which it didn't used to do that before).

Example:


gs -sDEVICE=pdfwrite -dCompatibilityLevel=1.4 -dPDFSETTINGS=/screen -dNOPAUSE -dQUIET -dBATCH -sOutputFile=MyPDFFile-New.pdf MyPDFFile.pdf

Now this is run in the same directory that MyPDFFile.pdf is in so it does exist and I was sure to type it exactly (matching upper and lower case). However, I get this:


Error: /undefinedfilename in (MyPDFFile.pdf)
Operand stack:

Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push
Dictionary stack:
--dict:1169/1684(ro)(G)-- --dict:0/20(G)-- --dict:77/200(L)--
Current allocation mode is local
Last OS error: No such file or directory
GPL Ghostscript 9.06: Unrecoverable error, exit code 1



What is going on? It worked before...

Can someone tell me how to reset the configuration so it will work again?

Thanks.