Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: The action would require the installation of packages from not authenticated sources

  1. #1
    Join Date
    Nov 2013
    Beans
    25

    The action would require the installation of packages from not authenticated sources

    i am trying to install CAPS plugins from ubuntu software center. all used to work fine, but now everything i try to install from there gives me this result:

    The action would require the installation of packages from not authenticated sources

    and the installation gets impossible.
    what should i do? i am a totally beginner , need very basic instructions. i know the terminal window, but dont know rules to type in proper commands.
    thanks!

  2. #2
    Join Date
    Sep 2006
    Beans
    8,627
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: The action would require the installation of packages from not authenticated sour

    Have you refreshed the package database?

    Code:
    sudo apt-get update
    That is often necessary before embarking on a major installation. Otherwise, the versions may not match and you can get errors.

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: The action would require the installation of packages from not authenticated sour

    In what way does the installation get impossible? That message is usually a request for the user to take responsibility for installing that package. Are you installing the version in the Ubuntu Software Centre or are you using the Software Centre to install a later version from the web site? I have just now installed C* Audio Plugin Suite (CAPS) from the Software Centre as a test and I did not have any problem. Nor, did I get that message.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Nov 2013
    Beans
    25

    Re: The action would require the installation of packages from not authenticated sour

    i did that, and at the end it said:
    W: Errore GPG: http://it.archive.ubuntu.com precise Release: Le seguenti firme non erano valide: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    then i tried again to install, and it did the same, it stops, gives the message


    The action would require the installation of packages from not authenticated sources

    and then let you choose "ok" and "repair", tried both ways but it never installes the software.

  5. #5
    Join Date
    Nov 2013
    Beans
    25

    Re: The action would require the installation of packages from not authenticated sour

    sorry, i did not understand what you meant. i just clicked the "install" button on the ubuntu software center, and got that result (even with any other software). thanks

  6. #6
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,909
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: The action would require the installation of packages from not authenticated sour

    stefabarta; Hi !

    Looks like you have also lost the signing key for the ubuntu archive.

    To authenticate; Terminal code:
    Code:
    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
    and now try and update the system:
    Terminal codes:
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    And advise us of status.


    just my bit to help
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  7. #7
    Join Date
    Nov 2013
    Beans
    25

    Re: The action would require the installation of packages from not authenticated sour

    i did that, and again the reply was some bad signatures:

    W: Errore GPG: http://it.archive.ubuntu.com precise Release: Le seguenti firme non erano valide: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    however about upgrading it said "0" needed updates

  8. #8
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,909
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: The action would require the installation of packages from not authenticated sour

    stefabarta; Well,

    That is not at all the norm.

    Try this:
    Try deleting the key:
    Code:
    sudo apt-key del 40976EAF437D05B5
    then updating the repository
    Code:
    sudo apt-get update
    You should get a NO_PUBKEY error instead of a BADSIG error and
    Code:
    sudo apt-key finger
    should not find the key (called "Ubuntu "XXXX" Archive Automatic Signing Key")

    Now add the key
    Code:
    sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5
    The result of apt-key finger should have
    pub <validation number> <date>
    Should be something similar to this:
    Key fingerprint = <validation number>C474 15DF F48C 0964 5B78 4097 6EAF 437D 05B5
    uid Ubuntu "XXXX" Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    maybe yes ?
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  9. #9
    Join Date
    Nov 2013
    Beans
    25

    Re: The action would require the installation of packages from not authenticated sour

    hey, first of all thx for your help!
    i tried all that and this was in fact the result:

    pub 1024D/FBB75451 2004-12-30
    Key fingerprint = C598 6B4F 1257 FFA8 6632 CBA7 4618 1433 FBB7 5451
    uid Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>

    pub 1024D/3E5C1192 2010-09-20
    Key fingerprint = C474 15DF F48C 0964 5B78 6094 1612 6D3A 3E5C 1192
    uid Ubuntu Extras Archive Automatic Signing Key <ftpmaster@ubuntu.com>

    pub 4096R/C0B21F32 2012-05-11
    Key fingerprint = 790B C727 7767 219C 42C8 6F93 3B4F E6AC C0B2 1F32
    uid Ubuntu Archive Automatic Signing Key (2012) <ftpmaster@ubuntu.com>

    pub 4096R/EFE21092 2012-05-11
    Key fingerprint = 8439 38DF 228D 22F7 B374 2BC0 D94A A3F0 EFE2 1092
    uid Ubuntu CD Image Automatic Signing Key (2012) <cdimage@ubuntu.com>

    pub 1024R/DF8063EB 2010-12-12
    Key fingerprint = A809 F6C3 07B5 8313 3B38 91B2 8753 8FED DF80 63EB
    uid Launchpad PPA for KXStudio Team

    pub 1024D/7FAC5991 2007-03-08
    Key fingerprint = 4CCA 1EAF 950C EE4A B839 76DC A040 830F 7FAC 5991
    uid Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>
    sub 2048g/C07CB649 2007-03-08

    pub 1024R/E2D0EBE9 2012-01-04
    Key fingerprint = AB3C 1187 1E5A DDD6 37F8 BAA8 9B0B BF00 E2D0 EBE9
    uid Launchpad PPA for RAVEfinity Project

    stefano@stefano-Satellite-A100:~$
    stefano@stefano-Satellite-A100:~$
    stefano@stefano-Satellite-A100:~$ sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 40976EAF437D05B5


    i have no idea what exactly i did, but it seemed to flow as you said. now should i try to install the package from ubuntu software center? or restart everything? thanksss a lot!

  10. #10
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,909
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: The action would require the installation of packages from not authenticated sour

    stefabarta; Hello;

    I expect you are in good shape, I would however prefer to do the package install from the command. From the command line we get better error reporting in the event of a problem.

    Code:
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install <the_CAPS_package_name>
    If that goes well, try the Software Center and see what results.

    cheers ??
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •