Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: xscreensaver unlock dialogue, possible to get fonts large enough to see?

  1. #1
    Join Date
    Sep 2011
    Beans
    615

    xscreensaver unlock dialogue, possible to get fonts large enough to see?

    As things stand, when unlocking from xscreensaver's lock I'm typing blind on faith because the characters (dots, stars, who knows?) are so tiny I can't even tell whether a key press registered once, twice, or not at all. Using a wireless (ok, a CHEAP wireless) keyboard that's not something that can be taken for granted. Frequently I have to try 3 or 4 times before I get it. I've been searching and reading on this off an on for months and more intensively for the past 48 hours or so.

    What I read is, in a word, strange. Seems like it has been a problem for a fair number of people for quite a while, but others seem to have no problem changing their font size. This thread
    http://ubuntuforums.org/showthread.p...+missing+fonts
    while actually about changing fonts in the "hacks" (i.e., individual screensavers) may be relevant. It seems to be more technically astute than anything else I've read touching on the subject. But the last post is a year and a half old, it doesn't really address quite the same issue, and anyway I tried the font that was mentioned in there without success. I've tried a lot of different font lines found reccomended in varilus fora in the .xresources file. All but the last were in exactly the same format. Just now I tried the line in the thread I just referenced, which is a little longer. Still no change. Nothing I put in .xresources or whether I even HAVE an .xresources file makes any difference.

    There are a lot of threads about making the unlock dialogue "prettier". I don't give a hoot about how pretty it is. I just want to be able to see the darned thing.

    At this point I can only think of 2 options I haven't tried yet that have a reasonalbe chance of working:

    1 - Use a script to call xscreensaver and lower the rez with xrandr before the lock command and raise it after unlocking. I tried that manually and it did work but it was rather slow.
    -- or --
    2 - Get the source, see if I can figure out how to edit it so it points to some font known in the civilised world and compile it. I've never done that but perhaps now is the time to learn it.

    Any suggestions would be appreciated.

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Xscreensaver can be "skinned" by editing the ~/.Xdefaults file (in your home folder). If it is the font size that you want to change, the lines of interest are:
    !font settings
    xscreensaver.Dialog.headingFont: -*-dina-bold-r-*-*-10-*-*-*-*-*-*-*
    xscreensaver.Dialog.bodyFont: -*-dina-medium-r-*-*-10-*-*-*-*-*-*-*
    xscreensaver.Dialog.labelFont: -*-dina-medium-r-*-*-10-*-*-*-*-*-*-*
    xscreensaver.Dialog.unameFont: -*-dina-medium-r-*-*-10-*-*-*-*-*-*-*
    xscreensaver.Dialog.buttonFont: -*-dina-bold-r-*-*-10-*-*-*-*-*-*-*
    xscreensaver.Dialog.dateFont: -*-dina-medium-r-*-*-10-*-*-*-*-*-*-*
    xscreensaver.passwd.passwdFont: -*-dina-bold-r-*-*-20-*-*-*-*-*-*-*
    On my system, I don't have the dina font installed so making changes to those lines won't make a difference. However, I do have the "georgia" font installed, so lets give it a try. (The "xfontsel" program can be used to see which fonts are installed on your system.)

    1. Kill the xscreensaver process (it stores the resource information at each startup and we need to have this refreshed):
    Code:
    kill -9 $(pidof xscreensaver)
    2. Edit the .Xdefaults file in your home directory, delete the lines above and replace them with:
    Code:
    !font settings
    xscreensaver.Dialog.headingFont:        -*-georgia-bold-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.bodyFont:           -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.labelFont:          -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.unameFont:          -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.buttonFont:         -*-georgia-bold-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.dateFont:           -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.passwd.passwdFont:         -*-georgia-bold-r-*-*-36-*-*-*-*-*-*-*
    ...note that I have set the font size to 36.

    3. Save the file.

    4. Merge the changes in:
    Code:
    xrdb -merge ~/.Xdefaults
    5. Restart the xscreensaver process:
    Code:
    xscreensaver -no-splash
    6. Test. You should get larger font sizes in the xscreensaver unlock screen. Make any other font changes as required following the same process as above. Note that the ~/.Xdefaults file is sourced on every login so you don't have to run "xrdb -merge" every time, only when we are testing (so we don't have to log out and back in again).

  3. #3
    Join Date
    Sep 2011
    Beans
    615

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Thanks, Toz. It's very strange. I distinctly remember composing, previewing, and POSTING (I could have sworn) a reply to this about an hour after your kind response. But it's not here. I must be losing my marbles.

    Anyway, we are at least on what is new ground for me here as all the other things I've read on this talk about similar code being put in .Xresources rather than .Xdefaults. I had no .Xdefaults so I made one and tried it 2 ways, first with an exact copy of your code, on the strength of the probability that if you had that font installed and didn't mention having installed it, probably I did too. That didn't cause any change in the font size in the unlock dialogue. So then I used xfontsel, clicked on the pxlsz heading, got a drop down menu of numbers and clicked on the highest one which was 32 and one of the middle asterixes was changed to 32. Then I clicked and chose something for all the other headings until I had a line where all asterixes were replaced with something. If I understand xfontsel correctly to this degree, that line should have fully specified some font that I have installed. I replaced all the corresponding strings in .Xdefaults with with that string and tried again. Both times I rebooted. No change. One point, seemingly odd to me, about xfontsel. The fonts listed don't seem to correspond all that well to the choices I typically get in some application with adjustable fonts, like gedit for instance. It's a much shorter list and only a couple of the entries sound familiar. I'm not sure what to make of that.

    Anyway, thanks for the ideas. So far though, I haven't gotten it to work. Now let's see if I can make this post successfully this time.

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    I think I may have made the .Xdefaults file a while ago myself and have kept recycling it. It shouldn't matter which file you put it in during the testing as long as you merge it in (using "xrdb -merge <file>"). The important thing is to make sure that the file you use is sourced during login. I believe both .Xdefaults and .Xresources are if they exist in the home directory.

    As for the fonts, I find you have to find the correct font for rendering or it doesn't work. I just tried a number of different ones displayed in xfontsel, and couldn't get some to work. The georgia font that I used is in the ttf-mscorefonts-installer package - make sure it is installed if you want to try the this font. You can check if the font itself is installed via:
    Code:
    fc-list  | grep georgia
    Using this process changes the fonts on the xscreensaver lock screen for me. I am using Xubuntu 13.10.

    One final thing - make sure you test using the process I identified above (no rebooting). Once you get that to work, then you can try rebooting to see if it becomes persistent.

  5. #5
    Join Date
    Sep 2011
    Beans
    615

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Thank you again, Toz. I followed your instructions EXACTLY this time, varying nothing.
    Code:
    fc-list  | grep georgia
    returned only a new prompt. I installed ttf-mscorefonts-installer, did it again and it showed up this time. I deleted everything in .Xdefaults and copied your code in in it's entirety. Followed the rest of your procedure precisely. Still no change. So I rebooted for good measure. Still no change.

    I find it interesting that you observe some fonts work and others don't. That suggests trying fonts at random or systematically trying all I have may be worthwhile. I'll try that for a while.

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Not sure if it matters, but that was only a snippet from my .Xdefaults file. Here is the complete listing:
    Code:
    ! xscreensaver ---------------------------------------------------------------
    
    !font settings
    xscreensaver.Dialog.headingFont:        -*-georgia-bold-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.bodyFont:           -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.labelFont:          -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.unameFont:          -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.buttonFont:         -*-georgia-bold-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.Dialog.dateFont:           -*-georgia-medium-r-*-*-36-*-*-*-*-*-*-*
    xscreensaver.passwd.passwdFont:         -*-georgia-bold-r-*-*-36-*-*-*-*-*-*-*
    !general dialog box (affects main hostname, username, password text)
    xscreensaver.Dialog.foreground:         #EDEDED
    xscreensaver.Dialog.background:         #202020
    xscreensaver.Dialog.topShadowColor:     #202024
    xscreensaver.Dialog.bottomShadowColor:  #202024
    xscreensaver.Dialog.Button.foreground:  #EDEDFF
    xscreensaver.Dialog.Button.background:  #444
    !username/password input box and date text colour
    xscreensaver.Dialog.text.foreground:    #EDEDFF
    xscreensaver.Dialog.text.background:    #444
    xscreensaver.Dialog.internalBorderWidth:24
    xscreensaver.Dialog.borderWidth:        0
    xscreensaver.Dialog.shadowThickness:    2
    !timeout bar (background is actually determined by Dialog.text.background)
    xscreensaver.passwd.thermometer.foreground:  #A9B7C4
    xscreensaver.passwd.thermometer.background:  #202020
    xscreensaver.passwd.thermometer.width:       8
    !datestamp format--see the strftime(3) manual page for details
    xscreensaver.dateFormat:    %I:%M%P %a %b %d, %Y

  7. #7
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Do you have a ~/.xscreensaver or a ~/.Xresources file? If so, can you post back the contents?
    Last edited by Toz; November 24th, 2013 at 05:41 PM.

  8. #8
    Join Date
    Sep 2011
    Beans
    615

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Quote Originally Posted by Toz View Post
    Do you have a ~/.xscreensaver or a ~/.Xresources file? If so, can you post back the contents?
    Thanks again, Toz. I've attached those files and 2 others that might concievably be relevant. I had to add the extension ".txt" not on the originals to some of them to get them to attach.
    Attached Files Attached Files

  9. #9
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Okay, lets try this (using my ~/.Xdefaults config files with the georgia font):

    Code:
    sudo bash
    cd /usr/share/fonts/truetype/msttcorefonts;mkfontdir
    exit
    ...then:
    Code:
    xset +fp /usr/share/fonts/truetype/msttcorefonts/
    xset fp rehash
    ...then check that georgia appears with:
    Code:
    xlsfonts  | grep -i georgia
    If it does, then merge in the .Xdefaults file:
    Code:
    xrdb -merge ~/.Xdefaults
    ...and check to see if the georgia font is merged into your resource file:
    Code:
    xrdb -query | grep georgia
    ...if its not, you need to run:
    Code:
    xrdb -merge ~/.Xdefaults"
    ...first.

    Then lets restart xsscreensaver:
    Code:
    xscreensaver-command -restart
    ...and test.
    Last edited by Toz; November 25th, 2013 at 03:29 AM.

  10. #10
    Join Date
    Sep 2011
    Beans
    615

    Re: xscreensaver unlock dialogue, possible to get fonts large enough to see?

    Thanks much, Toz. You're taking a lot of time with this and I do appreciate it. Interesting stuff. You're coming up with commands I never heard of and it'll take a bit of studying man pages and such before I can see where you're heading. But I won't hold up for comprehension. For the moment, I follow blindly, which is why I'm unsure whether you really meant that lone unpaired " mark. So:

    I deleted everything in my .Xdefaults and replaced it with the exact and ENTIRE contents of yours.

    Then in lxterminal:
    Code:
    me@ubuntu:~$ sudo bash
    [sudo] password for me: 
    root@ubuntu:~# cd /usr/share/fonts/truetype/msttcorefonts;mkfontdir
    root@ubuntu:/usr/share/fonts/truetype/msttcorefonts# exit
    exit
    me@ubuntu:~$ xset +fp /usr/share/fonts/truetype/msttcorefonts/
    me@ubuntu:~$ xset fp rehash
    me@ubuntu:~$ xlsfonts  | grep -i georgia
    me@ubuntu:~$ xrdb -merge ~/.Xdefaults"
    > ^C
    At that point I saw the arrow and looked more closely at what I'd copied and pasted and decided the " mark was a typo. So I entered the Cntrl-C [enter] for a new prompt and reentered that line without the " mark and continued:
    Code:
    me@ubuntu:~$ xrdb -merge ~/.Xdefaults
    me@ubuntu:~$ xscreensaver-command -restart
    xscreensaver-command: restarting.
    Then I tested it. The color stuff in the .Xdefaults file was picked up but the font size was unchanged. That, btw, is consistent with the response I've gotten from stuff I've put in .Xresources in the past. I have no problem changing color (except for one of the white areas in the logo I haven't been able to change yet) but nothing I've done affects font size. I can't say I've seen any evidence that the font style has ever been affected either but that's hard to be sure of, since they border on microscopic. So anyway, I thought, what if you really DID mean to have that unpaired " mark? So I did this:
    Code:
    me@ubuntu:~$ xrdb -merge ~/.Xdefaults"
    > xrdb -merge ~/.Xdefaults
    > xscreensaver-command -restart
    >
    and concluded it really was a typo.

    Then I studied what I'd done to see if maybe I'd left out something unstated but logically implied since I'd been kind of in the copy/paste automaton mode and this part seems odd to me:
    Quote Originally Posted by Toz View Post
    ...then check that georgia appears with:
    Code:
    xlsfonts  | grep -i georgia
    If it does, then merge in the .Xdefaults file:
    Code:
    xrdb -merge ~/.Xdefaults
    ...and check to see if the georgia font is merged into your resource file:
    Code:
    xrdb -query | grep georgia
    ...if its not, you need to run:
    Code:
    xrdb -merge ~/.Xdefaults"
    ...first.

    Then lets restart xsscreensaver: . . .
    So I check to see if it worked and if it didn't I just do the same thing again? Am I missing something? [see next post - I figured this part out, mea culpa]
    Last edited by Dreamer Fithp Apprentice; November 25th, 2013 at 08:37 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •