Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Reboot instead of shutdown

  1. #1
    Join Date
    Aug 2009
    Beans
    8

    Reboot instead of shutdown

    Hi,
    I use ubuntu 13.10 on acer aspire v5-571 laptop.When i try to shutdown my laptop restarts.I try on battery and on ac power but always happens the same. How to fix this?
    Thanks.

  2. #2
    Join Date
    Jun 2011
    Location
    North Carolina
    Beans
    463
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Reboot instead of shutdown

    Are you attempting shutdown with the Shut Down button (located in top right menu of Unity)?

    On some hardware, if you press the hardware power button, it intiates a reboot. To do a hard shutdown, you hold the hardware power button. Though it is best to shutdown from your OS (using Shut Down button in menu).

  3. #3
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,965
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Reboot instead of shutdown

    Try running the following command from a terminal and see which it does:
    Code:
    sudo shutdown -P now
    Jane, stop this crazy thing!

  4. #4
    Join Date
    Aug 2009
    Beans
    8

    Re: Reboot instead of shutdown

    @new85 I've tried that. Same problem...

  5. #5
    Join Date
    Aug 2009
    Beans
    8

    Re: Reboot instead of shutdown

    Quote Originally Posted by BBQdave View Post
    Are you attempting shutdown with the Shut Down button (located in top right menu of Unity)?

    On some hardware, if you press the hardware power button, it intiates a reboot. To do a hard shutdown, you hold the hardware power button. Though it is best to shutdown from your OS (using Shut Down button in menu).
    When i use the shut down menu it shutdown and after 3 sec laptop starts by itself. I can only shutdown when i hold the hardware power button.

  6. #6
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,042
    Distro
    Ubuntu Development Release

    Re: Reboot instead of shutdown

    Is there some setting in the bios that's causing this.

  7. #7
    Join Date
    Aug 2009
    Beans
    8

    Re: Reboot instead of shutdown

    I don't think so, on windows everything works fine.

  8. #8
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,042
    Distro
    Ubuntu Development Release

    Re: Reboot instead of shutdown

    Quote Originally Posted by dejan_87 View Post
    I don't think so, on windows everything works fine.
    There is a thing called "wake on lan motherboard" IIRC.

    Try switching off the router and then see if it shutsdown as it should.

  9. #9
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Reboot instead of shutdown

    Please provide following info:

    1. Is this your first experience with Ubuntu? If not, did it happen with previous versions?
    2. Was behaviour okay prior to some update, or has this been the behaviour from the start?
    3. Did you change any settings? eg. configuration files? If so, what did you change?
    4. Do you have external devices attached to your laptop? eg. USB drive? Name all.
    5. Are you running 32-bit or 64-bit? Please post back output of
    Code:
    uname -a
    Google shows that there can be any one of half a dozen reasons for this behaviour. You may wish to start with the least disruptive options first:

    1. Install laptop-mode-tools which may install enough laptop config settings to allow Ubuntu to poweroff elegantly. After install, choose laptop mode.
    Code:
    sudo apt-get update && sudo apt-get install laptop-mode-tools
    2. If above doesn't solve your problem and you don't need the wake-on-lan feature, then go into BIOS and turn this feature off.

    3. Set ACPI to not route IRQs. A captured IRQ that the kernel doesn't release could cause BIOS to always cycle rather than power off. Using either "sudo nano" or "gksudo gedit", add "acpi=noirq" to GRUB as follows:
    Code:
    gksudo gedit /etc/default/grub
    Find the line starting GRUB_CMDLINE_LINUX_DEFAULT and add acpi=noirq to the end between the quote marks so that it resembles
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq"
    Code:
    sudo update-grub
    This change cannot take effect until after at least one full reboot cycle, so don't expect it to power off your machine the first time. If problem remains, then reverse procedure and take out the change. No point in diminishing functionality if it doesn't do anything.

    There have been reports in other distro forums of the 3.11 kernel being wonky with shutdowns. Version 13.10 is relatively new, so it's not surprising to hear that bugs are still cropping up. If so, then no solution may exist until it's fixed in a future update.

  10. #10
    Join Date
    Aug 2009
    Beans
    8

    Re: Reboot instead of shutdown

    Quote Originally Posted by DuckHook View Post
    Please provide following info:

    1. Is this your first experience with Ubuntu? If not, did it happen with previous versions?
    2. Was behaviour okay prior to some update, or has this been the behaviour from the start?
    3. Did you change any settings? eg. configuration files? If so, what did you change?
    4. Do you have external devices attached to your laptop? eg. USB drive? Name all.
    5. Are you running 32-bit or 64-bit? Please post back output of
    Code:
    uname -a
    Google shows that there can be any one of half a dozen reasons for this behaviour. You may wish to start with the least disruptive options first:

    1. Install laptop-mode-tools which may install enough laptop config settings to allow Ubuntu to poweroff elegantly. After install, choose laptop mode.
    Code:
    sudo apt-get update && sudo apt-get install laptop-mode-tools
    2. If above doesn't solve your problem and you don't need the wake-on-lan feature, then go into BIOS and turn this feature off.

    3. Set ACPI to not route IRQs. A captured IRQ that the kernel doesn't release could cause BIOS to always cycle rather than power off. Using either "sudo nano" or "gksudo gedit", add "acpi=noirq" to GRUB as follows:
    Code:
    gksudo gedit /etc/default/grub
    Find the line starting GRUB_CMDLINE_LINUX_DEFAULT and add acpi=noirq to the end between the quote marks so that it resembles
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=noirq"
    Code:
    sudo update-grub
    This change cannot take effect until after at least one full reboot cycle, so don't expect it to power off your machine the first time. If problem remains, then reverse procedure and take out the change. No point in diminishing functionality if it doesn't do anything.

    There have been reports in other distro forums of the 3.11 kernel being wonky with shutdowns. Version 13.10 is relatively new, so it's not surprising to hear that bugs are still cropping up. If so, then no solution may exist until it's fixed in a future update.
    1.I use ubuntu since 8.04 version but not on this laptop.On my new laptop my first ubuntu was 13.04 and i got the same problem.
    2.From the start.
    3.No i don't change anything.This is happend right after new installation.
    4.No i don't.
    5.I run 64 bit version of ubuntu.
    Code:
    dejan@dejan-Aspire-V5-571:~$ uname -a
    Linux dejan-Aspire-V5-571 3.11.0-13-generic #20-Ubuntu SMP Wed Oct 23 07:38:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    I installed laptop-mode-tools and i can shutdown laptop but only on AC power, on battery still restarts.Also i disabled "wake-on-lan" feature in BIOS but nothing changed.Then i put "acpi_noirq" as boot parameter like you suggested and i can shutdown now but can't connect to internet.If i remove "acpi_noirq" from grub it connects to network but laptop restarts.

    I installed windows 7 it shutdown fine.I tried arch linux and opensuse 13.1 and same thing happend.With laptop-mode-tools installed opensuse shutdown fine on AC power and on battery.

    Thanks and sorry for my bad english.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •