Results 1 to 1 of 1

Thread: Intel 2200BG/Lubuntu 12.10/HP NC6220

  1. #1
    Join Date
    Nov 2013

    Intel 2200BG/Lubuntu 12.10/HP NC6220

    I have used this machine with Lubuntu using WiFI perfectly for a couple of years, normally on the latest version available. I upgraded to 13.10 last week.

    I have since found that the wireless is intermittent at best - occasionally on and working for a couple of minutes, but mostly showing "wireless is disconnected by wireless switch", or not even giving an option to enable Wifi. If I unblock with rfkill it might work after a reboot, but the whole computer will freeze and require powering off after a minute or two. Even if it is showing as not working, there will be random freezes, freezes at reboot and sometimes won't even reach the ROM setup HP logo without removing and reconnecting the battery.

    When the computer is wired to the router all is fine. Perfect internet, no freezes, all well. As soon as it is disconnected, trouble will begin. I have tried various options in ROM set-up with LAN power saving and LAN/WLAN switching but nothing cures the problem.

    I have tried a clean install of Lubuntu for 13.10, and 12.04 (then upgraded to 12.10). and this did not cure the problem.

    Does anyone have any possible solution before I rip it apart to check the hardware (or get a new laptop).

    HP NC6220 with 2GB RAM.


    02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)


    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11bg ESSID: off/any
    Mode:Managed Channel:0 Access Point: Not-Associated
    Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
    Retry limit:7 RTS thr: off Fragment thr: off
    Power Management: off
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    $ lsmod | grep "ipw2200":

    ipw2200 140514 0
    libipw 46389 1 ipw2200
    cfg80211 175574 2 ipw2200,libipw
    lib80211 14041 2 ipw2200,libipw

    $ dmesg | grep "ipw2200":

    [ 20.027536] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
    [ 20.027539] ipw2200: Copyright(c) 2003-2006 Intel Corporation

    $ sudo lshw -C network:

    description: Ethernet interface
    product: NetXtreme BCM5751M Gigabit Ethernet PCI Express
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:10:00.0
    logical name: eth0
    version: 11
    serial: 00:12:79:be:10:0d
    size: 100Mbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 duplex=full firmware=5751m-v3.29a ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
    resources: irq:16 memory:d0000000-d000ffff

    uname -mr:
    3.5.0-43-generic i686

    Please let me know if you need any more. Thank you to anyone who can help.


    Last edited by Farfrae; November 19th, 2013 at 06:22 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts