Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: GA-970A-DS3P revision 1 no usb 3.0

  1. #21
    Join Date
    Nov 2016
    Beans
    1

    Re: GA-970A-DS3P revision 1 no usb 3.0

    Works for Gigabyte 990x Gaming Sli Motherboard.
    Thanks you!

  2. #22
    Join Date
    Mar 2017
    Beans
    2

    Post Fix GIGABYTE GA-970A-DS3 USB3 properly

    Ok so for anyone with "GIGABYTE GA-970A-DS3" I have done alot of testing and research. The best config I found to get USB3 working is this:
    Edit Grub config:
    `sudo nano /etc/default/grub`
    Edit the line that looks like this:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    Add "amd_iommu=on iommu=pt" to the end of it so now the line now looks like this:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amd_iommu=on iommu=pt"
    Update grub:
    `sudo update-grub`
    once you have done that reboot the system and hit DEL / Delete key to enter BIOS/EUFI setup:
    Ensure IOMMU is enabled, XHCI handoff is enabled, EHCI handoff is disabled, USB Legacy support is enabled. OS type I have set to Windows8 but I have CSM enabled "Compatibility Support Module" so Linux will boot via BIOS emulation instead of UEFI.

    This fix allowed my USB3 to work properly and fixed a few audio issues.

    For bonus fix if your running a x64 bit Ubuntu and find USB transfers hang at the end apply this fix:
    https://unix.stackexchange.com/quest.../107722#107722

    This is working on Ubuntu 16.04.2, Kernel: x86_64 Linux 4.4.0-66-generic
    Last edited by 2e0pgs; March 16th, 2017 at 07:50 PM.

  3. #23
    Join Date
    Dec 2006
    Location
    Recife_PE-Brazil
    Beans
    9
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: GA-970A-DS3P revision 1 no usb 3.0

    Thank you, ozcyto !!
    It works for me... I spent 2 days looking for an answer why the wired connection with a fixed IP wasn't working. I've already had other computer working (same distro (Kubuntu 16.10), same router... The dhcp was working, but when I put to static IP didn't work. I changed cables... everything... after I read this whole thread I focus on the router... I had forgotten that, two years ago, I select, in the router, the fixed IP to the MAC addresses. Thus as I had changed MO (and processor) it was a different MAC address and the router didn't allow the connection!
    Finally I run in the problem that I had no USB 3 ports working... and I followed your instructions and work like a charm! with the grub line (=soft)
    (previously, at the beginning I couldn't install Kubuntu from a usb-stick, I had to enable IOMMU to be able to install from a USB-stick

    Everything is working now!
    Now I can start working!!!!
    Thank you again, ozcyto!!!
    Last edited by sorgud; April 23rd, 2017 at 04:38 PM.

  4. #24
    Join Date
    Aug 2017
    Beans
    2

    Re: GA-970A-DS3P revision 1 no usb 3.0

    Quote Originally Posted by ozcyto View Post
    Here is my updated fix

    First enable iommu in the uefi by restarting your computer and pressing delete to enter the uefi

    plug your usb mouse, keyboard and thumbdrive in usb 2 ports.

    save and exit the uefi

    Then In Ubuntu:

    press Ctrl+Alt+T to open up a terminal

    run the following command: sudo gedit /etc/default/grub

    Only edit the empty quotes in this line to read: GRUB_CMDLINE_LINUX="iommu=soft"

    save changes to grub and exit gedit and the terminal

    Open up a new terminal with ctrl+alt+t

    run the following command: sudo update-grub

    then exit the terminal using this command: exit

    Restart your computer press delete to get back into the uefi

    Disable iommu in bios, load optimized defaults and restart.

    usb, 2.0 usb 3.0 and networking all work now in Ubuntu, and disabling iommu in bios may also help improve your boot times.

    If the above post helps anyone I am happy.

    I just want to give you a kiss! I've been messing with this off and on for months, and this finally worked like a charm!

  5. #25
    Join Date
    Dec 2009
    Beans
    14

    Re: GA-970A-DS3P revision 1 no usb 3.0

    ozctyo.

    You saved me so much time and headache. Thank you very very much. It worked with the new GA-970A-DS3P board to get the USB2 ports working with Ubuntu 18.04. The USB3 ports worked with install.

    Bert
    Vancouver, BC

  6. #26
    Join Date
    Feb 2017
    Beans
    1

    Re: GA-970A-DS3P revision 1 no usb 3.0

    Thank you so much guys. It is working for me with the Rev 1.0 mb, and the F2j BIOS using abitwise's method. Thank you!!

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •