Results 1 to 3 of 3

Thread: 13.10 Radeon UVD

  1. #1
    Join Date
    Oct 2013
    Beans
    1

    13.10 Radeon UVD

    Shouldn't Radeon UVD work out of the box 13.10?

    I upgrade to 13.10 today and I was expecting this to work however vdpauinfo reports:

    Code:
    display: :0   screen: 0
    Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory
    Error creating VDPAU device: 1
    Card is an ATI HD4770
    I was using fglrx-legacy with 12.04.

    SOLVED: Manually installing libg3dvl-mesa from:
    https://launchpad.net/~oibaf/+archiv...d%7Er_i386.deb

    And these intructions: http://phoronix.com/forums/showthrea...127#post209127

    Thanks #radeon @freenode
    Last edited by boot2; October 18th, 2013 at 02:01 AM. Reason: Solved

  2. #2
    Join Date
    Apr 2007
    Beans
    65

    Re: 13.10 Radeon UVD

    I begin to worry that UVD feature didn't make it into Saucy. I too have this:
    Code:
    $ vdpauinfo 
    display: :0   screen: 0
    Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory
    Error creating VDPAU device: 1
    Using Radeon HD 6290.

    Your post confused me a lot.

    Your link points to a discussion posted in 2011, which explain about "VDPAU: r600" and " XvMC: r600 and nouveau". Since, it seems to me, UVD is introduced much later than 2011, it is unlikely an 2011 post have a solution to UVD. Even that early, the post said VDPAU: r600 is no longer supported by developers. I am not sure how to follow that instruction, which part to follow? The "VDPAU: r600" part (out-of-date) OR " XvMC: r600 and nouveau" (seems irrelevent since I use radeon)?

    And to allure other Google keyword seachers with full mplayer error message:
    Code:
    $ mplayer -vo vdpau SAM_3532.MP4
    MPlayer svn r34540 (Ubuntu), built with gcc-4.7 (C) 2000-2012 MPlayer Team
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    
    Playing SAM_3532.MP4.
    libavformat version 53.21.1 (external)
    Mismatching header version 53.19.0
    libavformat file format detected.
    [lavf] stream 0: video (h264), -vid 0
    [lavf] stream 1: audio (aac), -aid 0, -alang eng
    VIDEO:  [H264]  1280x720  24bpp  25.010 fps  8773.5 kbps (1071.0 kbyte/s)
    Clip info:
     major_brand: mp42
     minor_version: 0
     compatible_brands: mp42isomavc1
     creation_time: 1947-11-02 19:18:22
    Load subtitles in ./
    Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object file: No such file or directory
    [vdpau] Error when calling vdp_device_create_x11: 1
    Error opening/initializing the selected video_out (-vo) device.
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    libavcodec version 53.35.0 (external)
    Mismatching header version 53.32.2
    AUDIO: 32000 Hz, 2 ch, s16le, 126.3 kbit/12.33% (ratio: 15785->128000)
    Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
    ==========================================================================
    AO: [pulse] 32000Hz 2ch s16le (2 bytes per sample)
    Video: no video
    Starting playback...
    A:   1.6 (01.6) of 375.5 (06:15.4)  1.0% 
    
    Exiting... (Quit)
    In case anyone dare to get his hands dirty (or bloody), here is a how to on Ubuntu 13.04, which may be adapted to work with Ubuntu 13.10:
    http://lauri.vősandi.com/blog/open-source-radeon-uvd

    I haven't tried its alternative VAAPI, because its instruction guide below didn't mention raedon, nor that if I should install fglrx or stay with the shipped ati_drv.so
    http://www.webupd8.org/2012/11/insta...-hardware.html
    Last edited by zhangweiwu; November 3rd, 2013 at 03:37 PM. Reason: wording

  3. #3
    Join Date
    May 2006
    Beans
    Hidden!
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: 13.10 Radeon UVD

    this may be of interest to you, been using if for a month now and it's working pretty well.
    i'm usin full xubuntu x64 rather than the guides mini iso still works great.

    http://forum.xbmc.org/showthread.php?tid=174854

    What you get
    - Bitstream Audio (including DTS-HD, TrueHD, LPCM 7.1)
    - max resolution: 2048 x 1152
    - mpeg2, mpeg4, h264, vc1 advanced acceleration
    - Bob and Temporal deinterlacing via vdpau

    Known issues for now
    - h264 decoding performance is currently limited to max 36fps (E350 - was 50fps on xvba)
    - If xbmc is hanging on exit, disable the service version check addon from within xbmc.
    - some HD7xxx gpus have artifacts in the menus (see bugreport here: https://bugs.freedesktop.org/show_bug.cgi?id=63997)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •