Results 1 to 6 of 6

Thread: [server] fun speeds with no reason and computer shuts down blinking

  1. #1
    Join Date
    Dec 2010
    Location
    Torino
    Beans
    101

    [server] fun speeds with no reason and computer shuts down blinking

    Hi everyone,

    I have a simple Ubuntu server on a Dell desktop serving only the basic services (web server,mail,ftp,ssh etc). Always up to date.
    I've been experiencing two problems that I think could be linked:

    First of all, sometimes the fan goes off speeding crazily with apparently no reason. If i check with htop, I see the CPU is used at 0% by all processes. Maybe some processes could be hidden?

    Second, at very irregular intervals, the computer just turns off (doesn't shut down properly) and the front led start blinking orange. The strange thing is that the BIOS is set to restore the state of the system in case of power fault (ie. it turns automatically back on if the power goes out).

    What could be causing this? I've been thinking for a long time of a security problem (thread here) but couldn't find anything so far, so I'm thinking it could be a hardware problem or something to do with the power supply (the electricity infrastructure in my house is very old and sucks)

    I'd appreciate any suggestion or comment.

    thanks!


    [edit] Just now, the computer went off. I had htop open on a terminal, so I'm attaching its screenshot. That --purge --config=/etc/denyhosts.conf looks suspicious to me.

    And the led on the lan cable attachment keeps going on and off as if it were still exchanging info. the system seems completely off though!
    Attached Images Attached Images
    Last edited by sowdust; November 6th, 2013 at 01:24 AM.

  2. #2
    Join Date
    Jan 2010
    Beans
    695

    Re: [server] fun speeds with no reason and computer shuts down blinking

    My first suspicion would be the power supply. They are the most common hardware failure point.
    Wanted: Linux supported HD-SDI capture card to I-Frame-Only VP9

  3. #3
    Join Date
    Dec 2010
    Location
    Torino
    Beans
    101

    Re: [server] fun speeds with no reason and computer shuts down blinking

    thanks, Skaperen. now that I think of it though, the problem occured also in my old house, where the electric system was new.
    So I'm thinking, maybe an internal power supply problem? also, could that be connected to the speeding fan?

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [server] fun speeds with no reason and computer shuts down blinking

    CPU fan going crazy and system shutting down for no reason sounds like a CPU overheating problem to me.

    Usually happens in old desktops whose heatsink compound (the paste between the CPU and heatsink) has dried up (possibly creating air-gaps) or the heatsink is clogged with dust. But can also happen in new machines in case the heatsink has not been properly seated or is otherwise unable to dissipate the heat off the CPU.

    If you are comfortable with doing this, I'd suggest to pull out the heatsink and replace its stock heatsink compound with a good quality one, then reseat it properly and see if it helps. Of course you can try "lmsensors" or a similar tool to verify the heat levels beforehand if you are sure your CPU area has the required sensors to report that.

    As for blinking LED on the ethernet port, which one is blinking? Usually there are two LEDs, one remains steady (indicating the connection is established) and the other one blinks when there is traffic activity. If there is just one LED, you'll have to make sure which state means what. It could be just a "No or Faulty connection" indication.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #5
    Join Date
    Dec 2010
    Location
    Torino
    Beans
    101

    Re: [server] fun speeds with no reason and computer shuts down blinking

    thank you varuendra. I have now put the case in a fresher place and it hasn't shown problems so far. If it happens again I'll just give him some of that toothpaste : )

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [server] fun speeds with no reason and computer shuts down blinking

    Quote Originally Posted by sowdust View Post
    thank you varuendra. I have now put the case in a fresher place and it hasn't shown problems so far. If it happens again I'll just give him some of that toothpaste : )
    LOL !!

    I remember having read a post somewhere where a user did just that (used toothpaste instead of heatsink compound, simply because he didn't know the difference). Fortunately, his CPU was under warranty, which soon came in handy.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •