Results 1 to 3 of 3

Thread: 13.10 Local Apache server 403 Forbidden

  1. #1
    Join Date
    Oct 2013
    Location
    Ottawa, Ontario, Canada
    Beans
    130
    Distro
    Ubuntu 19.10 Eoan Ermine

    13.10 Local Apache server 403 Forbidden

    Since upgrading from 13.04 to 13.10 Apache access to ~/public_html fails with a 403 Forbidden error. There are no changes to permissions of any of the directories or, as far as I can see to any of the Apache configuration files.

    /etc/apache2/sites-available/000-default.conf is:

    Code:
    <VirtualHost *:80>
        ServerAdmin webmaster@localhost
    
        DocumentRoot /home/jcobban/public_html
        <Directory />
            Options FollowSymLinks
            AllowOverride None
        </Directory>
        <Directory /home/jcobban/public_html>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
        </Directory>
    
        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
        </Directory>
    
        ErrorLog ${APACHE_LOG_DIR}/error.log
    
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
    
        CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>

  2. #2
    Join Date
    Jan 2007
    Location
    New York City
    Beans
    165
    Distro
    Ubuntu Gnome 13.10 Saucy Salamander

    Re: 13.10 Local Apache server 403 Forbidden

    Bump. Same problem.

  3. #3
    Join Date
    Aug 2007
    Beans
    17
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: 13.10 Local Apache server 403 Forbidden

    I had this same problem and found this thread before I figured out the solution. Thought I'd post the answer here in case anyone still is having trouble.

    /etc/apache2/apache2.conf seems to be more restrictive now. To get rid of the 403 error for a certain folder, find this part:

    Code:
    <Directory />
            Options FollowSymLinks
            AllowOverride None
            Require all denied
    </Directory>
    
    <Directory /usr/share>
            AllowOverride None
            Require all granted
    </Directory>
    
    <Directory /var/www/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
    </Directory>
    After that, add something like this:

    Code:
    <Directory /home/USERNAME/FOLDER/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
    </Directory>
    Then restart Apache and it should work.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •