Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Booting Ubuntu 13.10 on Asus N550JV

  1. #1
    Join Date
    Oct 2013
    Beans
    4

    Booting Ubuntu 13.10 on Asus N550JV

    I have trouble to boot a fresh install of Ubuntu 13.10 so I come here in the hope someone will be able to help me

    I got recently a brand new laptop Asus N550JV to replace my old Acer 5920G.
    The official page for the laptop at Asus.com : http://www.asus.com/us/Notebooks_Ultrabooks/N550JV/

    Specs :

    - Processor Intel i7 4700HQ Haswell 4th Gen
    - 16 Gb DDR3
    - 15'6 screen HD IPS 1920x1080
    - Optimus technology Intel HD 4600/Nvidia GT 750M 4 Gb
    - 1TB HDD 5400 RPM
    -
    Windows 8 Preinstalled (upgraded to 8.1 recently)

    UEFI Bios, Aptio type, (204 version originally upgraded to 207, last available version)

    Now, I downloaded the 64 bits desktop 13.10 ISO and made a live USB using Universal USB Installer (also tried Unetbootin btw), tried to boot the USB stick but it was not possible.
    Secure Boot does not allow it (or something else).
    Disabling Secure Boot, I was able to boot the USB stick and proceed. Installation went smoothly.
    I forgot to mention I had previously resized the second windows partition (named 'Data') to free 200 Gb for Linux.
    Since I wanted to keep things simple, I only created a swap partition of 16 Gb and a root partition (/) with the rest of the space.
    I chose to install Grub on that partition (I mean the root partition) becauseI dind't want to mess with the Windows loader and all that new (at least for me) UEFI thing.
    Once back in Windows, I used EasyBCD 2.2 to add Ubuntu to the Windows loader (which I find quite elegant and way more watchable than Grub but that's juste me ).

    Then I noticed something strange. At the first run of EasyBCD, there was already an 'ubuntu' entry. I did not touch that one and added mine (Type: Grub2, Name: Ubuntu 13.10, Disk: Autolocate). Rebooted and here was my new entry Ubuntu 13.10 (but the weird 'ubuntu' entry I didn't add was nowhere to be seen). Trying to boot it, I got the, I believe, 'infamous' error message :

    (...)
    \NST\AutoNeoGrub0.mbr
    0xc000007b
    (...)


    I must say sometimes there is also like 3 lines on the top left corner but it's displayed to briefly and I can't read them.

    When trying to boot Linux, Secure Boot is disabled, Fast Boot is disabled, Fast Startup (in W8) is disabled. All that doesn't seem to help much.
    For EasyBCD, I also modified the entry to point it to the exact partition (not using the autolocate, just in case): no luck...
    Remade several times my live USB, downloading new 64 bits ISO, using Unetbootin instead of USB Universal Installer: no luck.
    Reinstalled several times: no change.
    Tried to install from a 'try session' : same result.

    Also tried to enable CSM (or CMS don't remember the exact term, the legacy stuff), doesn't help either.

    Now, I do know Ubuntu 13.10 is, as far as I can tell, perfectly (well maybe not that perfectly lol) installed, my problem is I just can't boot/run it.

    I read tons of articles here and there on installing Ubuntu on UEFI computers with preinstalled W8 but so far I'm getting nowhere.

    So any suggestion gladly accepted.

    Thank you for your patience

    Eric

    P.S. Forgot to mention another thing. About that stealth 'ubuntu' entry not showing and which popped up right at the first run of EasyBCD, I found its trace when pressing Esc at start to pick up the device to boot. It's listed there (as non UEFI partition clearly). Trying to boot that way doesn't work either but no error message just black screen and auto reboot.

    [Adding this after further reading:]

    From that link
    https://help.ubuntu.com/community/UEFI, I believe I may have a clue.
    I remember seing during partitionning when installing an EFI partition already existing (from the preinstalled Windows 8 obviously).

    I read on the mentionned page that:

    if you use the manual partitioning ("Something else"), the difference is that you will have to set the /boot/efi mount point to the EFI partition
    They don't say how.

    Also says on the very same page:

    If your disk already contains an EFI partition (eg if your computer had Windows8 preinstalled), it can be used for Ubuntu too. Do not format it. It is strongly recommended to have only 1 EFI partition per disk.
    Hum...

    When creating an EFI partition(which is not my case since I've got already one), it is said:

    Mount point: /boot/efi (remark: no need to set this mount point when using the manual partitioning, the Ubuntu installer will detect it automatically)
    Right...

    Found this http://askubuntu.com/questions/31529...with-windows-8, very interesting because it says:

    Note that you don't install Linux onto the ESP in any meaningful sense. You should create Linux partitions in the normal way on your GPT disk -- say, for swap, /, and /home. In the Ubuntu installer, you then mark the ESP as being the "EFI boot partition." Alternatively, the various automated partitioning options do this automatically.
    Whatever you do, do not create a new filesystem on the ESP, and do not remove the "boot flag" from the ESP or set a "boot flag" on any other partition.
    Note that ESP means here the EFI partition.

    Anyway still investigating.

    [Added on 10/31:]

    Booting my live usb ubuntu, I ran Boot-repair to 'fix' well that 'thing' since it's supposed to fix grub and uefi troubles. All went nicely until I got the following message:

    (...) Locked-ESP detected
    So after googling that error, I found out that there is indeed a known bug with such message. The bug is described here https://bugs.launchpad.net/ubuntu/+s...2/+bug/1090829 and probably else where.

    According to the people talking about that stuff on those pages, it's either a real locked up EFI partition (ESP) which prevents Ubuntu installation to write the files where it should OR, somehow, the files are corrupted (maybe for the same reason). Apparently, most people don't think the ESP is screwed but rather only the ubuntu file needed to boot in EFI mode.

    Creating a second EFI partition with the bootflag doesn't seem to fix it (haven't tried).

    Anyway, for info:
    http://paste.ubuntu.com/6332633/

    And the quest goes on...

    Editing this, three weeks later or so : I'm stuck and a lil bit fed up struggling with that issue. Can't run Ubuntu on my laptop because of some UEFI weirdness... Sadly, I doubt I'm the only one. Maybe Ubuntu will fix that, one never knows...
    Last edited by paralis; November 14th, 2013 at 02:45 AM.

  2. #2
    Join Date
    May 2006
    Beans
    3

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Awful news, I just bought the same computer and I'm having all the problems you describe.

    I'll let you know if i find something that can be done. Please let me know if you were able to fix this too.

    Good luck

  3. #3
    Join Date
    May 2006
    Beans
    3

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Hey I was able to get the Asus N550JV notebook to dobleboot OK following this guide:

    http://askubuntu.com/questions/22183...uefi-supported

    Good luck!

  4. #4
    Join Date
    Nov 2011
    Beans
    1

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Hi, I just got this laptop too and have got it dual-booting OK now too. Punk Fetish's link was great, https://help.ubuntu.com/community/UEFI helped too.

    I burnt a Ubuntu DVD from windows, disabled secure boot and fast boot in the BIOS and the DVD install worked OK. The BIOS is a bit strange, it doesn't let you set DVD as a boot priority unless there is a DVD in when you boot. Possibly if you're having trouble with a USB install, a DVD might be worth trying?

    I still have to try and get sound working, http://askubuntu.com/a/371567 says you can upgrade to a 3.12 kernel to fix it.

  5. #5
    Join Date
    Oct 2013
    Beans
    4

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Thank you guys, investigating your links

  6. #6
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Not sure it applies to your brand or not, but seems to be an Intel issue.
    Some of the new Haswell systems are having issues installing in UEFI mode with the Intel NIC (Integrated Network Interface Controller) turned on. But turning it off means the hard wired Ethernet connection does not work. Wireless still does.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  7. #7
    Join Date
    Oct 2013
    Beans
    4

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Would it be possible to turn it off, install and then turn it back on or at least has this been tried on some other brands?

  8. #8
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Booting Ubuntu 13.10 on Asus N550JV

    I saw one user say he could not turn it on. But when he installed in BIOS mode it worked. Do not know if a UEFI/BIOS update will eventually fix it or if it is a Ubuntu/grub issue. Often Linux has to work around systems that work only with Windows.

    The disadvantage of BIOS mode is that you cannot dual boot from grub menu but only from UEFI menu or one time boot key may also work. And depending on system you may have to turn UEFI on/off or BIOS/CSM on/off. It seems a lot of the newer ones know if booting a BIOS system it works or if booting a UEFI system it works. But you cannot have secure boot on as that is UEFI only.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #9
    Join Date
    Feb 2009
    Beans
    4

    Re: Booting Ubuntu 13.10 on Asus N550JV

    Hi!

    I was trying to install Ubuntu in my brand new Asus N550JV (same as in the original post of this thread) but I'm not having success. I did everything stated in the links:

    1. I resized Win8 partitions in order to have free unassigned space for Ubuntu.
    2. At BIOS menu, I disabled Secure boot and Fast boot.
    3. I disabled Fast startup in Windows 8.1 (yes, I've upgraded it).
    4. I started Ubuntu from a LiveDVD. Starting it from a LiveUSB has been absolutely impossible; I tried CSM mode (i.e. Legacy BIOS mode) and UEFI mode, but my USB drive did never show up. Following motifman suggestions I was able to boot it from a DVD (you have to start the BIOS menu with the actual LiveDVD inside the BD unit, else it won't let you choose it as a boot option)
    5. At the beginning, the installer showed a message saying that there was no other OS installed. I kindda expected it and chose manually manage partitions.
    6. I set the already existing EFI partition (it comes along with Windows8 pre-installations) as Ubuntu's EFI partition. I did not manually set the mount point during installation because Ubuntu detected the partition automatically, however, I've checked and it is correctly mounted on /boot/efi.
    7. When the installing process finished, I rebooted and yes, Grub showed both Windows AND Ubuntu. If I choose to boot with Windows, everything goes well.


    However, when I try to boot Ubuntu, I get stuck in the purple screen. I can certainly start recovery mode but didn't try anything further than checking partitions and unsuccessfully running startx. Does anyone know how to solve this? I didn't read anything similar in the linked pages or in previous posts...

    Thanks!!

  10. #10
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Booting Ubuntu 13.10 on Asus N550JV

    If it is Optimus you have both Intel & nVidia. Do you have control over which it uses to boot or is it automatic?

    With nVidia you use nomodeset. But Intel needs different settings.
    How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions


    Some other Intel boot options Each line is one that may work
    acpi_osi=Linux acpi_backlight=vendor
    i915.i915_enable_rc6=1


    Even though this is on Dell, the comment is on i915 Intel.
    http://en.community.dell.com/techcen...ion-m3800.aspx
    Running in legacy BIOS mode or in UEFI mode both work, but for now you'll need to enable "Legacy Option ROM" in the BIOS if you're running in UEFI mode because of the display's backlight. This is because of an issue with the Intel i915 driver that currently affects several systems from many vendors. If you don't enable this BIOS option, the backlight will be stuck at the lowest setting in Linux.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •