Concrete case:
I need to use libxen-dev 4.2.2 on Ubuntu 12.04, and the binary repositories only contain lower versions. This version of libxen-dev is only in 13.04.

If there exists a more general approach to these kind of problems which is that?

Thank you,
Dan