All research and searches to no avail. The problem:

Installed:
Mint 13 Maya (based on Ubuntu 12.04)
Icetea-7-Plugin (Version: 1.2.3-0ubuntu0.12.04.3)
Openjdk-7-jre (Version: 7u25-2.3.10-1ubuntu0.12.04.2)

According to Arachnophilia, java must be installed BEFORE downloading and running Arachnophilia.jar. This was done, as follows:

1. Icedtea plugin and Openjdk runtime were both first installed.
2. Terminal "java -version" returns:
java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.6) (6b27-1.12.6-1ubuntu0.12.04.2)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

3. Latest Arachnophilia.jar was downloaded into a folder "Arachnophilia" on my desktop.
4. According to Arachnophilia, to run Arachnophilia.jar I used the terminal, went into the Arachnophilia folder and attempted to run Arachnophilia.jar as per directions by running "java -jar Arachnophilia.jar".

The return:
computer@computer ~/Desktop/Arachnophilia $ java -jar Arachnophilia.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: Arachnophilia/Arachnophilia : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java :634)
at java.security.SecureClassLoader.defineClass(Secure ClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader .java:277)
at java.net.URLClassLoader.access$000(URLClassLoader. java:73)
at java.net.URLClassLoader$1.run(URLClassLoader.java: 212)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.j ava:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:3 21)
at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:2 66)
Could not find the main class: Arachnophilia.Arachnophilia. Program will exit.

I'm stumped, any ideas? Thanks...