Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Realtek 8187L Connection peaks

  1. #1
    Join Date
    Oct 2013
    Beans
    10
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Realtek 8187L Connection peaks

    Regards,

    I am using Ubuntu 12.04 LTS x64 with usb network card Alfa Network AWUS036H v5, this card contains the 8187L chipset, which gives connection problems with Ubuntu.

    I have read several threads and blogs where was the possible solution, but I have not managed to fix the problem completely.

    These are the steps I've followed several threads and tutorials, from installing Ubuntu to step 3 the connection is constantly lost and it was almost impossible to connect to the Internet, the sites not loading, from step 3 I managed to reload pages slowly, but still feel speed problems, speed changes in peaks, as soon reaches 40kb/s as it gets to 0kb/s

    1) I downloaded the version of my kernel to 3.2.0 to support native driver.

    2 ) I entered the following command to disable the Ubuntu kernel modules:
    Code:
    sudo rmmod r8187 rtl8187 mac80211 cfg80211
    2) I have installed the native driver downloaded from Realtek page, which, should solve my problem, not in my case.

    3) I have applied the following commands, found in this forum topic:

    Code:
    sudo modprobe rtl8187
    sudo iwconfig wlan0 rate 5.5M fixed
    sudo iwconfig wlan0 frag 2346
    sudo iwconfig wlan0 rts 2347
    sudo iwconfig wlan0 txpower 20
    Currently I can browse and experiencing slow speed peaks my connection quite drastic.

    The adapter works, has been tested on a Windows system and the problem is not, however, just want to have Ubuntu as the operating system on my computer.

    Attached some basic commands on the status of my connection .

    Output of ifconfig:
    Code:
    eth0      Link encap:Ethernet  direcciónHW 54:04:a6:83:xx:xx  
              Direc. inet:10.42.0.1  Difus.:10.42.0.255  Másc:255.255.255.0
              Dirección inet6: fe80::5604:a6ff:fe83:2e13/64 Alcance:Enlace
              ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
              Paquetes RX:4955 errores:0 perdidos:0 overruns:0 frame:0
              Paquetes TX:4526 errores:0 perdidos:0 overruns:0 carrier:0
              colisiones:0 long.colaTX:1000 
              Bytes RX:530339 (530.3 KB)  TX bytes:4193542 (4.1 MB)
              Interrupción:42 Dirección base: 0xe000 
    
    lo        Link encap:Bucle local  
              Direc. inet:127.0.0.1  Másc:255.0.0.0
              Dirección inet6: ::1/128 Alcance:Anfitrión
              ACTIVO BUCLE FUNCIONANDO  MTU:16436  Métrica:1
              Paquetes RX:460 errores:0 perdidos:0 overruns:0 frame:0
              Paquetes TX:460 errores:0 perdidos:0 overruns:0 carrier:0
              colisiones:0 long.colaTX:0 
              Bytes RX:45731 (45.7 KB)  TX bytes:45731 (45.7 KB)
    
    wlan0     Link encap:Ethernet  direcciónHW 00:c0:ca:75:xx:xx  
              Direc. inet:192.168.1.34  Difus.:192.168.1.255  Másc:255.255.255.0
              Dirección inet6: fe80::2c0:caff:fe75:6bc9/64 Alcance:Enlace
              ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
              Paquetes RX:32769 errores:0 perdidos:0 overruns:0 frame:0
              Paquetes TX:28962 errores:0 perdidos:0 overruns:0 carrier:0
              colisiones:0 long.colaTX:1000 
              Bytes RX:42098383 (42.0 MB)  TX bytes:3254483 (3.2 MB)
    Output of iwconfig:
    Code:
    lo        no wireless extensions.
    wlan0     IEEE 802.11bg  ESSID:"WLAN"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:80:5A:47:xx:xx   
              Bit Rate=5.5 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr=2346 B   
              Power Management:off
              Link Quality=44/70  Signal level=-66 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:2524  Invalid misc:5051   Missed beacon:0
    
    eth0      no wireless extensions.
    Does anyone have this chipset or had these problems can help me?

    Sorry for the inconvenience, but I have been 5 days researching self and my last resort is this post.

    Thanks in advance, greetings

    P.D: Sorry for my bad English, my native languaje is Spanish

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    Hello dekadence2, Welcome to the forums!

    I hope this 'last resort' of yours may prove helpful eventually. Please follow the "Wireless Script" link in my signature, download and run the script as per instructions there, and post back the report it generates.

    Based on the information we get from it, we may try more than one possible solution.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #3
    Join Date
    Oct 2013
    Beans
    10
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    Thanks for the welcome and for the help varunendra

    This is the info generated by the script, i upload it to pastebin, the forums not allow me to upload atachment with this size.

    http://pastebin.com/cpAgq1sj

    Thanks in advance, a greetings ^^

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    First alert -
    Code:
    ***** lsmod *****
     
    r8187l                159292  0
    rtl8187                57035  0
    mac80211              506862  1 rtl8187
    cfg80211              205774  2 rtl8187,mac80211
    eeprom_93cx6           12767  1 rtl8187
    You have installed the proprietary driver, but not using it. Both the native and the proprietary one are loaded and may be conflicting with each other.

    Please blacklist the native one to try the proprietary one -
    Code:
    echo "blacklist rtl8187" | sudo tee -a /etc/modprobe.d/blacklist.conf
    Then either reboot or manually unload the modules and reload only the desired one -
    Code:
    sudo modprobe -rv r8187l rtl8187
    sudo modprobe -v r8187l
    On next boot (and plugging in the USB), make sure the native one is not loaded again. Check -
    Code:
    lsmod | egrep 'rtl8|r81'
    ..it should return only one line showing r8187l in it.

    Additionally, delete the current udev rules file as it contains two entries for the same interface (usb) -
    Code:
    sudo rm /etc/udev/rules.d/70-persistent-net.rules
    It will be automatically regenerated at next boot or when you replug the USB adapter.

    As a side note, you may wish to use WPA2-PSK (AES/CCMP) encryption for your access-point, of course if you have admin access to it. WEP security is almost no security, and is probably not good for speeds as well.

    On another note, is that "*Pablo & Cindii [o8.o6.1o]*" access-point yours? If yes, it is highly recommended to change its encryption to same above too (WPA2-PSK(AES/CCMP)). The WPA/WPA2 mixed mode + TKIP is strongly discouraged with Linux as that combination is inefficient and doesn't work well with Linux drivers.

    Anyway, try these and let me know how it goes.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #5
    Join Date
    Oct 2013
    Beans
    10
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    After apply all steps, the lsmod only return 2 interfaces: r8169 (My LAN card) and r8187l (My Wireless card), but when system take connection with router the system freeze (no show errors, the screen frezee and no mouse move)

    I blacklisted r8187l, and connect now with no problems, but connection is slow :S

    In the past, I put this lines in rc.local from this topic: http://askubuntu.com/questions/28828...n-ubuntu-13-04

    Code:
    sudo modprobe rtl8187
    sudo iwconfig wlan0 rate 5.5M fixed
    sudo iwconfig wlan0 frag 2346
    sudo iwconfig wlan0 rts 2347
    sudo iwconfig wlan0 txpower 20
    I should remove these lines from file?

    Yes, I have two access points, 1 for internet (WLAN) and 1 for LAN (*Pablo & Cindii [o8.o6.1o]*) the LAN access point is connected by ethernet cable, but have more PC with Ubuntu connected by Wireless, I apply change to WPA2-PSK now, thanks for the tip

    A greeting

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    Quote Originally Posted by dekadence2 View Post
    After apply all steps, the lsmod only return 2 interfaces: r8169 (My LAN card) and r8187l (My Wireless card), but when system take connection with router the system freeze (no show errors, the screen frezee and no mouse move)
    Unfortunately, this is a problem with this driver which I couldn't find a solution to (or even the reason yet). It works for some, not for others. So yeah, unless you can find a solution to the freezing problem, you'd have to live with the native driver. Probably the best idea is to remove the proprietary one altogether then.

    And..
    In the past, I put this lines in rc.local from this topic: http://askubuntu.com/questions/28828...n-ubuntu-13-04

    Code:
    sudo modprobe rtl8187
    sudo iwconfig wlan0 rate 5.5M fixed
    sudo iwconfig wlan0 frag 2346
    sudo iwconfig wlan0 rts 2347
    sudo iwconfig wlan0 txpower 20
    Yes, you should indeed remove these lines from it. I don't think they are helping anything. On the contrary, it seems to me that the value of frag is too high (if I'm understanding correctly). As a side note on this, you don't need to add "sudo" to anything in that file, it is already run as root.

    Try the changes, and post back the output of -
    Code:
    ifconfig wlan0
    ..plus, a fresh output of wireless_script. Oh, and could you try the attached EXPERIMENTAL VERSION of Wireless Script this time please? I'm still working on it, so not sure if there may be any problems with it. If the output seems incomplete (does not end with the last "**** done ****" line), use the regular one instead.
    Attached Files Attached Files
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  7. #7
    Join Date
    Oct 2013
    Beans
    10
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    Hello ^^

    I removed lines from rc.local and reboot my system, after this, this is the info outputs from my system:

    From ifconfig wlan0:
    Code:
    pabloycindii@TeAmoCindii:~$ ifconfig wlan0
    wlan0     Link encap:Ethernet  direcciónHW 00:c0:ca:75:6b:c9  
              Direc. inet:192.168.1.34  Difus.:192.168.1.255  Másc:255.255.255.0
              Dirección inet6: fe80::2c0:caff:fe75:6bc9/64 Alcance:Enlace
              ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
              Paquetes RX:10265 errores:0 perdidos:0 overruns:0 frame:0
              Paquetes TX:10720 errores:0 perdidos:0 overruns:0 carrier:0
              colisiones:0 long.colaTX:1000 
              Bytes RX:10541714 (10.5 MB)  TX bytes:1623861 (1.6 MB)
    From wireless-script-v2 (The script no present any problems or errors and finish the output with *** done *** line ):
    wireless-info-alt.tar.gz

    P.D: Unexpectly, my conection now is more fast

    Thanks for the time you spend in my case, I stay alert to new tips.

    A greetings ^^
    Last edited by dekadence2; October 25th, 2013 at 01:17 AM.

  8. #8
    Join Date
    Oct 2013
    Beans
    10
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    It is possible that the problem has been solved, if not completely, at least partially, my connection currently browsing 5 times faster than earlier sailing.

    Unfortunately I do not know exactly what was the failure to serve as a future contribution, I just followed all your steps.

    Is it possible that the error is in mac80211 and cfg80211 modules Ubuntu? (The manufacturer's driver module contains its own mac80211 and cfg80211)

    Once again, many thanks varunendra, I will investigate and see if I detect that causes the error and attentive to any recommendations, you're a wireless master!

    Greetings ^^

  9. #9
    Join Date
    Oct 2013
    Beans
    10
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    One question... If my problem is resolved in 3.2.0 kernel, I can update now to 3.8.0 with any problems? (I downgrade this to install manufacturer driver)

    A greeting, and thanks, really a lot of thanks ^^

  10. #10
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Realtek 8187L Connection peaks

    Quote Originally Posted by dekadence2 View Post
    P.D: Unexpectly, my conection now is more fast
    That's because earlier you had 'fixed' it to 5.5m, while now it is free to negotiate and try to reach the optimal speed. It currently shows to be connected at 11Mb/s, which is apparently the maximum speed your access point can support (??) -
    Code:
    wlan0     IEEE 802.11bg  ESSID:"WLAN"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: <MAC address removed>   
              Bit Rate=11 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=44/70  Signal level=-66 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:168  Invalid misc:267   Missed beacon:0
    ....
    ....
    Cell 01 - Address: <MAC address removed>
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=43/70  Signal level=-67 dBm  
                        Encryption key:on
                        ESSID:"WLAN"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                        Mode:Master
    So okay, slightly higher this time, but does it really support only that much speed? Is it set to use only 'b' channel? Even if not, it may currently be working in 'b' only mode, because 'g' channel supports upto 54Mb/s. Can you confirm if any other device/computer is able to get higher speed from the same access-point?

    Oh, and regarding the other AP ("*Pablo & Cindii [o8.o6.1o]*"), not just the encryption, change its channel to 1 or 11 too, which usually work much better with Linux drivers. Currently that one is set to channel 5.

    A few more things to try -

    1) Try disabling IPv6 as mentioned in this post.

    2) Try changing the DNS from your current ones to Google's 8.8.8.8 and 8.8.4.4 (set it in Network Manager, then confirm with "nm-tool" command).

    3) If using channel 11 on both Access Points, you may try this -
    Code:
    sudo modprobe -rv rtl8187
    sudo modprobe -v cfg80211 cfg80211_disable_40mhz_24ghz=Y
    sudo modprobe -v rtl8187
    Note that this may disable support for channel 5 which seems to be using 40MHz frequency as per your regulatory domain. It means you may no longer be able to connect to the other access-point "Pablo & Cindii.." until you change its channel to 11 (or channel that falls within 2457000 KHz - 2494000 KHz band). Besides, it is not guaranteed to improve anything. But anyway, it will be just a temporary change and will be lost at next boot. Whether or not to make it permanent depends upon whether it helps anything or not.

    Of course none of above is needed if 11Mb/s is all your access-point can support, and the 'peaking' problem is gone. So please test these (whether it can support higher speed or not, and whether the 'peaking' is still happening) and let me know the result.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •