Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

  1. #1
    Join Date
    Dec 2006
    Beans
    Hidden!

    upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    It requires a reboot.
    This is an onboard e1000 network chip

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 20.04 Focal Fossa

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    13.10 is no longer in development and has been released now.

    Thread moved to Installation & Upgrades.
    Ubuntu 18.04 Desktop Guide - Ubuntu 20.04 Desktop Guide - Forum Guide to BBCode - Using BBCode code tags - IRC #ubuntuforums

    Member: Not Canonical Team

    Please do not PM me about your forum account unless you have been asked to. The correct place to contact an admin about your account is here.

  3. #3
    Join Date
    Dec 2006
    Beans
    Hidden!

    upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    It requires a reboot.
    This is an onboard e1000 network chip
    any ideas?

    I have the x1300 AMD video card
    After it wakes up, you see the empty network triangle and click on it says network disabled.
    And the leds are off.
    IF you tell it to enable, the LEDs light up but the empty triangle remains. And no network.

  4. #4
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    I solved following this advice
    http://askubuntu.com/questions/26685...ter-suspension

    Code:
    Here is a technique that sometimes works:
    
    gksudo gedit /etc/pm/config.d/config
    Add a single line:
    
    SUSPEND_MODULES="e100"
    Proofread, save and close gedit. Reboot, suspend and let us have your report.
    for me the driver is e100.
    You find the driver by sudo lshw -C network

    the line driver = 'the driver', the driver is what you use in that line

    SUSPEND_MODULES="the driver"

  5. #5
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    Not solved.
    This seems to work if you do a suspend and then within a couple minutes awake the PC.
    I just left it sit suspended for an hour and when it awakens, the network is disabled.
    Last edited by sdowney717; October 20th, 2013 at 05:51 PM.

  6. #6
    Join Date
    May 2006
    Location
    greenville, south carolin
    Beans
    43
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    Same issue here.

    I can however resume network with : sudo nmcli nm sleep false

  7. #7
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    Thanks for this. That does work.
    I ran it and I got a message that says network now offline.

    Then you click the icon and you see all the network cards
    Then tell it to enable networking, selecting 'Auto Ethernet'
    And it comes back working.

    SO, how can we make this work like it should?
    Anyone submitted a bug yet?

    I changed the line to read
    SUSPEND_MODULES="e100 e1000" in that config file, but it has no effect.
    This MB has 2 NICS onboard builtin.
    Last edited by sdowney717; October 21st, 2013 at 11:32 AM.

  8. #8
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    I started a bug report so if you wish to join and contribute some input there.
    https://bugs.launchpad.net/ubuntu/+s...r/+bug/1242679

  9. #9
    Join Date
    Aug 2013
    Location
    Poland
    Beans
    13
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    I have this bug as well. I found the work-around* here and here. The basic steps are:
    sudo touch /etc/pm/sleep.d/wakenet.sh

    sudo chmod +x /etc/pm/sleep.d/wakenet.sh

    sudo gedit /etc/pm/sleep.d/wakenet.sh
    Insert the following lines:
    #!/bin/bash
    case "$1" in
    thaw|resume)
    nmcli nm sleep false
    ;;
    *)
    ;;
    esac
    exit $?
    Save


    Now the interface is started upon resume. It seems to suspend/resume slower, but it works.

    Peace,
    Paul

    *This is not the solution (as I originally wrote) but a work-around. The solution is for the bug to be fixed. Visit this page and click if it's affecting you. Thanks.
    Last edited by phaenze; October 28th, 2013 at 08:18 AM. Reason: Clarify status of bug

  10. #10
    Join Date
    Apr 2007
    Beans
    3
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: upgrade to 13.10 after you suspend, network is disabled and cant be enabled

    Quote Originally Posted by phaenze View Post
    I have this bug as well. I found the work-around* here and here. The basic steps are:


    Now the interface is started upon resume. It seems to suspend/resume slower, but it works.

    Peace,
    Paul

    *This is not the solution (as I originally wrote) but a work-around. The solution is for the bug to be fixed. Visit this page and click if it's affecting you. Thanks.
    This worked perfectly for me. Ubuntu 13.10, driver=iwlwifi,

    Hardware:
    description: Wireless interface
    product: PRO/Wireless 5100 AGN [Shiloh] Network Connection
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    logical name: wlan0
    version: 00
    serial: 00:21:5d:90:dd:44
    width: 64 bits
    clock: 33MHz


    Thanks.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •