Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Problems with UEFI disabled.

  1. #1
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Problems with UEFI disabled.

    I purchased a new PC and it has windows 8 installed. I went into the BIOS and disabled UEFI. I tried to boot a Ubuntu Desktop Disk and the PC wont allow it. The DVD is not spinning. I have set the BIOS to boot from DVD.

    Can i blow away the Win 8 install on the drive? Will this make installing Ubuntu easier. I dont need windows but I wanted to make sure that my PC will be fine running Ubuntu before blowing away M$. I read that the OS is tied to the hardware so If i blow away windows will my PC still work?

    I am looking for the easiest fasted way to get Ubuntu running. I have read a lot about UEFI and am very confused about what parts of what I have ready apply to me and my set up. The BIOS has the option of disabling UEFI so I cant understand why it will not boot.

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Problems with UEFI disabled.

    Often best to turn off secure boot but not turn off UEFI. Some laptops have limited settings and with secure boot off, it only has one boot option that is UEFI if UEFI found or BIOS if MBR found with boot loader.
    If you have secure boot on, only those systems seen as secure boot will even be shown.
    Also if you have not turned fast boot off in Windows or UEFI you need to do that also.

    What system? And what video does it have?
    Often video is also an issue, and if a Ultrabook, you may have issues with Intel SRT which uses RAID.

    More info in link in my signature.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Problems with UEFI disabled.

    Gateway sx2370 UR12 AMD Quad Core A6-3620 APU 6GB DDR3 DVD Super Multi.
    AMD Radeon Graphics

    Quiet Boot is disabled I dont see a Fast Boot. The BIOS is from ACER and the MOBO says ACER on it, the MOBO is a DAA 75L aParker 1105-1

    The Only place UEFI is listed in in Boot Options as the second boot device. UEFI: HL-DT-ST DVDRAM GH82N.

    I dont see a place to disable UEFI. I do see Secure Boot under the Authentication Tab of the BIOS and secure boot is now disabled.

  4. #4
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Problems with UEFI disabled.

    I do not know all the details on AMD, often nomodeset is required.

    How to set NOMODESET and other kernel boot options in grub2 - both BIOS liveCD & grub first boot ( also UEFI with grub)
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions

    Next version of kernel has some changes for AMD cards.

    The AMD Radeon Performance Is Incredible On Linux 3.12
    http://www.phoronix.com/scan.php?pag...12_major&num=1


    https://wiki.ubuntu.com/X/Troublesho...riverDetection
    Ubuntu Precise Installation Guide - AMD/ATI
    http://wiki.cchtml.com/index.php/Ubu...#Video_Tearing
    Add Hardware Graphics - ATI: After installing ATI Driver: From QIII
    http://ubuntuforums.org/showthread.php?t=2050320
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  5. #5
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Problems with UEFI disabled.

    I tried the nomodeset at the end of the kernel boot line. The DVD does not spin up after I hit enter. Nothing happens. I am wondering if there is still a problem with UEFI not allowing the DVD to boot or stopping the PC from proceeding with the boot process.

  6. #6
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Problems with UEFI disabled.

    I have a sony external DVD I plugged into a USB port. I can see it in the BIOS and have set it as the primary boot device. The PC will not boot from that DVD. If I hit F12 to see the boot menu I do not see the DVD device listed. I only see the windows Boot manager. I also do not see the internal DVD device that was on the F12 boot list prior to plugging in my external DVD.

  7. #7
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Problems with UEFI disabled.

    Also of note when booting UBUNTU 13 from my external drive I see the old school boot list not the newer boot screen shown in the first link on your post above I do not have the function keys available. The only way for me to modify the boot parameters is by down arrow to the selection and pressing 'e' to append the kernel line. I am wondering if this is a graphics issue as you are discussing. My external DVD is now spinning but i see no ouput on the screen.
    Sloan

  8. #8
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Problems with UEFI disabled.

    You probably want to boot in UEFI mode and that gives you a grub menu that you have to manually edit.

    Only if you really want to install in legacy/BIOS/CSM mode do you boot DVD or flash drive in BIOS mode that gives purple screen.

    Sometimes these force different video modes to get you into system so you can use it. If one works then you will probably need it on first boot or until you permanently install proprietary drivers.
    On grub menu use e, scroll to linux line and replace quiet splash with one of these.
    xforcevesa
    or
    nouveau.modeset=0
    or
    radeon.modeset=0
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #9
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Problems with UEFI disabled.

    I tried all 3 in your last post and also tried the NOMODESET. I see the black screen and hear the external drive spin but no install commences.
    Sloan

  10. #10
    Join Date
    Oct 2007
    Location
    Southern California
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Problems with UEFI disabled.

    I booted into the first boot screen and at the grub> prompt i ran videotest. in the upper left corner there is a small red square next to that diagonally toward the lower right corner is a light blue square. another dark blue square is in the middle of the screen. The text :"the quick brown fox jumped over the lazy" is nested inside that square. so colors and text are visible. Not sure why.
    Sloan

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •