Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Connect to network, but no internet

  1. #1
    Join Date
    Oct 2013
    Beans
    10

    Connect to network, but no internet

    I'm using Ubuntu 13.04 on an older Gateway for several months with no issues. Had a brief (5 second) power failure about 2 weeks ago, and lost the ability to connect to the internet. The Windows computers and Apple computers in the house can still connect to the network and the internet, but now the Ubuntu computer can connect to the network, but not the internet.

    I tried reinstalling Ubuntu 13.04 from scratch, but it didn't help.

    I read several forum threads on similar problems, but am unable to find a solution. Please note that my command line knowledge is really bad.

    I ran some of the commands that had been recommended to see what the feedback looks like, and here they are "ifconfig", "route -n" and "ping google.com":

    Code:
    steven@steven-GM5091H:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:16:76:26:70:08  
              inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::216:76ff:fe26:7008/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:7874639 errors:0 dropped:0 overruns:0 frame:0
              TX packets:5246751 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:2014873843 (2.0 GB)  TX bytes:2402127989 (2.4 GB)
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:56222 errors:0 dropped:0 overruns:0 frame:0
              TX packets:56222 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:4171759 (4.1 MB)  TX bytes:4171759 (4.1 MB)
    Code:
    steven@steven-GM5091H:~$ route -n
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 eth0
    169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
    192.168.0.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
    steven@steven-GM5091H:~$
    Code:
    steven@steven-GM5091H:~$ ping google.com
    ping: unknown host google.com
    steven@steven-GM5091H:~$
    Until 2 weeks ago, I had perfect internet connection, and my other computers still connect no problem, so I don't think it's a hardware issue, but I'm at a loss. Has anyone seen this before, and perhaps know what's wrong? Thank you so much!
    Last edited by Iowan; October 13th, 2013 at 07:31 PM. Reason: added [code] tags

  2. #2
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: Connect to network, but no internet

    Useful first steps. Next steps:

    Code:
    traceroute -n 8.8.8.8
    mtr -nrc2 8.8.8.8
    Post the output here.

  3. #3
    Join Date
    Oct 2013
    Beans
    10

    Re: Connect to network, but no internet

    traceroute -n 8.8.8.8 command gave the following output:

    Code:
    steven@steven-GM5091H:~$ traceroute -n 8.8.8.8
    The program 'traceroute' can be found in the following packages:
     * inetutils-traceroute
     * traceroute
    Try: sudo apt-get install <selected package>
    steven@steven-GM5091H:~$

    mtr -nrc2 8.8.8.8 command gave the following output

    Code:
    steven@steven-GM5091H:~$ traceroute -n 8.8.8.8
    The program 'traceroute' can be found in the following packages:
     * inetutils-traceroute
     * traceroute
    Try: sudo apt-get install <selected package>
    steven@steven-GM5091H:~$
    Last edited by Iowan; October 13th, 2013 at 07:31 PM. Reason: added [code] tags

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Connect to network, but no internet

    Quote Originally Posted by stevenpmacneil View Post
    The program 'traceroute' can be found in the following packages:
    * inetutils-traceroute
    * traceroute
    ..please do what those messages suggested -
    Code:
    sudo apt-get install traceroute
    ..then try again what sanderj asked for and post back the results.

    PS:
    And it would be better to use 'Code' box to post commands & terminal outputs instead of manually formatting them. Please follow the "Using Code Tags" link in my signature to see how.
    Last edited by varunendra; October 13th, 2013 at 06:34 PM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #5
    Join Date
    Oct 2013
    Beans
    10

    Re: Connect to network, but no internet

    Thank you for the input, I have much to learn. I ran the command sudo apt-get install traceroute and got the following output:

    Code:
      steven@steven-GM5091H:~$ sudo apt-get install traceroute
    [sudo] password for steven: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package traceroute is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    
    E: Package 'traceroute' has no installation candidate
    steven@steven-GM5091H:~$ 
    

    Thank you for the help!

  6. #6
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Connect to network, but no internet

    Hmm.. make sure the "Universe" repository is enabled in Software Soruces -

    Press Alt+F2 > type software-properties-gtk > press Enter or click the item that comes up > Supply your login password when asked > under "Ubuntu Software" tab in the opened box, make sure the (universe) repository is enabled (has a tick in the checkbox) > Close it and in a terminal, do -
    Code:
    sudo apt-get update
    sudo apt-get install traceroute
    Let me know if having any difficulty again.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  7. #7
    Join Date
    Oct 2013
    Beans
    10

    Re: Connect to network, but no internet

    I opened this GTK software properties window as instructed above, and under the "Ubuntu Software" tab,the option for the universe repository is already selected. Since my Ubuntu computer can't connect to the internet, I'm guessing that it can't connect to the universe repository to get and install the traceroute package. I'd really appreciate any ideas. Thanks!

  8. #8
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,485

    Re: Connect to network, but no internet

    When you live-boot from CD or USB stick, is Internet working?

    We're talking your *wired* ethernet connection, I hope? Not wireless?
    And: hopefull no firewall installed?

  9. #9
    Join Date
    Oct 2013
    Beans
    10

    Re: Connect to network, but no internet

    Hi, that's correct.
    1) My Ubuntu is connected via a wired ethernet connection
    2) When I use the "try Ubuntu" option on the live DVD, I can't get onto the internet. Firefox responds with "server not found". However, in both my installed O/S and in the DVD "try Ubuntu" mode, I can open the "files" icon, and "browse network" and access the other computers and network drives in the house.
    3) I don't have a firewall.

    Thanks!

  10. #10
    Join Date
    Nov 2008
    Location
    S.H.I.E.L.D. 6-1-6
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Connect to network, but no internet

    Whats the output of
    Code:
    ping -c 10 8.8.8.8
    cat /etc/resolv.conf
    Don't waste your energy trying to change opinions ... Do your thing, and don't care if they like it.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •