Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Dual boot Machine dropping connection only on Ubuntu. DHCP?

  1. #1
    Join Date
    Oct 2013
    Beans
    30
    Distro
    Ubuntu 14.04 Trusty Tahr

    Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Here are the facts:
    Despite that my computer is literally 5 feet away from my router, I get periodic disconnects. Also, most of the time my wifi icon reads 3 out of 4 bars. I run a 3rd party VPN, and although the disconnect is for only a second, I lose my vpn connection. This causes me to have to monitor my icon to make sure there was no drop. I'll mention now that I also lose connection while on clean , non VPN connection. I watch the wifi icon constantly fluctuating.
    Before I go any further I'll mention that I am on a Toshiba Satellite L755. I am running dual boot Operating systems, Windows 7 and Ubuntu 12.04 LTS. I have already sent a log to my VPN server who shows that there are no errors on their end. Plus, I'm not always connected through vpn, yet I still get a popup saying "disconnected". Also, I have no issue with droped connections while running Windows7 on this machine.
    So for the past week, I have been trying everything and anything that comes up in my search. It's worth saying that I am doing these things blindly, and have no idea if they actually pertain to my issue, but since it was suggested to other users with similar problems, I tried it. Here's what I've tried so far that has not worked:
    When I command `sudo lspci` it shows that my network controller is


    Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)


    It was suggested somewhere that I try `sudo iwconfig wlan0 power off`
    To which I get this:


    "Error for wireless request "Set Power Management" (8B2C) : SET failed on device wlan0 ; Operation not supported". Whether this has anything to do with my problem, I have no idea.


    It was suggested I go into "System Settings>Additional Drivers and I found :


    "No proprietary drivers are in use on this system"


    I found alot of common answers were based on the fact that my driver , Realtek , does not play well or work with Ubuntu. It was suggested on similar threads to download a new driver. Here are the steps I followed.
    `sudo apt-get install gcc build-essential linux-headers-generic linux-headers-$(uname -r)`
    for necessary dependencies


    1) Download driver from :realtek website
    `http://152.104.125.41/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level= 5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true #2722`
    and copy it to your desktop (it's about 12 MB download).


    2) Right-click the downloaded file (linux_mac80211_0012.0207.2013.tar.bz2) > "Extract here". This will extract a folder named "rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211 _001 2.0207.2013" on your desktop.


    3) Open a terminal (Ctrl+Alt+T) and run following commands :
    Code:


    cd ~/Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012 .0207.2013
    make
    sudo make install


    4) Reboot or manually load the driver with -
    Code:


    sudo modprobe -v rtl8188ee


    After doing this, nothing changed. I restarted the computer, and still had the same issues.
    I mention that after doing step 3 above, I get a long scroll of activity, but there a number of error messages: ![error after install][2]


    It is at this point that I get help to my question, and was told to try this:


    """"First, let's clean up the file from your first attempt:


    cd Desktop/rtl_92ce_92se_92de_8723ae_88ee_linux_mac80211_0012 .0207.2013
    make clean


    Now, let's modify one file:


    gedit pci.h


    At the top of the file,after the comment section all out lined in **, add this sequence:


    #ifndef __devinit
    #define __devinit
    #define __devinitdata
    #endif




    Proofread carefully, save and close gedit. Now do:


    make
    sudo make install


    Finally, I believe the driver you need is rtl8192ce and not rtl8188ee:


    sudo modprobe rtl8192ce


    Your wireless should now be working"""".






    AT first, I noticed that I had 4 bars in wifi(instead of 3) Apparently there is no other way to see if what I did actually worked though. It wasn't until yesterday that I noticed that the disconnection problem still persisted. So far while typing this question, my signal has dropped twice. At this point, I've tried everything in all the threads that I could find. I don't know where to go next. ANY HELP?


    Here, I confirm driver by entering:

    lsmod | grep rtl


    My Results:


    rtl8192ce 141806 0
    rtlwifi 123323 1 rtl8192ce
    mac80211 630977 2 rtl8192ce,rtlwifi
    cfg80211 525326 2 rtlwifi,mac80211

    ALSO, Whether or not my Power Management is ON or OFF by running:


    iwconfig | grep Power


    My Results:


    tun0 no wireless extensions.

    eth0 no wireless extensions.

    lo no wireless extensions.

    Bit Rate=72.2 Mb/s Tx-Power=20 dBm
    Power Management:off


    ALSO I took the liberty of running:


    lspci -nn | grep 0280


    My Results:


    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)


    FURTHER EDITS: Within 5 minutes after disconnect I run this:


    ~$ cat /var/log/syslog | grep -e etwork -e wlan | tail -n20


    MY RESULTS:





    Oct 9 18:49:57 Mike-Ubuntu12 kernel: [ 6452.055962] wlan0: RX AssocResp from 58:6d:8f:89:14:46 (capab=0x11 status=0 aid=3)
    Oct 9 18:49:57 Mike-Ubuntu12 kernel: [ 6452.056232] wlan0: associated
    Oct 9 18:49:57 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: authenticating -> associated
    Oct 9 18:49:57 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
    Oct 9 18:49:57 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
    Oct 9 18:51:42 Mike-Ubuntu12 kernel: [ 6557.222852] wlan0: Connection to AP 58:6d:8f:89:14:46 lost
    Oct 9 18:51:42 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: completed -> disconnected
    Oct 9 18:51:42 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): roamed from BSSID 58:6D:8F:89:14:46 (HighMoon) to (none) ((none))
    Oct 9 18:51:42 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: disconnected -> scanning
    Oct 9 18:51:43 Mike-Ubuntu12 kernel: [ 6558.171237] wlan0: authenticate with 58:6d:8f:89:14:46
    Oct 9 18:51:43 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: scanning -> authenticating
    Oct 9 18:51:43 Mike-Ubuntu12 kernel: [ 6558.190989] wlan0: send auth to 58:6d:8f:89:14:46 (try 1/3)
    Oct 9 18:51:43 Mike-Ubuntu12 kernel: [ 6558.192747] wlan0: authenticated
    Oct 9 18:51:43 Mike-Ubuntu12 kernel: [ 6558.194187] wlan0: associate with 58:6d:8f:89:14:46 (try 1/3)
    Oct 9 18:51:43 Mike-Ubuntu12 kernel: [ 6558.197471] wlan0: RX AssocResp from 58:6d:8f:89:14:46 (capab=0x11 status=0 aid=3)
    Oct 9 18:51:43 Mike-Ubuntu12 kernel: [ 6558.197782] wlan0: associated
    Oct 9 18:51:43 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: authenticating -> associated
    Oct 9 18:51:43 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake
    Oct 9 18:51:43 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
    Oct 9 18:51:48 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): roamed from BSSID (none) ((none)) to 58:6D:8F:89:14:46 (HighMoon)






    I tried $ `iwconfig wlan0` WHILE I WAS ON NORMAL /NON VPN CONNECTION. My Results:




    wlan0 IEEE 802.11bgn ESSID:"HighMoon"
    Mode:Managed Frequency:2.437 GHz Access Point: 58:6D:8F:89:14:46
    Bit Rate=7.2 Mb/s Tx-Power=20 dBm
    Retry long limit:7 RTS thr=2347 B Fragment thr:off
    Power Management:off
    Link Quality=70/70 Signal level=-22 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:11 Missed beacon:


    WHILE RUNNING CLEAN/NO VPN , MY COMPUTER DISCONNECTED. Here is the readout directly after the disconnect.


    I Run: `~$ cat /var/log/syslog | grep -e etwork -e wlan | tail -n20`


    interface wlan0.IPv4 with address 192.168.1.116.
    Oct 10 18:19:08 Mike-Ubuntu12 avahi-daemon[959]: New relevant interface wlan0.IPv4 for mDNS.
    Oct 10 18:19:08 Mike-Ubuntu12 avahi-daemon[959]: Registering new address record for 192.168.1.116 on wlan0.IPv4.
    Oct 10 18:19:08 Mike-Ubuntu12 dhclient: XMT: Info-Request on wlan0, interval 930ms.
    Oct 10 18:19:09 Mike-Ubuntu12 NetworkManager[970]: <info> (wlan0): writing resolv.conf to /sbin/resolvconf
    Oct 10 18:19:09 Mike-Ubuntu12 NetworkManager[970]: <info> (wlan0): device state change: ip-config -> activated (reason 'none') [70 100 0]
    Oct 10 18:19:09 Mike-Ubuntu12 NetworkManager[970]: <info> Policy set 'HighMoon' (wlan0) as default for IPv4 routing and DNS.
    Oct 10 18:19:09 Mike-Ubuntu12 NetworkManager[970]: <info> Activation (wlan0) successful, device activated.
    Oct 10 18:19:09 Mike-Ubuntu12 NetworkManager[970]: <info> Activation (wlan0) Stage 5 of 5 (IPv4 Commit) complete.
    Oct 10 18:19:09 Mike-Ubuntu12 dhclient: XMT: Info-Request on wlan0, interval 1800ms.
    Oct 10 18:19:11 Mike-Ubuntu12 dhclient: XMT: Info-Request on wlan0, interval 3510ms.
    Oct 10 18:19:15 Mike-Ubuntu12 dhclient: XMT: Info-Request on wlan0, interval 7250ms.
    mike@

    Can anyone help me?
    Here is the original thread on AskUbuntu : http://askubuntu.com/questions/35558...i-could-find-o

  2. #2
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    First off, Welcome to the forums Mike !

    I see you were already being assisted by the best person here, chili555. Looks like you added this info 'After' his last comment on you askubuntu post (because he can't miss it) -
    Quote Originally Posted by Mike1977 View Post
    Oct 9 18:49:57 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
    Oct 9 18:51:42 Mike-Ubuntu12 kernel: [ 6557.222852] wlan0: Connection to AP 58:6d:8f:89:14:46 lost
    Oct 9 18:51:42 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: completed -> disconnected
    Oct 9 18:51:42 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): roamed from BSSID 58:6D:8F:89:14:46 (HighMoon) to (none) ((none))
    ....
    ....
    Oct 9 18:51:43 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
    Oct 9 18:51:48 Mike-Ubuntu12 NetworkManager[975]: <info> (wlan0): roamed from BSSID (none) ((none)) to 58:6D:8F:89:14:46 (HighMoon)
    Accordingly, I'd suggest to save your access-point's MAC address (58:6D:8F:89:14:46) in the "BSSID" field in the connection settings in Network Manager, like the screenshot below -



    Save and close the settings and retry to connect. If it still drops out, please follow the "Wireless Script" link in my signature, download and run the script as per instructions there, and post back the report it generates.

    PS:
    Oh, and you should use 'Code' tags to post the output parts. It preserves its formatting and makes the post compact and more readable
    Please follow the "Using Code Tags" link in my signature below to see how to use it.
    Attached Images Attached Images
    Last edited by varunendra; October 13th, 2013 at 01:32 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  3. #3
    Join Date
    Nov 2012
    Beans
    8

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Wow.. No I know this for my new install!. That was so irritating!

  4. #4
    Join Date
    Oct 2013
    Beans
    30
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Thanks Varunendra. I had a feeling I was typing in wrong format.I apologize for that long, run on question Anyways, I'm having a problem opening the Network Manager, to enter the BSSID. I'm typing
    nm-connection-editor
    in Terminal, but I'm not getting any option to edit anything. What am I doing wrong? Thanks

  5. #5
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Quote Originally Posted by Mike1977 View Post
    ..I'm having a problem opening the Network Manager, to enter the BSSID. I'm typing in Terminal..
    Not in terminal, it has to be entered in the GUI of Network Manager. If you are using default version of Ubuntu, look at the top right corner for this icon -



    Click on it to produce the drop-down menu > click "Edit Connections" > goto "Wireless" tab > double-click your connection to edit it > locate the BSSID field under "Wireless" tab > Enter your Access-Point's MAC address in the "BSSID" field > Save > Close and done !

    If you are using a different desktop environment than Unity, find the option to edit the network connections from menu, tray or wherever it is located.

    Try it, and let us all know if it works as expected for you too.
    Attached Images Attached Images
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  6. #6
    Join Date
    Oct 2013
    Beans
    30
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Thanks Varunendra,
    I have not been on Ubuntu too much this past weekend, but I have changed the BBSID number in the field ( the field was blank before). I just connected today today, and although I have not had any disconnects in the past 20 minutes, I am already seeing that the wifi icon is fluctuating. Sometimes to no bars(yet staying connected, apparently) Should I wait until it disconnects before I run the "wireless script" in your signature? Or is there another step to try? Thanks.
    EDIT: 5 MINUTES LATER AND IT DISCONNECTED. I'll post the results below.
    Last edited by Mike1977; October 14th, 2013 at 09:52 PM.

  7. #7
    Join Date
    Oct 2013
    Beans
    30
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Code:
    #
    *************** info trace ***************
    
    ***** uname -a *****
    
    Linux Mike-Ubuntu12 3.8.0-31-generic #46~precise1-Ubuntu SMP Wed Sep 11 18:21:16 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
    
    ***** lsb_release *****
    
    Distributor ID:    Ubuntu
    Description:    Ubuntu 12.04.3 LTS
    Release:    12.04
    Codename:    precise
    
    ***** lspci *****
    
    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
        Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8181]
        Kernel driver in use: rtl8192ce
    --
    03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
        Subsystem: Toshiba America Info Systems Device [1179:fc50]
        Kernel driver in use: atl1c
    
    ***** lsusb *****
    
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 04f2:b289 Chicony Electronics Co., Ltd 
    
    ***** PCMCIA Card Info *****
    
    
    ***** iwconfig *****
    
    wlan0     IEEE 802.11bgn  ESSID:"HighMoon"  
              Mode:Managed  Frequency:2.412 GHz  Access Point: <MAC address removed>   
              Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
              Power Management:off
              Link Quality=70/70  Signal level=-28 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    
    ***** rfkill *****
    
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    
    ***** lsmod *****
    
    rtl8192ce             141806  0 
    rtlwifi               123323  1 rtl8192ce
    mac80211              630977  2 rtl8192ce,rtlwifi
    cfg80211              525326  2 rtlwifi,mac80211
    
    ***** nm-tool *****
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            atl1c
      State:             unavailable
      Default:           no
      HW Address:        <MAC address removed>
    
      Capabilities:
        Carrier Detect:  yes
    
      Wired Properties
        Carrier:         off
    
    
    - Device: wlan0  [HighMoon] ----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            rtl8192ce
      State:             connected
      Default:           yes
      HW Address:        <MAC address removed>
    
      Capabilities:
        Speed:           7 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        mccoy:           Infra, <MAC address removed>, Freq 2412 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
        Kenny:           Infra, <MAC address removed>, Freq 2462 MHz, Rate 54 Mb/s, Strength 100 WPA WPA2
        HighMoon-guest:  Infra, <MAC address removed>, Freq 2412 MHz, Rate 54 Mb/s, Strength 100
        *HighMoon:       Infra, <MAC address removed>, Freq 2412 MHz, Rate 54 Mb/s, Strength 94 WPA WPA2
        NETGEAR50:       Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA2
    
      IPv4 Settings:
        Address:         192.168.1.116
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.1.1
    
        DNS:             75.75.76.76
        DNS:             75.75.75.75
        DNS:             192.168.1.1
    
    
    
    ***** NetworkManager.state *****
    
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true
    
    ***** NetworkManager.conf *****
    
    [main]
    plugins=ifupdown,keyfile
    dns=dnsmasq
    
    [ifupdown]
    managed=false
    
    ***** interfaces *****
    
    auto lo
    iface lo inet loopback
    
    
    ***** iwlist *****
    
    wlan0     Scan completed :
              Cell 01 - Address: <MAC address removed>
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=70/70  Signal level=-36 dBm  
                        Encryption key:on
                        ESSID:"HighMoon"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000000000000000
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 0008486967684D6F6F6E
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D1601081500000000000000000000000000000000000000
                        IE: Unknown: DD810050F204104A00011010440001021041000100103B0001031047001002519461683B1AF5B2843176671BB6DB102100074C696E6B7379731023000D4C696E6B7379732045343230301024000776312E302E30321042000234321054000800060050F20400011011000D4C696E6B737973204534323030100800020084103C000103
                        IE: Unknown: DD090010180203F02C0000
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 02 - Address: <MAC address removed>
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=70/70  Signal level=-32 dBm  
                        Encryption key:off
                        ESSID:"HighMoon-guest"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000000000000000
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 000E486967684D6F6F6E2D6775657374
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D1601081100000000000000000000000000000000000000
                        IE: Unknown: DD090010180200F02C0000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 03 - Address: <MAC address removed>
                        Channel:1
                        Frequency:2.412 GHz (Channel 1)
                        Quality=32/70  Signal level=-78 dBm  
                        Encryption key:on
                        ESSID:"mccoy"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=00000015ec45a872
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 00056D63636F79
                        IE: Unknown: 010882848B962430486C
                        IE: Unknown: 030101
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: DD090010180203F0000000
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : CCMP TKIP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 04 - Address: <MAC address removed>
                        Channel:6
                        Frequency:2.437 GHz (Channel 6)
                        Quality=30/70  Signal level=-80 dBm  
                        Encryption key:on
                        ESSID:"NETGEAR50"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                                  24 Mb/s; 36 Mb/s; 54 Mb/s
                        Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                        Mode:Master
                        Extra:tsf=0000028a43ae501c
                        Extra: Last beacon: 60ms ago
                        IE: Unknown: 00094E4554474541523530
                        IE: Unknown: 010882840B162430486C
                        IE: Unknown: 030106
                        IE: Unknown: 2A0100
                        IE: Unknown: 2F0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32040C121860
                        IE: Unknown: 2D1AFC181FFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D1606081500000000000000000000000000000000000000
                        IE: Unknown: 4A0E14000A002C01C800140005001900
                        IE: Unknown: 7F0101
                        IE: Unknown: DD7F0050F204104A0001101044000102103B00010310470010620A080DB957EB4BE3B0A59CD15F81E21021000D4E4554474541522C20496E632E1023000A574E44523334303076321024000A574E44523334303076321042000230311054000800060050F20400011011000A574E4452333430307632100800020004103C000103
                        IE: Unknown: DD090010180201F0040000
                        IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
              Cell 05 - Address: <MAC address removed>
                        Channel:11
                        Frequency:2.462 GHz (Channel 11)
                        Quality=28/70  Signal level=-82 dBm  
                        Encryption key:on
                        ESSID:"Kenny"
                        Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                                  9 Mb/s; 12 Mb/s; 18 Mb/s
                        Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                        Mode:Master
                        Extra:tsf=0000002eb5931180
                        Extra: Last beacon: 296ms ago
                        IE: Unknown: 00054B656E6E79
                        IE: Unknown: 010882848B960C121824
                        IE: Unknown: 03010B
                        IE: Unknown: 050400010000
                        IE: Unknown: 200100
                        IE: Unknown: 2A0100
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: WPA Version 1
                            Group Cipher : CCMP
                            Pairwise Ciphers (1) : CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: 32043048606C
                        IE: Unknown: DD180050F2020101040003A4000027A4000042435E0062322F00
                        IE: Unknown: 2D1A8C131BFFFF000000000000000000000000000000000000000000
                        IE: Unknown: 3D160B080800000000000000000000000000000000000000
                        IE: Unknown: DD0900037F01010000FF7F
                        IE: Unknown: DD0A00037F04010000000000
                        IE: Unknown: 0706555320010B1B
    
    
    ***** resolv.conf *****
    
    nameserver 127.0.0.1
    search hsd1.pa.comcast.net
    
    ***** blacklist *****
    
    [/etc/modprobe.d/blacklist-ath_pci.conf]
    blacklist ath_pci
    
    [/etc/modprobe.d/blacklist.conf]
    blacklist evbug
    blacklist usbmouse
    blacklist usbkbd
    blacklist eepro100
    blacklist de4x5
    blacklist eth1394
    blacklist snd_intel8x0m
    blacklist snd_aw2
    blacklist i2c_i801
    blacklist prism54
    blacklist bcm43xx
    blacklist garmin_gps
    blacklist asus_acpi
    blacklist snd_pcsp
    blacklist pcspkr
    blacklist amd76x_edac
    
    ***** modinfo *****
    
    filename:       /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
    firmware:       rtlwifi/rtl8192cfw.bin
    description:    Realtek 8192C/8188C 802.11n PCI wireless
    license:        GPL
    author:         Larry Finger    <Larry.Finger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         lizhaoming    <chaoming_li@realsil.com.cn>
    srcversion:     8371CA3A9E899B11125FFDE
    alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
    alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
    alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
    alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
    depends:        rtlwifi,mac80211
    vermagic:       3.8.0-31-generic SMP mod_unload modversions 
    parm:           swlps:bool
    parm:           swenc:using hardware crypto (default 0 [hardware])
     (bool)
    parm:           ips:using no link power save (default 1 is open)
     (bool)
    parm:           fwlps:using linked fw control power save (default 1 is open)
     (bool)
    
    filename:       /lib/modules/3.8.0-31-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
    description:    Realtek 802.11n PCI wireless core
    license:        GPL
    author:         Larry Finger    <Larry.FInger@lwfinger.net>
    author:         Realtek WlanFAE    <wlanfae@realtek.com>
    author:         lizhaoming    <chaoming_li@realsil.com.cn>
    srcversion:     C5BE23342E67ABA5ADA703E
    depends:        mac80211,cfg80211
    vermagic:       3.8.0-31-generic SMP mod_unload modversions 
    
    
    ***** udev rules *****
    
    # PCI device 0x1969:/sys/devices/pci0000:00/0000:00:1c.6/0000:03:00.0 (atl1c)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
    
    # PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0 (rtl8192ce)
    SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"
    
    ***** dmesg *****
    
    [   10.371170] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [   10.371388] rtlwifi: wireless switch is on
    [   18.839026] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   18.841035] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   23.155469] wlan0: authenticate with <MAC address removed>
    [   23.175505] wlan0: send auth to <MAC address removed> (try 1/3)
    [   23.177173] wlan0: authenticated
    [   23.178972] wlan0: associate with <MAC address removed> (try 1/3)
    [   23.182057] wlan0: RX AssocResp from <MAC address removed> (capab=0x11 status=0 aid=2)
    [   23.182291] wlan0: associated
    [   23.182298] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1169.464837] wlan0: deauthenticating from <MAC address removed> by local choice (reason=3)
    [ 1173.401798] wlan0: authenticate with <MAC address removed>
    [ 1173.420409] wlan0: send auth to <MAC address removed> (try 1/3)
    [ 1173.422026] wlan0: authenticated

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Quote Originally Posted by Mike1977 View Post
    Code:
    02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)
        Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8181]
        Kernel driver in use: rtl8192ce
    ....
        *HighMoon:       Infra, <MAC address removed>, Freq 2412 MHz, Rate 54 Mb/s, Strength 94 WPA WPA2
    ....
    wlan0     Scan completed :
              Cell 01 - Address: <MAC address removed>
               ....
                        ESSID:"HighMoon"
                        ....
                        IE: IEEE 802.11i/WPA2 Version 1
                            Group Cipher : TKIP
    First and foremost, please change the encryption type in the router from WPA/WPA2 mixed mode to pure WPA2-PSK (AES/CCMP) only. No mixed mode, no TKIP. Please refer to your router's user manual to see how to do that. Change it and reboot the router to make sure the new settings are effective.

    Then in Ubuntu, please try a few parameters with your driver as suggested in this post.

    Like mentioned in the above linked post, those parameters will be temporary and will be lost at next boot. If any of them could help stability, we'll make it permanent.

    To make them permanent, use the method in this post (ignore the initial part, read from "For example, to make the "swenc=1" option permanent.....").

    Please post back the progress and we can try other things if necessary.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  9. #9
    Join Date
    Oct 2013
    Beans
    30
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Could you give me a little clarification as to why I should change the settings in wireless security from "mixed mode" to Wpa2? From my reading, I see that my settings as they are now, are the most secure, and I don't have any connection issues while running Windows 7 on this laptop. So, I'm wondering, do I have have to make my wireless security more vulnerable just to be able to use Ubuntu? It is saying in many of the Cisco forums that Mixed mode is what I want. OR are you saying I have to change to a different setting in order to be able to run the parameters you provided?
    Also. I have two bands to change from mix mode. 5GHZ and 2.4GHZ.
    And the choices to select are:
    WPA2 personal, WPA Personal, WPA2/WPA enterprise mixed mode, WPA2 enterprise, WPA enterprise, wep, radius, and disable. My router is a Linksys E4200.
    Thanks Varunendra

  10. #10
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Dual boot Machine dropping connection only on Ubuntu. DHCP?

    Quote Originally Posted by Mike1977 View Post
    Could you give me a little clarification as to why I should change the settings in wireless security from "mixed mode" to Wpa2? From my reading, I see that my settings as they are now, are the most secure, and I don't have any connection issues while running Windows 7 on this laptop. So, I'm wondering, do I have have to make my wireless security more vulnerable just to be able to use Ubuntu? It is saying in many of the Cisco forums that Mixed mode is what I want.
    I'm glad you brought it up. If you are concerned about enhanced security, then No, the mixed mode you are currently using is certainly NOT what you want. I'll very happily share the details why -

    The most advanced and most secure encryption protocol is WPA2, and the most secure (and probably the most efficient too at the same time) encryption algorithm is AES which is the base of CCMP.

    The most outdated and most insecure encryption protocol (for wifi) is WEP, and WPA (not WPA2) is not much different from it and uses the weak and very inefficient encryption algorithm TKIP. TKIP is not only weak, but is inefficient too, thus severely limiting the throughput on the device (you can't go above 54 Mb/s with TKIP).

    So the WPA/WPA2 mixed mode is used for backward compatibility purpose and the WPA-TKIP part of it is the vulnerable part. The only reason why one should use the mixed mode is if they have one of those ancient hardware which can't support the modern WPA2 (AES) encryption. Otherwise, just get rid of it.

    Some facts about these -

    WPA & WPA2 (http://en.wikipedia.org/wiki/Wi-Fi_Protected_Access) -
    WPA (sometimes referred to as the draft IEEE 802.11i standard) became available in 2003. The Wi-Fi Alliance intended it as an intermediate measure in anticipation of the availability of the more secure and complex WPA2.
    ....
    WPA uses a message integrity check algorithm called Michael to verify the integrity of the packets. Michael is much stronger than a CRC, but not as strong as the algorithm used in WPA2.
    ....
    WPA2 has replaced WPA. WPA2,.... In particular, it introduces CCMP, a new AES-based encryption mode with strong security.
    TKIP Vs AES or CCMP (http://en.wikipedia.org/wiki/CCMP#Security) -
    CCMP is the standard encryption protocol for use with the WPA2 standard and is much more secure than the WEP protocol and TKIP protocol of WPA.
    So clearly, it is the mixed mode that is not only inefficient, but is also more vulnerable compared to pure WPA2-PSK with AES.

    Now why windows 7 works nicely with it is obvious. All the hardware manufacturers keep windows as a standard while designing their hardware, and the same is true for the drivers they provide. Thus both the hardware and the driver are 'optimized' for windows and can take care of the added complexity caused by such inefficient combinations. Note here that the added 'complexity' is not adding any security here, on the contrary, is compromising it.

    Almost no hardware is specifically designed for Linux and most of the drivers are developed by the open source community, either by the "partially" disclosed information by the manufacturer, or reverse-engineering. Hence they are obviously not as efficient as the drivers designed by the manufacturers themselves and constantly being upgraded by them.

    But the capability of Open Source shines when it comes to stuff closer to real universal 'Standards' (not 'patches' to match a particular OS). Hence the Linux drivers can handle the WPA2-AES encryption much better than the mixed mode. Windows drivers should be able to handle all the available modes just fine, so you shouldn't notice any negative effect after changing the encryption. If anything, it will only be enhanced (due to getting rid of TKIP).

    OR are you saying I have to change to a different setting in order to be able to run the parameters you provided?
    The parameters I provided would work in any case, only they will work much better when the encryption type is optimized too. Please note that none of the parameters is 'guaranteed' to enhance the speed or connectivity, but most often they do.

    Also. I have two bands to change from mix mode. 5GHZ and 2.4GHZ.
    And the choices to select are:
    WPA2 personal, WPA Personal, WPA2/WPA enterprise mixed mode, WPA2 enterprise, WPA enterprise, wep, radius, and disable. My router is a Linksys E4200.
    The 5GHz band is still not well supported by many Linux drivers. I'm not sure if rtl8192ce can support it or not. So it is safer to disable the 5GHz mode, if none of the devices on your network are getting advantage of the extra speeds offered by it (300 Mb/s +). Either use 2.4 GHz only, or mixed mode.

    For encryption, WPA2 personal is what you want, with AES or CCMP being the encryption algorithm (or 'Ciphers').

    Hope it clears your doubts, and helps making the connection better.
    Last edited by varunendra; October 16th, 2013 at 02:08 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •