Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 'The following packages have unmet dependencies'

  1. #1
    Join Date
    Nov 2012
    Beans
    11

    'The following packages have unmet dependencies'

    Hi all ...

    I'm trying to install a new program on the computer but keep getting this error message.

    Any help would be much appreciated.

    With thanks in advance,

    Dane

    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies.
    kdenlive : Depends: kdenlive-data (= 0.9.2-2ubuntu1) but it is not going to be installed
    Recommends: swh-plugins but it is not going to be installed
    Recommends: dvgrab but it is not going to be installed
    Recommends: recordmydesktop but it is not going to be installed
    linux-image-extra-3.5.0-28-generic : Depends: linux-image-3.5.0-28-generic but it is not going to be installed
    linux-image-extra-3.5.0-30-generic : Depends: linux-image-3.5.0-30-generic but it is not going to be installed
    linux-image-extra-3.5.0-36-generic : Depends: linux-image-3.5.0-36-generic but it is not going to be installed
    linux-image-extra-3.5.0-41-generic : Depends: linux-image-3.5.0-41-generic but it is not going to be installed
    linux-image-generic : Depends: linux-image-3.5.0-28-generic but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

  2. #2
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,996

    Re: Problem with installing software

    You might want to run 'apt-get -f install' to correct these:
    The command is:

    Code:
    sudo apt-get -f install
    If your not familiar with terminal

    https://help.ubuntu.com/community/Us...ing_a_Terminal
    Last edited by ibjsb4; October 8th, 2013 at 02:16 PM.

  3. #3
    Join Date
    Nov 2012
    Beans
    11

    Re: Problem with installing software

    Many thanks for this. It seemed to be working but returned this error message at end.

    " Errors were encountered while processing: /var/cache/apt/archives/linux-image-3.5.0-28-generic_3.5.0-28.48_amd64.deb
    /var/cache/apt/archives/linux-image-3.5.0-30-generic_3.5.0-30.51_amd64.deb
    /var/cache/apt/archives/linux-image-3.5.0-36-generic_3.5.0-36.57_amd64.deb
    /var/cache/apt/archives/linux-image-3.5.0-41-generic_3.5.0-41.64_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Any advice would be greatly appreciated again!

  4. #4
    ibjsb4 is offline Ubuntu addict and loving it
    Join Date
    Sep 2012
    Beans
    4,996

    Re: 'The following packages have unmet dependencies'

    Try a house cleaning.

    Code:
    sudo -i
    apt-get clean
    cd /var/lib/apt
    mv lists lists.old
    mkdir -p lists/partial
    apt-get clean
    apt-get update
    exit

  5. #5
    Join Date
    Nov 2012
    Beans
    11

    Re: 'The following packages have unmet dependencies'

    Thanks so much for your help. It seemed to work and ended with this message:

    W: Duplicate sources.list entry http://dl.google.com/linux/talkplugin/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_talkplugin_deb_dists_stable_ma in_binary-amd64_Packages)
    W: Duplicate sources.list entry http://dl.google.com/linux/talkplugin/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_talkplugin_deb_dists_stable_ma in_binary-i386_Packages)
    W: You may want to run apt-get update to correct these problems

    I am still trying to install software and get the following messge now:

    The package system is broken.

    If you are using third party repositories then disable them, since they are a common source of problems.
    Now run the following command in a terminal: apt-get install -f

    Details:

    The following packages have unmet dependencies:


    linux-image-extra-3.5.0-28-generic: Depends: linux-image-3.5.0-28-generic but it is not installed
    linux-image-extra-3.5.0-30-generic: Depends: linux-image-3.5.0-30-generic but it is not installed
    linux-image-extra-3.5.0-36-generic: Depends: linux-image-3.5.0-36-generic but it is not installed
    linux-image-extra-3.5.0-41-generic: Depends: linux-image-3.5.0-41-generic but it is not installed
    linux-image-generic: Depends: linux-image-3.5.0-28-generic but it is not installed


    I've tried to run the command but receive the message:

    E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

  6. #6
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    12,487
    Distro
    Lubuntu 17.10 Artful Aardvark

    Re: 'The following packages have unmet dependencies'

    Quote Originally Posted by daneandrewlam View Post
    are you root?
    It tries to tell you something...
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  7. #7
    Join Date
    Nov 2012
    Beans
    11

    Re: 'The following packages have unmet dependencies'

    Quote Originally Posted by mrgs View Post
    It tries to tell you something...
    What exactly it's trying to tell me is lost on me ...

  8. #8
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    12,487
    Distro
    Lubuntu 17.10 Artful Aardvark

    Re: 'The following packages have unmet dependencies'

    You grant yourself temporary root privileges by adding sudo in front of the command.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

  9. #9
    Join Date
    Nov 2012
    Beans
    11

    Re: 'The following packages have unmet dependencies'

    Ahhh.... thanks!

    Quote Originally Posted by mrgs View Post
    You grant yourself temporary root privileges by adding sudo in front of the command.

  10. #10
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    12,487
    Distro
    Lubuntu 17.10 Artful Aardvark

    Re: 'The following packages have unmet dependencies'

    You are welcome.
    If this solves your problem please mark the thread so.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •