I tried to install Ubuntu 13.04 alongside Windows 7 on my HP laptop today. All was well, until I rebooted and was greeted with a command line called grub rescue, saying no such device. I know this issue has been posted before, but none of their answers have helped. I know that the install was going to be interesting, as my laptop has two hard drives, a 32GB SSD called the 'OS', and I think its running Intel's RAID. Then the other harddrive is for personal stuff.
I was able to run the live usb again and follow some tutorials to reinstall grub, and run the boot-fixer program with apparent success, untill I reboot and found myself in the grub rescue command line. Ive also tried to run a windows recovery disk, but it doesnt work (Gets stuck on "Start Boot from usb")
One more thing, I noticed that the partitons are seperated like so...
dev/sda (i think) Windows
dev/sdb (i think) Ubuntu
-sdb1 This one I think is the problem, as it says its a 'OS/2' Hidden C: Storage
-sdb5 This one (i think) is the main Ubuntu Drive
To sum up, basicly is there a thing I may have missed or something I havent tried yet that may get (at least) Windows going again and (if Im lucky) Ubuntu.
I dont have anything important on the Linux Partition.
Thanks heaps for your help,