Results 1 to 4 of 4

Thread: Black screen on bootup

  1. #1
    Join Date
    Sep 2010

    Black screen on bootup

    Hello everyone,

    I'm opening a new thread, similar to solved one:

    as I'm not the author and it doesn't work for me.

    When I boot my Toshiba satellite, I can hear the login bongos play, but can only see a black screen with my mouse cursor. I tried to put GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" in grub, but it worked only once.
    There is a strange thing : if I force the grub menu to display on boot, then choose "ubuntu" line, everything goes fine. So what is the difference ? There must be one as I have a black screen in a case, not in the other.

    And I don't know why this error appeared suddenly.
    Thanks everyone. Have a good day.


    PS : my ubuntu is 13.04 with last updates (I suspect one of theses updates to be responsible).
    Last edited by olipoh1; October 6th, 2013 at 08:10 AM.

  2. #2
    Join Date
    Apr 2012

    Re: Black screen on bootup (NOT SOLVED)

    Yes, It would appear mine also isn't fixed.. it takes a series of reboots for it to go.. acpi I'm guessing must be unrelated, and the changes I've made with acpi being a success must of just been by chance..

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Black screen on bootup (NOT SOLVED)

    There is this bug. But if it worked once.
    Any setting on grub menu as you boot is a one time change, more for testing. You have to edit /etc/default/grub and update grub to make it permanent.

    Intermittent black screen or low graphics mode message bug

    Also turn off one Video mode or Intel settings in UEFI/BIOS like Intel NIC if USB flash not working.
    Some Laptops need this in place of quiet splash:
    acpi_osi=Linux acpi_backlight=vendor
    Some laptops just have backlight set way down, press f key to make it brighter
    New Haswell systems may need newest kernel in currently beta 13.10 to support newest video
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #4
    Join Date
    Sep 2010

    Re: Black screen on bootup (NOT SOLVED)

    Thank you very much olfred. It helped me.

    I read the links you gave and I found 2 solutions :

    1. switch from lightdm to gdm

    2. then I came back to lightdm and tried something else. I pasted "sleep 1" between line 23 (script) and line 24 (if [ -n "$UPSTART_EVENTS" ]). It doesn't work for everybody, some will need to increase this time to 2 or more; as for me, it works. Oups, the file to edit is :

    Thanks again, and good luck to lama2p0 and others.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts