Results 1 to 7 of 7

Thread: Problem with apt-get update / SU and PPA on a beta release

  1. #1
    Join Date
    Oct 2013
    Location
    europe
    Beans
    155
    Distro
    Lubuntu Development Release

    Problem with apt-get update / SU and PPA on a beta release

    Hello there,

    everything works as it should except for this "little" thing.

    I need to fetch a package from the PPA repository (yes, it's lxkeymap where the bug-fixed version is still in staging and hasn't found its way after a year to the "official" reps) and I always get a 404 not found error.

    I know why it happens, since Software Updater does nothing much different from apt-get update.

    W: Failed to fetch

    http://ppa.launchpad.net/lubuntu-dev...-i386/Packages 404 Not Found

    E: Some index files failed to download. They have been ignored, or old ones used instead.

    This directory physically does not exist yet - I've checked it.
    But again, I know the way how to solve the problem, and that's by pointing the updater to:
    http://ppa.launchpad.net/lubuntu-dev...-i386/Packages

    But how can I do that (if at all)

  2. #2
    Join Date
    Jan 2009
    Location
    Belgium (Ghent)
    Beans
    481
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Problem with apt-get update / SU and PPA on a beta release

    So, you use 13.10.
    Open "Software & Update" via de Dash and click on the second tab.
    Below on the left you see a button with "Add" (I think, here is it in Dutch)
    Click on it and Copy/Paste de link in the box
    Code:
    http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/dists/saucy/main/binary-i386/Packages
    Than click "Add Source" and do than a update.
    Or change the link you already have.
    Or you wait till the next update of 13.10. It's not yet released, so tomorrow it maybe changed again.
    Succes!
    Last edited by heir4c; October 3rd, 2013 at 02:11 PM.
    Dutch speaking; understand English, writing is a bit difficult. Member of: http://forum.ubuntu-nl.org
    be Open be Free be Ubuntu Reg. User #485479
    Ubuntu 13.10 Saucy Salamander - Ubuntu 14.04 Trusty Tahr

  3. #3
    Join Date
    Oct 2013
    Location
    europe
    Beans
    155
    Distro
    Lubuntu Development Release

    Re: Problem with apt-get update / SU and PPA on a beta release

    Quote Originally Posted by heir4c View Post
    Or change the link you already have.
    YES! This was the right pointer. In Software Updater, this link can be edited. And then it works. Hooray!
    Careful though, the fix you proposed will not work for Software Updater.
    You would have to specify a way shorter URL:

    Code:
    http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu
    The actual culprit for that though is aptitude with its non-ability to set 'daily' URLs.
    I've run into this by typing

    Code:
    sudo add-apt-repository ppa:lubuntu-dev/staging
    It would probably be no big deal to include a checking mechanism "Are we final?" and if not, we will just go looking on the 'lubuntu-daily' branch, adapt the URL accordingly for the Updater - and avoid running into 404s.
    Last edited by syntaxerror74; October 3rd, 2013 at 05:06 PM.

  4. #4
    Join Date
    Jan 2009
    Location
    Belgium (Ghent)
    Beans
    481
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Problem with apt-get update / SU and PPA on a beta release

    Good that it works!
    And ThanX for posting your way to solve the problem.

    It would probably be no big deal to include a checking mechanism "Are we final?" and if not, we will just go looking on the 'lubuntu-daily' branch, adapt the URL accordingly for the Updater - and avoid running into 404s.
    You will use a -dev packages and it's a ppa: So, I'm not a expert or developer, but that's logic, there are no stable or finished.

    One more question: Am I right you use 13.10?
    Last edited by heir4c; October 3rd, 2013 at 05:39 PM.
    Dutch speaking; understand English, writing is a bit difficult. Member of: http://forum.ubuntu-nl.org
    be Open be Free be Ubuntu Reg. User #485479
    Ubuntu 13.10 Saucy Salamander - Ubuntu 14.04 Trusty Tahr

  5. #5
    Join Date
    Nov 2008
    Location
    S.H.I.E.L.D. 6-1-6
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Problem with apt-get update / SU and PPA on a beta release

    moved to Ubuntu+1

    Please ask for help on unreleased versions of Ubuntu on the U+1 forums please.

    Thanks!
    Don't waste your energy trying to change opinions ... Do your thing, and don't care if they like it.

  6. #6
    Join Date
    Apr 2011
    Location
    Mystletainn Kick!
    Beans
    6,728
    Distro
    Ubuntu

    Re: Problem with apt-get update / SU and PPA on a beta release

    For what it's worth, from what I see there is no saucy version for that PPA.
    Hence the original errors.

    The newest I see is quantal.
    Splat Double Splat Triple Splat
    Earn Your Keep
    Don't mind me, I'm only passing through.
    Once in a blue moon, I'm actually helpful
    .

  7. #7
    Join Date
    Oct 2013
    Location
    europe
    Beans
    155
    Distro
    Lubuntu Development Release

    Re: Problem with apt-get update / SU and PPA on a beta release

    Quote Originally Posted by heir4c View Post
    One more question: Am I right you use 13.10?
    Absolutely! 13.10 beta 2 (final as it looks) to be exact.

    And you might even know why not 13.04: ONLY 13.10 ships with Firefox, and I just wanted to start browsing without doing any install stuff first. Since there were too many things to setup first (e. g. this annoyance that vi/vim is never set to non-compatible mode by default, so you will produce ugly A B C D letters in insert mode. With vi, the most important thing to work ARE the cursor keys. LOL.)
    Last edited by syntaxerror74; October 3rd, 2013 at 08:44 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •