Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: CJK text input candidate list not showing

  1. #11
    Join Date
    Jul 2010
    Beans
    145

    Re: CJK text input candidate list not showing

    Exactly my sentiment. I don't really give it a da*n about what input method I use as long as I can type in Chinese character (both simplified and traditional), and it is PINYIN-based. For all I'm concerned, it can be totally generic. The key issue is that it must work, and must be consistently working.

    However, in real life, the more popular the input method, the more developers will be attracted to its maintenance, and it will have a less chance of having devastating regression.

    In our machines, we typically have both ibus and fcitx installed. To add fcitx-sogoupinyin to your system, enter the following commands:

    sudo add-apt-repository ppa:fcitx-team/nightly

    sudo apt-get install fcitx-sogoupinyin

    Then go to the language support to select fcitx as your input method.

    You can also install other input engines (e.g., google pinyin, etc). I also like Google pinyin a lot. However, with ibus, I can't change Google pinyin's preference. I understand your frustrations!

  2. #12
    Join Date
    May 2007
    Beans
    12

    Re: CJK text input candidate list not showing

    just found workaround to the preference problem

    13.10 is still using ibus indeed. The problem with that is that the ibus-setup utility is not quite compatible to the updated ibus stack. Therefore, certain settings won't work. For instance adding a new input method (but a new IM can be added through the Text Entry applet in Settings application).

    Therefore, to access the preference setup for a specific input method, just add the input method via the utility anyway. Then just change the settings for the particular input method as desired. (you may want to remove the input method from list after changing the settings)

    Then in terminal, execute "ibus restart", and the new settings should be applied now

  3. #13
    Join Date
    Apr 2008
    Location
    New Zealand
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: CJK text input candidate list not showing

    I could not get ibus to work. I installed , SCIM anthy and use the settings | language support select input method "Scim anthy" then find the Scim anthy input method configuration tool ( on my system I installed nome-session-fallback (because unity sucks) so its on the menu "system tools | preferences | SCIM input method"). after loging out and back in again the trigger function was working. the little anthy screen pops up when active, space bar works for selecting kanji, F7 convert the hirokana to katakana. its all good.

    the EN or Ja icons (top right) --> text entry setting seems to only change a keyboard layout (remapping the keys) for example the + key gets mapped to ~ when Ja is active. There also a Japanese Kana layout that gives you the old style Japanese keyboard (not useful unless you have stickers for the keys or have the layout etched into your brain). the Ubuntu 12.10 everything still works, 13.10 they managed to break ibus totally.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •