I have a Lenovo Ideapad Y470 with a . Every time that I install the FGLRX driver through System Settings -> software Sources -> Additional Drivers, my window manager completely crashes after rebooting, and I receive a blank desktop. I can open a terminal window and load up applications if I want to, but no window manager. If I switch to Gnome, I can also get around.

I have also found that I have the exact same problem if I switch to Linux Mint and try to use Cinnamon, so I know that the problem is not Unity.

I've tried enable the nomodeset option in GRUB, but that does not seem to have an effect.

I tried a fresh install, first ran updates and installed linux-headers-generic, and then attempted to install the beta driver from AMD's website.

After rebooting, I received an error about xorg not being configured, and it asked me if I wanted to restore the default configuration, which I did.

Now, after reboot I just boot to the Ubuntu graphical login prompt followed by black screen. Not sure what to do...

Could this possibly have something to do with the hybrid Intel/AMD graphics that come with this laptop?