Results 1 to 2 of 2

Thread: Intel Pro Wireless 3945 ABG

  1. #1
    Join Date
    Sep 2013

    Angry Intel Pro Wireless 3945 ABG

    Intel Pro Wireless 3945 abg no gateway address after update.

    Running Ubuntu 12.10 and an update ran last Wednesday which stopped my network card from working properly. I could see my network card connect wirelessly with no problems. It showed connected, but when I attempted to access the internet or ping anything it wouldn't resolve. I ran an ifconfig to verify the card was assigned an IP from my local network 192.168.2.x, and it was. I ran route -n only to find that although the wireless card had an IP address, for some reason the gateway was not set properly.

    I plugged in via ethernet cable and tried to report the bug yesterday several times but each time it locked up on me, so I decided to just delete the partition and reload with 12.04 LTS. Of course now I have to go about installing samba, my printers, etc once again.

    Is there a problem with updates? I am hesitant to download any updates now for fear of losing wireless. A laptop without wireless is kind of useless as a laptop.
    Last edited by joyce-nord; September 30th, 2013 at 02:17 PM.

  2. #2
    Join Date
    Nov 2008
    Metro Boston
    Kubuntu 14.04 Trusty Tahr

    Re: Intel Pro Wireless 3945 ABG

    There was a kernel update along the way in the 12.04 series that broke my Intel wireless as well. I reverted back to the previous kernel to solve the problem. The next kernel update fixed the problem entirely.

    I don't see much value in upgrading from 12.04 to 12.10. I've been running 13.04 after I bought an Android device since that is the first release with solid support for the MTP protocol that Android now uses to handle file transfers via USB. If I were going to upgrade from 12.04, I'd go to 13.04 or wait a couple of months and move to 13.10 after it has been released for a while. I expect to move to 14.04 next spring as it will be the next LTS release.

    (BTW, the "fragility" I mentioned about 13.04 in the linked post has largely gone away. The one persistent problem I have with audio is a KDE issue.)
    Last edited by SeijiSensei; September 30th, 2013 at 02:32 PM.
    If you ask for help, do not abandon your request. Please have the courtesy to check for responses and thank the people who helped you.

    Blog · Linode System Administration Guides · Android Apps for Ubuntu Users


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts